Jump to content
xt:Commerce Community Forum
Sign in to follow this  
totto

Problem Bei W?hrungsumrechnung

Recommended Posts

Hallo,

ich habe ein etwas gr??eres Problem, und komme nicht mehr weiter...

Im Shop werden zwei W?hrungen angeboten, EUR und US$. Soweit funktioniert das auch...

Wenn jedoch ein Kunde sich anmeldet, der in einer Gruppe ist, wo auf die Artikel ein Rabatt gew?hrt wird, wird bei der Umstellung der W?hrung diese nur bei solchen Artikeln der richtige Preis angezeigt, wenn diese Artikel als Sonderangebote deklariert sind (da gibt's ja eh keinen Rabatt mehr). Bei "normalen Artikeln" wird jedoch nur das EUR in US$ ge?ndert, der Preis ?ndert sich jedoch nicht... Es wird immer der Preis mit dem korrekten Rabatt des Kunden angezeigt, aber immer der EUR Wert...

Ich hab' schon ?berall geschaut, wo ich dachte, da k?nnte es dran liegen, nun bin ich aber mit meinem Latein am Ende...

Kann mir evtl. jemand weiterhelfen...???

Danke schon mal...!!!

Share this post


Link to post
Share on other sites
Guest gwinger

DAs ist eher ein Thema f?r mzanier, da hat er eigentlich den ?berblick. Preisklasse schonmal angeschaut?

Share this post


Link to post
Share on other sites

Originally posted by totto@Aug 5 2004, 13:52 PM

Hallo,

ich habe ein etwas gr??eres Problem, und komme nicht mehr weiter...

Im Shop werden zwei W?hrungen angeboten, EUR und US$. Soweit funktioniert das auch...

Wenn jedoch ein Kunde sich anmeldet, der in einer Gruppe ist, wo auf die Artikel ein Rabatt gew?hrt wird, wird bei der Umstellung der W?hrung diese nur bei solchen Artikeln der richtige Preis angezeigt, wenn diese Artikel als Sonderangebote deklariert sind (da gibt's ja eh keinen Rabatt mehr). Bei "normalen Artikeln" wird jedoch nur das EUR in US$ ge?ndert, der Preis ?ndert sich jedoch nicht... Es wird immer der Preis mit dem korrekten Rabatt des Kunden angezeigt, aber immer der EUR Wert...

Ich hab' schon ?berall geschaut, wo ich dachte, da k?nnte es dran liegen, nun bin ich aber mit meinem Latein am Ende...

Kann mir evtl. jemand weiterhelfen...???

Danke schon mal...!!!

Hallo

Das mit dem W?hrungsproblem habe ich schon ?fters dargelegt.

Es gibt auch Probleme mit den W?hrungen wenn Du mit Gutscheinen arbeitest, dort wirds dann auch falsch umgerechnet.

Aber wie es aussieht ist dies ein gr?sseres Problem oder hier arbeiten die Meisten nur mit 1 W?hrung, desshalb wird es auch nicht als so dringend erachtet , dieser Bug :D

Greets

Share this post


Link to post
Share on other sites

Originally posted by totto@Aug 5 2004, 14:52 PM

Hallo,

ich habe ein etwas gr??eres Problem, und komme nicht mehr weiter...

Im Shop werden zwei W?hrungen angeboten, EUR und US$. Soweit funktioniert das auch...

Wenn jedoch ein Kunde sich anmeldet, der in einer Gruppe ist, wo auf die Artikel ein Rabatt gew?hrt wird, wird bei der Umstellung der W?hrung diese nur bei solchen Artikeln der richtige Preis angezeigt, wenn diese Artikel als Sonderangebote deklariert sind (da gibt's ja eh keinen Rabatt mehr). Bei "normalen Artikeln" wird jedoch nur das EUR in US$ ge?ndert, der Preis ?ndert sich jedoch nicht... Es wird immer der Preis mit dem korrekten Rabatt des Kunden angezeigt, aber immer der EUR Wert...

Ich hab' schon ?berall geschaut, wo ich dachte, da k?nnte es dran liegen, nun bin ich aber mit meinem Latein am Ende...

Kann mir evtl. jemand weiterhelfen...???

Danke schon mal...!!!

bitte genaue angaben machen. glaskugel ist nicht im einsatz.

shopversion ?

Share this post


Link to post
Share on other sites

Originally posted by mzanier+Aug 5 2004, 18:22 PM--></div><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (mzanier @ Aug 5 2004, 18:22 PM)</td></tr><tr><td id='QUOTE'> <!--QuoteBegin-totto@Aug 5 2004, 14:52 PM

Hallo,

ich habe ein etwas gr??eres Problem, und komme nicht mehr weiter...

Im Shop werden zwei W?hrungen angeboten, EUR und US$. Soweit funktioniert das auch...

Wenn jedoch ein Kunde sich anmeldet, der in einer Gruppe ist, wo auf die Artikel ein Rabatt gew?hrt wird, wird bei der Umstellung der W?hrung diese nur bei solchen Artikeln der richtige Preis angezeigt, wenn diese Artikel als Sonderangebote deklariert sind (da gibt's ja eh keinen Rabatt mehr). Bei "normalen Artikeln" wird jedoch nur das EUR in US$ ge?ndert, der Preis ?ndert sich jedoch nicht... Es wird immer der Preis mit dem korrekten Rabatt des Kunden angezeigt, aber immer der EUR Wert...

Ich hab' schon ?berall geschaut, wo ich dachte, da k?nnte es dran liegen, nun bin ich aber mit meinem Latein am Ende...

Kann mir evtl. jemand weiterhelfen...???

Danke schon mal...!!!

bitte genaue angaben machen. glaskugel ist nicht im einsatz.

shopversion ?

Share this post


Link to post
Share on other sites

Wie nachl?ssig, Deine Glaskugel ausgerechnet jetzt in den Urlaub zu schicken... :)

Also, Shopversion ist XTC v2.0 RC1.2, Sicherheitsdingens wegen dem Smarty ist auch installiert.

Der Fehler tritt auf wenn:

Ein User sich einloggt, der Rabatt auf jedes Produkt bekommt. Es werden immer die EUR Werte des Preises angezeigt, nur die vorgestellte W?hrung wechselt von EUR auf US$, und zur?ck... AUSSER: das Produkt ist ein Sonderangebot (Special), dann wird der Preis korrekt von US$ auf EUR umgerechnet.

Share this post


Link to post
Share on other sites

Originally posted by dariusboy@Aug 5 2004, 19:34 PM

Hallo

Ich denke das hat mal was mit dem Bug 0000184 zu tun

oder nicht ?

Greets

Kann schon sein, dass da ein und das gleiche Modul angezogen wird, was den Fehler verursacht... Kann ich aber nix genaues zu sagen, ich hab' mich mit den Gutscheinen noch nicht auseinander gesetzt...

Share this post


Link to post
Share on other sites

So, jetzt hab ich mal XTC nochmal neu instaliert, nix ver?ndert, und das Szenario nochmal nachgestellt...

Es ist tats?chlich ein Bug... L?sst sich beliebig reproduzieren...

Werd' das mal in den Bug Tracker eintragen, w?re aber f?r eine Sofort-Hilfe sehr dankbar...!!!

So long...

Share this post


Link to post
Share on other sites

hm, ist im aktuellem entwickluns-system bereits behoben (da neue preisklasse einegebaut) einen fix f?r die alte version kann ich zur zeit nicht zur verf?gung stellen.

Share this post


Link to post
Share on other sites

HEUREKA, ich hab's gefunden....!!!!! :bounce: :) :pint: :z:

Wenn man bedenkt, dass ich eigentlich so gut wie keine PHP Kenntnisse habe, bin ich doch schon ein echter B?r...!!! :):):) Es geht doch nix ?ber Erfolgserlebnisse...!!!

Also:

In der xtc_get_products_price.inc.php steht in der Zeile 110 folgendes:


$price_string=xtc_format_special_price($rabatt_string,$price_string,$price_special,$calculate_currencies=false,$quantity,$products_tax);

Und hier muss einfach nur das Flag f?r die W?hrungsumrechnung auf "true" gesetzt werden, sprich, die Zeile muss so aussehen:

$price_string=xtc_format_special_price($rabatt_string,$price_string,$price_special,$calculate_currencies=true,$quantity,$products_tax);

Und schon werden die Rabatte auch in den anderen W?hrungen richtig dargestellt.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...