Jump to content
xt:Commerce Community Forum
Sign in to follow this  
pogo

Fehlermeldung nach korrekter Installation:

Recommended Posts

Hi!

bekomme leider eine fehlermeldung,

mein provider sagte mir folgendes:

--------------------------------------------

auf unseren Servern ist der safe_mode aktiviert. Allerdings verwenden wir die

suPHP-Technik. suPHP löst das Problem der Eigentumsrechte vom safe_mode auf.

Sie können problemlos xt:Commerce installieren, es wird einwandfrei "out of

the box" funktionieren. Es sind keinerlei Anpassungen notwendig.

--------------------------------------------

jetzt meine fehlermeldung:

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 948 is not allowed to access owned by uid 0 in /var/www/webserver/html/testshop/shop/includes/application_top.php on line 250

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /var/www/webserver/html/testshop/shopincludes/application_top.php:250) in /var/www/webserver/html/testshop/shop/includes/application_top.php on line 281

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/webserver/html/testshop/shopincludes/application_top.php:250) in /var/www/webserver/html/testshop/shop/includes/application_top.php on line 281

bin FÜR JEDE HILFE DANKBAR!!!

Share this post


Link to post
Share on other sites

Das Problem wird sein, dass du nicht nach /tmp schreiben darftst.

So wie ich das nämlich sehe, liegt das SESSION_WRITE_DIRECTORY dort.

Mach mal mit dem phpmyadmin folgende abfrage:

SELECT *

FROM `configuration`

WHERE `configuration_key` = 'SESSION_WRITE_DIRECTORY'

Es gibt also zwei möglichkeiten... entweder session in mysql verlegen

Dazu musst du in der ./includes/configure.php und ./admin/includes/configure.php den folgenden wert anpassen

define('STORE_SESSIONS', 'mysql');

Oder du änderst den Wert von SESSION_WRITE_DIRECTORY in der Datenbank.

Gruß,

Thomas

Share this post


Link to post
Share on other sites

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 948 is not allowed to access owned by uid 0 in /var/www/webserver/html/testshop/shop/includes/application_top.php on line 250

Würde mal sagen "owned by uid 0" heißt: Die Datei "/var/www/webserver/html/testshop/shop/includes/application_top.php" gehört dem Benutzer "root" und ich hoffe das der Webserver NICHT mit dem Benutzer Root läuft. Setze die Rechte auf den richtigen Benutzer. Wenn ihr suPHP benutzt, dann kontrolliere ob die Umask und die Benutzer evtl. nicht passen.

Share this post


Link to post
Share on other sites

ja...oder leer lassen

moin, ich habe selbiges problem, bekomme es aber auch mit der umstellung auf mysql oder leer lassen nicht weg. es bleint die fogende fehlermeldung:

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/www/doc/11660/carrerabahn-ingolstadt.de/www/shop/inc/xtc_js_lang.php:31) in /home/www/doc/11660/carrerabahn-ingolstadt.de/www/shop/includes/application_top.php on line 281

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/www/doc/11660/carrerabahn-ingolstadt.de/www/shop/inc/xtc_js_lang.php:31) in /home/www/doc/11660/carrerabahn-ingolstadt.de/www/shop/includes/application_top.php on line 281

übrigens finde ich zu diesem problem zwar zig tausend einträge über die suche, aber wirklich helfen tut da nix.

die installationsroutine läuft ohne eine fehlermeldung durch, erst wenn ich auf catalog klicke kommt diese meldung. einloggen kann ich mich auch nicht.

die rechte hatte ich genau wie in der anleitung geändert.

vielleicht hat ja noch einer ne idee wo der fehler liegt.

danke

gruß frank

Share this post


Link to post
Share on other sites

Hallo,

auch ich hatte das Problem. Nach der Installation eines Templates habe ich dieses Templates im Adminbereich ausgewählt und auf Speichern geklickt. Wenn man nun den Shop aufgerufen hat, kam nur eine leere Seite und in den Log-Dateien erschienen ähnliche Einträge. Es gab aber kein Fehler in der Berechtigung zum schreiben in das tmp-Verzeichnis.

Ich hatte lediglich übersehen, die Rechte des neuen Verzeichnisses anzupassen.

Beispiel: ich kopierte das komplette Verzeichnis des Templates in das Verzeichnis xtcommerce/templates mit dem Ergebnis xtcommerce/templates/[Name des Templates]. Hier müssen also mit chown -R usr:gruppe die Rechte gesetzt werden. Schon gehts!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...