Jump to content
xt:Commerce Community Forum
Sign in to follow this  
illuminati424

Bitte um hilfe bei Bestsellerbox!

Recommended Posts

Hallo Leute,

ich hätte da frage zur Bestsellerbox.

Momentan ist der Shop im Aufbau aber ich hab jetzt schon Probleme mit der Bestsellerbox.

Folgendes...:

Ich hab mir ein Template runtergeladen und Testversuche gemacht. Die Zwei Gekauften Sachen in der Bestsellerbos wird zwar angezeigt, allerdings werden die Sachen mit einem " ._________________ " angezeigt

(siehe hier http://www.edhardy-shop.net/ )

Kann mir jemand sagen woran das liegt, oder wie ich das ändern kann? Oder muss ich mich hierzu an denjenigen wenden, wo ich das Template herhab?

Würde mich freun, wenn ich Antwort bekommen würde.

Besste Grüße Georgi

Share this post


Link to post
Share on other sites

Moin!

Öffne doch mal die Template-Datei

-> templates/DeinTemplate/boxes/box_best_sellers.html

und schau, wie die Variablen dort benannt sind.

Vllt. hat sich der Template-coder einfach verschrieben.

Im Standard-Template kommt an:

{config_load file="$language/lang_$language.conf" section="boxes"}
{#heading_best_sellers#}
{$box_data.COUNT}
{$box_data.PRODUCTS_NAME}
{$box_data.PRODUCTS_PRICE}
{$box_data.PRODUCTS_VPE}
{$box_data.PRODUCTS_TAX_INFO}
{$box_data.PRODUCTS_SHIPPING_LINK}
[/PHP]

Gruß

Numerobis

Share this post


Link to post
Share on other sites

Hallo Numerobis,

erst mal vielen dank für Deine Anwort.

Bei mir sieh der Quelltext folgendermaßen aus:

{config_load file="$language/lang_$language.conf" section="boxes"}


<table width="100%" border="0" cellpadding="2" cellspacing="0">

  <tr>

    <td><table width="100%"  border="0" cellpadding="0" cellspacing="0">

        <tr>

          <td class="infoBoxHeading_right">{#heading_best_sellers#} </td>

          <td> </td>

        </tr>

    </table></td>

  </tr>

  <tr>

    <td class="infoBox_right" align="left"><table width="95%"  border="0" cellpadding="2" cellspacing="0">

        <tr>

          <td class="boxText"><table border="0" width="100%" cellspacing="0" cellpadding="3" class="infoBoxContents">

            <tr>

              <td align="left" class="boxText">

                <table width="100%" border="0" cellspacing="2" cellpadding="0">

        {foreach name=aussen item=box_data from=$box_content}

          <tr>

            <td valign="top" class="boxText" style="border-bottom: 1px solid; border-color: #cccccc;">{$box_data.ID}.</td>

            <td style="border-bottom: 1px solid; border-color: #cccccc;" class="boxText"><table width="100%"  border="0" cellpadding="0" cellspacing="0">

                <tr>

                  <td class="boxText"><a href="{$box_data.LINK}">{$box_data.NAME}</a> </td>

                </tr>

                <tr>

                  <td class="boxTextPrice" align="right"><strong>{$box_data.PRICE}</strong></td>

                </tr>

              </table></td>

          </tr>

        {/foreach}

              </table></td>

            </tr>

          </table></td>

        </tr>

    </table></td>

  </tr>

</table>

Leider hab ich kein PHP-Program wo ich mir anschaun kann, was da jetzt Falsch ist oder wo der Fehle drinn liegt.

Könntest Du oder jemand mir den gefallen zun und das für mich Richtig stellen, fals da nur ein Zeichen oder so Fehlt?

Wär echt Supi :D

Gruß Georgi

Share this post


Link to post
Share on other sites

Aaaaah... oke Danke, das hat sich dann erledigt... aber wenn ich jetzt dadrauf klick, dann kommt immer nur Startseite und man kommt nicht auf das Produkt und ich hätte das lieber als laufend mit Bild.

kann mir jemand sagen, was ich hierzu machen oder einfügen muss?

Danke :D

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...