Jump to content
xt:Commerce Community Forum
Sign in to follow this  
DanWahn

Version 3.0.3 auf MySQL5 & PHP5

Recommended Posts

Hallo zusammen

Ich überlege mir aus verschiedenen Gründen, mein Hosting auf de aktuellsten Versionen von MySQL und PHP umzustellen.

Da momentan XTC 3.0.3 auf PHP & MySQL4 läuft, stelle ich mir die Frage, ob bei einem Update Probleme auftreten können bzw. ob konkrete bekannt sind.

Da der Shop sehr stark an Kundenwünsche angepasst ist, kann ich kein Update auf die aktuellste XTC-Version vornehmen, ohne sehr sehr grossen Aufwand zu betreiben. Die Frage ist also eher, ob v. 3.0.3 auf MySQL5 & PHP5 läuft...

Bin froh um jeden Hinweis!

Danke und Gruss

Daniel

Share this post


Link to post
Share on other sites

Hallo zusammen

Ich überlege mir aus verschiedenen Gründen, mein Hosting auf de aktuellsten Versionen von MySQL und PHP umzustellen.

Da momentan XTC 3.0.3 auf PHP & MySQL4 läuft, stelle ich mir die Frage, ob bei einem Update Probleme auftreten können bzw. ob konkrete bekannt sind.

Da der Shop sehr stark an Kundenwünsche angepasst ist, kann ich kein Update auf die aktuellste XTC-Version vornehmen, ohne sehr sehr grossen Aufwand zu betreiben. Die Frage ist also eher, ob v. 3.0.3 auf MySQL5 & PHP5 läuft...

Bin froh um jeden Hinweis!

Danke und Gruss

Daniel

Hallo Daniel,

habe das gleiche Problem beim Shop (alt: xtc:3.0.3 - neu xtc:3.0.4, aufwendiges Template-Anpassungen). Jetzt steht der alte Shop, weil nicht mehr mySQL5-kompatibel.

Hast Du eine brauchbare Antwort (oder die "Updatescripts") bekommen?

Tausend Dank für kurze Antwort.

Achim

Share this post


Link to post
Share on other sites

Hi Achim

Das ist ne Weile her... :-)

Ich glaub es gab einie Queries die man anpassen muss, v.a. in Bezug auf die LEFT JOIN's. Wenn Du die Seite kopierst und die Fehlermeldung im Forum suchst, wirst Du garantiert fündig... ist ein 2, 3 Stellen ein Problem.

Also bei mir läuft der Shop auf PHP5 seit längerer Zeit problemlos...

Gruss

Daniel

Share this post


Link to post
Share on other sites

Hallo,

wie habt Ihr das Problem in den Griff bekommen, dass bei MySQL5 die Definition DECIMAL(3,2) eine andere Bedeutung hat als bei Version 4??

Betrifft v.a. das Feld products.products_discount_allowed, wo man dann plötzlich nur noch einen Rabatt von 9.99 eingeben kann...

Entsprechende Seite: MySQL :: MySQL 5.0 Reference Manual :: 11.13.2 DECIMAL Data Type Changes

Ich kann nur raten, VORISCHT mit Updates von MySQL 4.x auf 5.x!!

BBKing

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...