Jump to content
xt:Commerce Community Forum
Sign in to follow this  
xbutton

Brauche Image_manipulator.php

Recommended Posts

Guten Abend alle miteinander !!!

Hat jemand eine image_manipulator.php Datei f?r mich die auch mit GD Lib unter 2.0 arbeitet ???

Bekomme die ganze Zeit nur Fehlermeldungen wenn ich Bilder f?r Artikle hochladen will.

Vielen Dank im vorraus

Paddy :)

Share this post


Link to post
Share on other sites

Originally posted by xbutton@Sep 30 2004, 20:22 PM

Guten Abend alle miteinander !!!

Hat jemand eine image_manipulator.php Datei f?r mich die auch mit GD Lib unter 2.0 arbeitet ???

Bekomme die ganze Zeit nur Fehlermeldungen wenn ich Bilder f?r Artikle hochladen will.

Vielen Dank im vorraus

Paddy :)

oder einfacher:

wechsel doch einfach den hostingprovider ;-)

da findest du bestimmt auch jemanden mit libgd > 2

die 2er version macht wesentlich bessere ergebnisse als die 1er. oder bearbeite die bilder doch auf deinem normalen rechner und lade dann die fertigen bilder hoch (entweder mit lokaler XT:C installation oder [wie richtige m?nner] mit photoshop & co)...

sorry f?r diesen bl?den kommentar :i:

da ich keine werbung machen will poste ich jetzt nicht die url eines hosting anbieters der daf?r bestens geeignet w?re (=ich)

Share this post


Link to post
Share on other sites

hi den profis

nun hats mich auch erwischt warum auch immer ich kann keine bilder hochladen

den imagekonverter hab ich schon neu aufgespielt von dem link 2-3 posts ober mir

nur ich bekomme imme rnoch ne fehler meldung

Fatal error: Call to undefined function: imagecreatefromgif() in /home/www/web1/html/shopping/admin/includes/classes/image_manipulator.php on line 177

wenn ich das bild als jpg bild hochladen will

als bmp wird die fehler liste noch l?nger

und als gif kommt die gleiche fehlermeldung wie oben nur in zeile 59

ich weiss nimmer weiter warum das bei mir nicht geht

der server steht bei 1&1 wenns wer wissen will

danke f?r eure hilfe

gru?

torsten

Share this post


Link to post
Share on other sites

imagecreatetruecolor

geht erst ab >GD2

einfach mal ne phpinfo(); ansehen und die PHP+GD Version checken

Du bist bei 1und1 und dort "web1"? Ist das ein Root- bzw. Managed Server? Die Managed Server sollten in den letzten WOchen neue PHP und GD Versionen bekommen haben.

Share this post


Link to post
Share on other sites

Wenn du den Imageconverter aus dem Link aufgespielt hast, haste nen Fehler gemacht. Der ist nur f?r GD-Versionen < 2 zust?ndig.

Evtl. solltest du die Datei wieder durch eine aus dem Shoparchip ersetzen.

Share this post


Link to post
Share on other sites

Ja, cherubim hat recht.

Du hast

 imagecreatefromgif

was darauf schliessen l??t, da? Du den Imagemanipulator f?r GD1 druff hast. Aber GD2 sollte damit auch umgehen k?nnen.

Wieso wurde eigtl. mein Vorschlage auf function_exist() zur?ckzugreifen nie umgesetzt. Dann k?nnte man sich den ganzen Hick-Hack sparen :)

Share this post


Link to post
Share on other sites

danke f?r die tips weiss zwar nicht wirklich was ihr da nun mir vorgeschlagen habt denn ich bin in der beziehung nen noob ;)

aber ich hab mit mal die faq durchgelesen und bin eigentlich mit den hinweisen schnell zurechtgekommen nun funkts auch

danke f?r eure tips zeit und m?he

gru?

torsten

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...