Jump to content
xt:Commerce Community Forum
Sign in to follow this  
ripper017

Probleme Mit Produktbildern

Recommended Posts

Hallo Leute,

ich hab mich jetzt schon ein wenig mit der Beta 2 besch?ftigt und sie ist echt klasse. Aber ich hab ein kleines Problem.

Ich kann Kategorien erstellen und ihnen eigene Bilder hochladen, alles kein Problem. Aber wenn ich versuche Produkte zu erstellen mit Bild , dann bekomme ich fogende Fehlermeldung:

Fatal error: Call to undefined function: imagecreatefromjpeg() in /home/www/web11/html/entwicklungsbereich/xtcommerce2/admin/includes/classes/image_manipulator.php on line 51

Ich hab in dieser Datei nichts ver?ndert, hab sie mir mal angesehen, aber dort kann ich keinen Fehler finden.

Die Bilder die ich verwenden wollte sind die selben JPEG die ich in der Beta 1 verwendet hab.

Hoffe ihr k?nnt mir mal helfen.

Mfg

Micha

Share this post


Link to post
Share on other sites

Das sieht eher nach fehlender GD-Lib aus. Imagecreatfromjpeg sollte eigentlich schon funktionieren.

Einfach mal Provider fragen od GD-Lib im PHP einkompiliert ist.

Share this post


Link to post
Share on other sites

Ich hab es jetzt mit dem Contribute versucht, und ohne. Beides war eine Pleite.

Ich hab mal den Server angesehen, ich hab php 4.3.2 drauf, also m?sste es doch funktionieren, oder??

In einem anderen Topic wurde gepostet das diese Version von php schon all diese Funktionen unterst?tzt, richtig????

Woran kann es dann liegen???

mfg

Micha

Share this post


Link to post
Share on other sites

Originally posted by ripper017@Dec 21 2003, 13:45 PM

Ich hab es jetzt mit dem Contribute versucht, und ohne. Beides war eine Pleite.

Ich hab mal den Server angesehen, ich hab php 4.3.2 drauf, also m?sste es doch funktionieren, oder??

In einem anderen Topic wurde gepostet das diese Version von php schon all diese Funktionen unterst?tzt, richtig????

Woran kann es dann liegen???

mfg

Micha

guckmal in deiner phpinfo nach, ob dein provider jpeg support f?r gdlib installiert hat.

Share this post


Link to post
Share on other sites

Die GD-Lib ist zwar dabei, muss aber auch enabled werden. Einfach mal den Provider fragen.

Zum eigenen ?berpr?fen eine Datei phpinfo.php erstellen mit folgendem Inhalt

<?php

phpinfo();

?>

auf den Server laden, aufrufen und den Punkt GD suchen.

Share this post


Link to post
Share on other sites

Hallo Hubi,

ich hab deinen Ratschlag angenommen und diese Datei erstellt, ausgef?hrt und die ewig lange Liste durchsucht. Aber ich kann keinen Punkt mit GD finden.

Binn ich blind oder bedeutet das, das mein Server diese Funktion nicht unterst?tzt??

mfg

Micha

Share this post


Link to post
Share on other sites

so sollte das aussehen:

gd

GD Support enabled

GD Version bundled (2.0.11 compatible)

FreeType Support enabled

FreeType Linkage with freetype

GIF Read Support enabled

JPG Support enabled

PNG Support enabled

WBMP Support enabled

XBM Support enabled


wenn du keinen punkt GD in deiner phpinfo findest, dann hat das dein provider nicht installiert.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...