Jump to content
xt:Commerce Community Forum
Sign in to follow this  
Rafael0801

Artikelattribute

Recommended Posts

Hallo

Wieder ein problem sorry :(

Ich habe für ein Artikel 4 Attribute angelegt Beispiel

Pentium3 --- 100Mhz,200MHz,300MHz der kunde soll auswählen welche variante er kaufen möchte das klappt ja die Varianten werden auch angezeigt nur sind sie alle markiert ich kann da nicht zwischen den Versionen wählen und wenn ich dann auf kaufen gehen habe ich alle 3 sorten im Warenkorb

Danke

Rafael

Share this post


Link to post
Share on other sites

xxxx.html steht für deine Vorlage im entsprechenden Template, d.h. du mußt jedes Template separat anpassen.

Nimm einfach mal aus der Vorlage das " checked="checked" " heraus.

Share this post


Link to post
Share on other sites

grad gemacht hab es entfernt die punkte sind weg ich kann sie setzen nur ich kann es nicht rückgängig machen spriech falls der kunde sich doch für blau und nicht rot entscheidet

also der Fehler muss anders sein hab grad noch Xampp installiert und dort nen schop erstellt es ist das selbe :( orginal XT templates

Share this post


Link to post
Share on other sites

Kurze Frage auch von mir hierzu (zu den Attributen).

Auch wir haben in unserem Shop Attribute angelegt.

Klappt auch soweit alles.

ABER Seit neustem Folgendes Problem:

Gehe ich im Admin auf ein Produkt und klicke Attribute editieren (egal ob bei dem Produkt bereits ein Attribut hinterlegt wurde, oder nicht) um beispielsweise ein Attribut hinzu zu fügen komme ich ebenfalls wie immer in das Menü in dem ich die einzelnen (in meinem Fall Farben) auswählen kann.

Ich hake also wegen mir drei oder 5 Farben an, und klcike auf SPEICHERN.

Dann passiert es:

Es erscheint keine Erfolgsmeldung oder etwas dergleichen, sondern es kommt lediglich ein weißes Fenster!

Er speichert also nichts.

Ich hatte das Gefühl, dass ich zu viele Attribute angelegt habe...

Habe also welche Gelsöcht, bzw eine 2te Gruppe hinzu gefügt, doch auch dann selbes Bild. Nach dem Speichern ein weißes Fenster :-(

Kann mir da jemand von euch weiterhelfen?

Liebe Grüße

tom

Share this post


Link to post
Share on other sites

Schreib mal den Code deiner Produktauswahl ../template/.../module/product_options/produkt_options_selections.php (die du im Artikel dann auch gewählt hat) hier hin:

{foreach ....

<input type="radio" name="id[{$options_data.ID}]" value="{$item_data.ID}" {php}if($i == 0) {{/php}checked="checked"{php} $i = 1; }{/php} />

....

....{/foreach}

Share this post


Link to post
Share on other sites

Schreib mal den Code deiner Produktauswahl ../template/.../module/product_options/produkt_options_selections.php (die du im Artikel dann auch gewählt hat) hier hin:

{foreach ....

<input type="radio" name="id[{$options_data.ID}]" value="{$item_data.ID}" {php}if($i == 0) {{/php}checked="checked"{php} $i = 1; }{/php} />

....

....{/foreach}

Uff. WAS soll ich machen?

Also das Verzeichnis bzw die Datei habe ich..

Aber ähh was soll cih hier posten?

Share this post


Link to post
Share on other sites

Meinst du das hier:

Das ist alles was in der Datei ssteht (da ich amateur bin) mit Front Page geöffnet und den Code raus kopiert:

{if $options!=''}

<table width="100" border="0" cellspacing="0" cellpadding="0">

{foreach name=outer item=options_data from=$options}

<tr>

<td valign="top" class="main"><b>{$options_data.NAME}:</b> </td>

<td class="main">

{foreach key=key_data item=item_data from=$options_data.DATA}

<input type="radio" name="id[{$options_data.ID}]" value="{$item_data.ID}" checked="checked" />

{$item_data.TEXT} {if $item_data.PRICE!=''}( {$item_data.PREFIX}{$item_data.PRICE} ){/if}<br />

{/foreach}

</td>

</tr>

{/foreach}

</table>

{/if}

Share this post


Link to post
Share on other sites

Kurze Frage auch von mir hierzu (zu den Attributen).

...

Ich hatte das Gefühl, dass ich zu viele Attribute angelegt habe...

Habe also welche Gelsöcht, bzw eine 2te Gruppe hinzu gefügt, doch auch dann

...

Also an zu vielen Attributen kann es nicht liegen, in einem unserer Shops gibt es

55 Gruppen und ca. 700 Artikelvarianten (das dauert immer über ne Minute bist die alle auf sind)

Allerdings, wenn du nichts in ..../includes/modules/product_attributes.php geändert hast, könnte ich mir vorstellen das du in einem der noch vorhandenen Attribute Steuerzeichen verwendest,

oder du musst mal schauen, ob die Spalte products_attributes in deiner Datebank repariert werden muss. (das ist aber kein Drama, hatte ich auch mal)

An sonsten mal auflisten was du alles geändert hast, bevor der Fehler auftrat.

Share this post


Link to post
Share on other sites

Da bin ich wieder,

R4ph1 schau mal bei dir in dieser Zeile:

<input type="radio" name="id[{$options_data.ID}]" value="{$item_data.ID}" checked="checked" />

da fehlt die Abfrage ob es angeklickt ist:

<input type="radio" name="id[{$options_data.ID}]" value="{$item_data.ID}" {php}if($i == 0) {{/php}checked="checked"{php} $i = 1; }{/php} />

Share this post


Link to post
Share on other sites

Hi,

vielen Dank.

Habe das gefunden, und auch versucht abzuändern.

Aebr mit meinen geistigen Mitteln, und mit eminen vorhandenden Programmen, KEIINE Cahnce, habe das Teil geändert, aber immer wenn cih es speichere und dann erneut in die Datei rein gehe um zu schauen, hat der die Änderung nicht gemacht, es steht immernoch dieses checked in der Zeile.

Kann mir jemand, dem cih die Datei zukommen lasse diese berichtigen und abändern?

Das anschließende rein kopieren in das richtige Verzeichnis bekomme ich noch hin!

Gruß

tom

Share this post


Link to post
Share on other sites

Ich sehe gerade das sowohl der Checkout-Fehler, als auch der Fehler im Adminbereich (weißes Fenster) von R4ph1 sind.

Das ist verdächtig, hast du mal in der Datenbank nachgesehen ob die Tabelle evtl repariert werden muss?

Share this post


Link to post
Share on other sites

Hi, nett das ihr mir helfen möchtet..

Aber ich kenne mich so gut wie gar nicht damit aus..

Wäre soweit auch kein Thema, da wir Programmierer für sowas haben.. ABER die sind nicht erreichbar, und der Shop muss mit "Attribut Artikeln" gefüllt werden..

Wer kann mir helfen, oder sagen, was ich machen soll?

Liebe Grüße

Thomas

Share this post


Link to post
Share on other sites

Bitte hiermit nochmals um HILFE zu dem angesprochenen Problem.

@ unriagh kannst du mir bitt sagen welche Datei genau du brauchst?

Bzw. VOR ALLEM wie deine Mail Addy ist?

Lieben Gruß

tom

Vielen Dank vorab!

Share this post


Link to post
Share on other sites

Und nochmal der Hilfe Ruf!!!

Wer hat Erfahrung, und eine Ahnung, wie man dieses Problem beseitigen kann?

Bitte um Info!

Gerne auch per PM!

Vielen Dank im Voraus,

Thomas

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...