Jump to content
xt:Commerce Community Forum
Sign in to follow this  
yshield

Suma URL erzeugt immer eine "1" hintendran

Recommended Posts

Hallo.

Mal nicht per Support Ticket, sondern hier im Forum! Ich hab in den "Suchmaschinen"-Einstellungen die "Sperre SEO Url manuell bearbeiten" auf "nein" gestellt, damit ich den Inhalt per Hand pflegen kann. Ist manchmal logischer.

Jedes mal wenn ich ein Produkt, einen Content oder eine Kategorie ändere, hängt der Shop automatisch eine "1" hinten an meine "Suma URL".

Warum passiert das? So muss ich jedesmal nach nur einer kleinen Änderung in einem Produkt, das gleiche nochmals aufrufen, um die "1" wegzumachen :-( Hab kein(!) Master/Slave installiert, das könnte theoretisch schuld sein?!

Nervt mich total! Wie kriegt man das weg? Danke ...

Share this post


Link to post
Share on other sites

Ja, das dumme ist nur, das gilt auch für den selben Artikel und ist daher extrem nervig!

Mein Tipp: Vor dem Speichern das Feld für die SUMA-URL einfach leeren, dann wird es vom System automatisch ausgefüllt und es hängt keine 1 hinten dran.

Share this post


Link to post
Share on other sites

sicher das kein 2ter artikel mit der gleichen url vorhanden ist ?

Denn ein solcher Check wird bereits durchgeführt. (4.0.9), man sollte nur beachten das bei der suma url immer de/ vorne steht (bzw die andere sprache).

Share this post


Link to post
Share on other sites

Also, von MEINER Seite, bin ich ziemlich sicher, dass keine 2te gleiche URL vorhanden ist! de/ oder en/ steht auch dabei ...

Und eine automatische URL gibt bei meinen Artikelnamen Unsinn aus. Ich will das unbedingt per Hand machen!

-> Entwickler: Da ist definitiv noch ein Fehler drin, da die "1" auch beim Speichern des gleichen Artikels angehängt wird! Da erkennt Euer "Check" wohl den gleichen Artikel als "gleiche URL" ... den aktuell zu speichernden Artikel sollte man aus der Prüfroutine wohl ausschliessen ...

Danke.

Share this post


Link to post
Share on other sites

Also, von MEINER Seite, bin ich ziemlich sicher, dass keine 2te gleiche URL vorhanden ist! de/ oder en/ steht auch dabei ...

Und eine automatische URL gibt bei meinen Artikelnamen Unsinn aus. Ich will das unbedingt per Hand machen!

-> Entwickler: Da ist definitiv noch ein Fehler drin, da die "1" auch beim Speichern des gleichen Artikels angehängt wird! Da erkennt Euer "Check" wohl den gleichen Artikel als "gleiche URL" ... den aktuell zu speichernden Artikel sollte man aus der Prüfroutine wohl ausschliessen ...

Danke.

ich denke auch das da irgendwas noch nicht richtig funzt.

beim artikel kopieren wird die zweimal die selben suma url vergeben, wenn man es automatisch machen lässt.

ich dachte es wird sich dabei am Artikelnamen orientiert bei der Automaik.

Aber irgendwie heißen dann alle Artikel gleich beim kopieren.

Sind es ähnliche Artikel und man ändern nur eine Kleinigkeit im Artikelnamen wird der dann in der SUMA URL nicht automatisch geändert, das ist komisch

v.g. micha

Share this post


Link to post
Share on other sites

ich denke auch das da irgendwas noch nicht richtig funzt.

beim artikel kopieren wird die zweimal die selben suma url vergeben, wenn man es automatisch machen lässt.

ich dachte es wird sich dabei am Artikelnamen orientiert bei der Automaik.

Ja das ist klar.

Beim kopiervorgang heißt der Artikel ja noch gleich, von daher auch gleiche SEO Url.

Sind es ähnliche Artikel und man ändern nur eine Kleinigkeit im Artikelnamen wird der dann in der SUMA URL nicht automatisch geändert, das ist komisch

Auch das ist Absicht, denn der Sinn von Suma Urls sind das diese Möglichst statisch sind, und sich nicht ändern wenn man mal den Artikelnamen selbst etwas verändert, denn dann wäre der alte link für google logischerweise ja auch nichtmehr erreichbar, und das will ja niemand :)

Da würden sich alle beschweren warum sich die Url jedesmal ändert.

Aus diesem Grunde kann man ja die Einstellung aktivieren das man diese URL selbst ändert.

Das ne 1 angehängt wird klingt daher eher danach das man mal einen Artikel kopiert hat und die seo url dann nicht geändert hat.

Share this post


Link to post
Share on other sites

@Mario: Wenn ich meinen Artikel "Test" aufrufe und bearbeite, lautet die URL nachher /Test1. Bearbeite ich diesen Artikel nun erneut, lautet die URL nachher /Test11 usw.

Da ist definitiv noch ein Bug vorhanden und bei mir läuft die 4.0.9. Ich denke Matthias ist daran das zu fixen für Version 4.1.0?!

Share this post


Link to post
Share on other sites

Ja das ist klar.

Beim kopiervorgang heißt der Artikel ja noch gleich, von daher auch gleiche SEO Url.

Naja das ist ja schon richtig :)

Aber wenn ich dem Artikel dann eine andere Überschrift geben, sollte

ja dann auch eine andere SUMA URL rausspringen oder nicht???

Weil nach Änderung des Artikels bzw. Überschrift bleibt die SUMA URL die selbe.

Das ne 1 angehängt wird klingt daher eher danach das man mal einen Artikel kopiert hat und die seo url dann nicht geändert hat.

heißt das ich muss nach dem kopieren eines Artikels immer zwingend die SUMA URL auch anpassen, wird dies nicht automatisch anhand des Artikelnamen gemacht?

Viele Dank für Antworten auf diesem Weg. :D

Ticket is ja leider in der Schwebe :P

v.g. micha

Share this post


Link to post
Share on other sites

heißt das ich muss nach dem kopieren eines Artikels immer zwingend die SUMA URL auch anpassen, wird dies nicht automatisch anhand des Artikelnamen gemacht?

Nein wird nicht automatisch gemacht, denn das ist ja Absicht.

Die SEO Url wird 1 mal erzeugt, und kann danach nur mehr manuell geändert werden, denn wie schon geschrieben wäre es ziemlich doof wenn man zb im Artikelnamen nen Buchstaben ändert, und danach die alte URL nichtmehr erreichbar wäre.

Share this post


Link to post
Share on other sites

Nein wird nicht automatisch gemacht, denn das ist ja Absicht.

Okay danke:D

dann weiß ich jetzt Bescheid das ich nach dem kopieren das manuell bearbeiten muss auch wenn ich den Artikelnamen abändere...

ich dachte des geht automatisch... was mir eigentlich auch immer noch sinnvoll erscheinen würde.

v.g. micha

Share this post


Link to post
Share on other sites

Gibt es keine Möglichkeit für einen "Hardreset", d.h. Überschreibung aller generierten SUMA-URLs mit neuen, aus dem Namen gebildetetn URLs? Gerade in der ersten Testphase, bevor ein Shop online geht is das extrem hilfreich, da ich nun sicher keine paar hundert Artikel händisch ändern werde... schon gar nicht in mehreren Sprachen....

hat einer ne praktikabele Idee bzw. kann mir sagen wie das geht?

Share this post


Link to post
Share on other sites

Ich hätte hierzu auch gerne eine Antwort. :)

Das bräuchte ich auch.

Arbeite seit einem halben Jahr am einrichten meines Shops. Mittlerweile sind alle ARtikel drin. Nach vielen Umstrukturieren (verschieben in den Kategorien, Artikel-Titel ändern), sind wir jetzt soweit, das wir online gehen könnten. Nur leider sind alle Suma-URLs noch so, wie die Artikel anfangs mal eingeben wurde.

So ein "Alle Artikel-Suma neu generien" vor dem ersten Onlinebetrieb wäre sicherlich sinnvoll.

Mardl

Share this post


Link to post
Share on other sites

Kann man nun für mehrere Kategorien die SUMA URL automatisch erzeugen lassen. Momentan geht es scheinbar nur, wenn ich jede Kategorie einzeln anwähle und mit der rechten Maustaste die Auswahl treffe.

MfG Frank

Share this post


Link to post
Share on other sites

ich denke, dass du bei "Kategorie" (der Überschrift) die alle auf einmal ausführen lassen kannst. Da er die vorhandenen ja beibehält machst Du Dir auf diesem Wege nichts kaputt..

Share this post


Link to post
Share on other sites

hi,

ich schmeiss das Thema mal wieder rein, da mir eine Lösung ziemlich helfen würde:

Gibt es keine Möglichkeit für einen "Hardreset", d.h. Überschreibung aller generierten SUMA-URLs mit neuen, aus dem Namen gebildetetn URLs? Gerade in der ersten Testphase, bevor ein Shop online geht is das extrem hilfreich, da ich nun sicher keine paar hundert Artikel händisch ändern werde... schon gar nicht in mehreren Sprachen....

schonmal Danke für Ideen!

Share this post


Link to post
Share on other sites

wie hast du eine lösung?

bei mir geht es auch nicht?

lösch eich die "1" in der DB ist alles weg.....

soll doch jeder in eine zeile schreiben können

was er für ULR namen will.

und das am besten auf einer seite übersichtlich.

nicht mit 1000 tabs.....

Edited by shop999

Share this post


Link to post
Share on other sites

Das mit der 1 in der Kategorie stört mich auch sehr und es sollte die Möglichkeit geben einfach einen Counter an den Artikel zu hängen, denn bei den Kategorien sollte jeder Shopbetreiber selbst entscheiden wie er dem Stammbaum anlegt und ob dann ein Counter notwendig ist.

Kann man das mit der 1 mittlerweile ausschließen, denn immer beim Import meiner Artikel aus der Amicron Wawi geht der Counter hoch.

Share this post


Link to post
Share on other sites

hallo

zu dieser zeit hatte ich auch noch amicron.

und es dann gott sei dank nicht weiter benutzt und umgestellt !

diese WAWI empfehle ich keinen !

soviele fehler habe ich selten gesehen in einer software

und dann noch der unverschämte support.

ob die gelöschten artikel daher kamen kann ich nicht genau sagen.,

das problem mit den URLs und Nummern ist jedoch ein

XT problem

keine ahnung ob das in 4.14 behoben ist

eine manuelle änderung probierte ich auch schon in der DB

dann kam aber nur eine weisse seite.

lösch erst mal dein amicron oder gib es zurück

und kauf dir dann was gescheites.

ich empfehle dir orgamax , SAP B1 oder die Xt Wawi Xt Office

Bei allen bist du auf der sicheren Seite

und der Support ist auch viel besser.

Share this post


Link to post
Share on other sites

Ich habe 2 Shops mit XTC 4.1 im Einsatz und es sind unterschiedliche Verhaltensweisen!

Shop1: Bei Kopieren eines Artikels wird das Feld "Suma URL" vom vorherigen Artikel mit kopiert und mit der nervigen "1" ergänzt. ==> Manueller Eingriff erfoderlich.

Shop2: Hier bleibt das Feld "Suma URL" leer und füllt sich erst mit der richtigen, neuen URL, wenn ich den Artikel speichere! ==> wünschenswert!

Hinweis:

Shop1: geupdatet von Veyton

Shop2: Neuinstallation ohne Vorgängerversion

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...