Jump to content
xt:Commerce Community Forum
Sign in to follow this  
eurogard

Falsche Darstellung Umlaute

Recommended Posts

Umlaute sind immer kompliziert, da braucht man schon etwas mehr Infos.

Datenbank ist also UTF8, wenn du die Umlaute in die HTML Mail nicht in HTML-Code reinschreibst, muss der Browser so eingestellt sein, dass er die Umlaute richtig interpretiert, oder du solltest reinschreiben, was für ein Zeichensatz genommen wurde.

z.B.

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-15" />

Ich habe übrigens keine Probleme mit den Umlauten.

Es gibt einen Bug in xtc, wenn man eine Bestellung editiert, dann gehen eventuell die Umlaute verloren. Das hatte ich irgendwann mal hier beschrieben, was man da ändern muss. War ein Schreibfehler im Code.

Share this post


Link to post
Share on other sites

Hi,

Umlaute in der kundenadresse werden im Browser richtig dargestellt!!

Sobald der Kunde aber bestellt werden Sie in der Bestell email nicht mehr korrekt Dargestellt

Hallo Bernd ÖSterreichh,

Vielen Dank fuer Ihre Bestellung.

Ihre Daten nochmals zur Kontrolle:

Bestellnummer: 33

Bestelldatum: 16.01.2009

Lieferadresse

Bernd ÖSterreichh

teststrasse 2

4567 Wien

Österreich

Rechnungsadresse

Share this post


Link to post
Share on other sites

Hallo,

habe auch noch das Problem mit den Umlauten, es wird bei "Upcomming products" der März als M?rz angezeigt.

wenn ich das in die INI reinschreibe

default_charset="iso-8859-1" [/HTML]

dann wird der März zwar richtig angezeigt, aber es werden alle bisherigen Umlaute, die Korrekt angezeigt wurden, falsch angezeigt.

Woran kann das liegen?

MFG

Share this post


Link to post
Share on other sites

der default charset muss utf-8 sein.

habe auch noch das Problem mit den Umlauten, es wird bei "Upcomming products" der März als M?rz angezeigt.

März kommt hier nicht vom Shop, sondern direkt von PHP, wenn es hier ein Umlautproblem gibt, bitte an den Provider wenden, dies ist dann ein Serverseitiges Problem.

Share this post


Link to post
Share on other sites

Bei mir werden alle Umlaute und Soderzeichen richtig angezeigt. Nur bei den Textpassagen, die aus der lag_german.conf stammen, kann ich machen was ich will. Die werden nicht richtig interpretiert. Auch wenn ich die Umlaute/Sonderzeichen dort als html-Code schreibe, es bleibt dabei. Hat vielleicht einer eine Idee, womit das zusammenhängen kann?

Zur weiteren Info: Bei mir sind alle Zeichensätze auf utf-8 eingestellt (SQL-Datenbank, Webserver, Shop und Browser).

Share this post


Link to post
Share on other sites

Bei mir werden alle Umlaute und Soderzeichen richtig angezeigt. Nur bei den Textpassagen, die aus der lag_german.conf stammen, kann ich machen was ich will. Die werden nicht richtig interpretiert. Auch wenn ich die Umlaute/Sonderzeichen dort als html-Code schreibe, es bleibt dabei. Hat vielleicht einer eine Idee, womit das zusammenhängen kann?

Zur weiteren Info: Bei mir sind alle Zeichensätze auf utf-8 eingestellt (SQL-Datenbank, Webserver, Shop und Browser).

Bitte beachten, dies hier ist das Forum für xt:Commerce VEYTON.

Bitte Anfragen in den richtigen Foren-Bereich posten.

Share this post


Link to post
Share on other sites

hallo,

eben hat mich ein kunde angerufen und gesagt das bei unserem gesamten shop die umlaute falsch/fehlerhaft angezeigt werden. nach meiner kontrolle unter ie8 und ff 3.0.11 wird alles richtig angezeigt? der kunde hat ie7, ist dieser vielleicht falsch konfiguriert "utf-8"???

gruß

kris

Share this post


Link to post
Share on other sites

Hallo allerseits,

also wir haben ebenfalls das Problem, dass die Umlaute in den E-Mail, z.B. in der Bestellbestätigung, nicht korrekt dargestellt werden obwohl die Texte in der Datenbank sowie auf der Website richtig ausgegeben werden. Server und Datenbank sind zudem, wie erforderlich, auf UTF-8 eingestellt!

Hat hierzu noch jemand einen Tipp?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...