Jump to content
xt:Commerce Community Forum
Sign in to follow this  
Nino808

Navileiste funkt nicht mehr

Recommended Posts

Hallo an alle,

wieder einmal ich^^ Ich hab meinen Shop einigermaßen optisch anpassen können. Als ich zuletzt festgestellt habe, dass die Navileiste nicht funktioniert - dachte ich kein Problem das löst du schon....aber nun sitze ich schon seit 2 Tagen dran und komme irgendwie nicht weiter :-( Ich hoffe hier die ersehnte Hilfe zu finden.

Vorab muss ich aber sagen, dass ich leider Anfänger bin aber schnell dazu lerne.

Auf dem Bild sieht man das Problem:

Die Navileiste ist nicht schön gerade und auch nicht mittig ausgerichtet. Noch dazu enthält sie diese komischen <> und <id="current"> Zeichen und der Hintergrund der Buttons ist immer noch schwarz :confused:

Ich habe anscheinend zuviel in der /template/index.html gespielt und kenne mich nicht mehr aus.

Bitte könnt ihr mir sagen was ich korrigieren soll?

Hier ist der Code:

<div id="nav_main">

<ul>

<{php} echo $current = $cur_link=='index.php' ? ' id="current"' : '';{/php}><a href="{php}echo xtc_href_link('index.php');{/php}"><span>Home</span></a>

{if $account}{php} if (isset($_SESSION['customer_id'])){ {/php}

<{php} echo $current = $cur_link=='logoff.php' ? ' id="current"' : '';{/php}><a href="{$logoff}"><span>{#link_logoff#}</span></a>

{php} }{/php}{/if}

{if $account}

<{php} echo $current = $cur_link=='account.php' ? ' id="current"' : '';{/php}><a href="{$account}"><span>{#link_account#}</span></a>

{/if}

<{php} echo $current = $cur_link=='shopping_cart.php' ? ' id="current"' : ''; {/php}><a href="{$cart}"><span>{#link_cart#}</span></a></li>

<{php} echo $current = $cur_link=='checkout_shipping.php' ? ' id="current"' : '';{/php}><a href="{$checkout}"><span>{#link_checkout#}</span></a></li>

<li><a href="http://forum.yaml.de/" target="_blank"><span>Forum</span></a></li>

</ul>

</div>

post-81647-14337914702942_thumb.jpg

Share this post


Link to post
Share on other sites

{if $account}{php} if (isset($_SESSION['customer_id'])){ {/php}

<{php} echo $current = $cur_link=='logoff.php' ? ' id="current"' : '';{/php}><a href="{$logoff}"><span>{#link_logoff#}</span></a>

{php} }{/php}{/if}

sieht seltsam aus und auch php und if heben sich mittendrin auf....

{if $account}{php} if (isset($_SESSION['customer_id'])) { {/php} <a href="{$logoff}"><img src="{$tpl_path}img/BILDNAME" align="middle" /></a><br />

 {php} } {/php}{/if}

so in etwa müsste sowas eher aussehen - müsstest du mal bei php fragen gehen

Share this post


Link to post
Share on other sites

ich weiß nicht was du meinst mit php fragen gehen, sry.

habe bemerkt dass wenn ich auf einen Button klicke zb Kassa, dass ich auf die Kasse seite komme und wenn ich nochmal drauf klicke dass ich auf der Home seite lande. Also das wechselt sich ab komischer Weise. Vielleicht hilft die Info weiter?

Ich lade mal meine Index Seite hoch, vielleicht geht das dann einfacher..

Liebe Grüße

index.html

Share this post


Link to post
Share on other sites

ich sag ja ich bin kein experte ;)

Dein skript in sich sieht merksam aus - mit den verweisen zu logoff.php und der steuerbefehl #logoff# - das scheint mir alles doppelt zu sein....

das von mir gepostete ( rot) funktioniert bei mir einwandfrei ( bei dir wohl ohne align=middle) ansonsten wende dich mal an

http://xhtmlforum.de/xhtml/

bin immer froh wenn ich erkenne das was nich stimmt - aber wie man im speziellen dies oder jenes besser machen kann - dazu bin ich der Falsche :P

Share this post


Link to post
Share on other sites

hat sonst noch wer einen tipp?

Edit: Hat sich erledigt. Der Header war größer als wie vorgesehen und hat die Navileiste überlagert (transparent). Sowas verdaut FF nicht gern, dem IE ist des wurst der hackt die graphik einfach ab wenn die nächste kommt.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...