Jump to content
xt:Commerce Community Forum
Sign in to follow this  
tierschundco

Versandkosten pro Artikel

Recommended Posts

Hallo,

und zwar suche ich eine Lösung für die Berechnung von Versandkosten. Am besten wäre ein Modul für Versandkosten pro Stück und das nochmal differenziert in versch. Länder.

Z.B.:

Artikel 1 - DE 10€

Artikel 1 - GB 20€

Artikel 1 - IT 25€

Artikel 2 - DE 50€

Artikel 2 - GB 80€

Artikel 2 - IT 95€

Wie kann ich das realisieren? Ich habe XTC 3.04 SP1.

Gruß

Share this post


Link to post
Share on other sites

hi,

möglich ist viel :) mit den normalen boardmitteln von xt gehts denke ich nicht, aber mit ein wenig bastelei, oder einem eigenem modul dafür ganz sicher.

sollen denn tatsächlich die versandkosten für alle artikel addiert werden? also in deinem beispiel: 3x artikel 1 und 3 x artikel 2 in einer bestellung macht 180€ versandkosten für die eine bestellung nach DE?

Share this post


Link to post
Share on other sites

So ist es! Die Versandkosten sollten addiert werden.

mmmh... da du ja scheinbar für nahezu jeden artikel andere versandkosten hast, wäre vielleicht eine möglichkeit die versandkosten mit in die produkt-tabelle der datenbank aufzunehmen, dann müsstes du natürlich zu jedem artikel die versandkosten einzeln eingeben....

eventuell könnte man, wenn du das gewicht für den jeweiligen artikel nicht benötigst, da etwas tricksen...

ist aber alles erstmal so ins blaue gedacht :)

Share this post


Link to post
Share on other sites

Hallo,

es gibt ein Modul ***** mit dem man beim Artikel anlegen die Versandkosten pro Artikel eintragen kann.

**** such mal nach Artikel Versandkosten vielleicht hilft das etwas...

Gruss

Jan

Share this post


Link to post
Share on other sites

Hallo Spezialisten,

Habe ein Problem mit dem Modul von gambio.

Im Prinzip funktioniert alles einwandfrei bis zu einem Versandpreis von 100.- Euro. Sobald bei einem Artikel ein Versandpreis größer 100.- Euro (also z.B. 130.- Euro) angegeben wird, zeigt der Shop nur 100.- Euro an. Auch im Admin beim Artikel selbst ist dann immer nur 99.9999 Euro angegeben.

Scheinbar kann das Modul keine 3-stelligen Versandkosten.

Weiß hierzu jemand eine Lösung???

Oder vieleicht ein anderes Modul???

Hoffe es kann mir jemand helfen.

Danke

Pat

Share this post


Link to post
Share on other sites

Hallo Spezialisten,

Habe ein Problem mit dem Modul von gambio.

Im Prinzip funktioniert alles einwandfrei bis zu einem Versandpreis von 100.- Euro. Sobald bei einem Artikel ein Versandpreis größer 100.- Euro (also z.B. 130.- Euro) angegeben wird, zeigt der Shop nur 100.- Euro an. Auch im Admin beim Artikel selbst ist dann immer nur 99.9999 Euro angegeben.

Scheinbar kann das Modul keine 3-stelligen Versandkosten.

Weiß hierzu jemand eine Lösung???

Oder vieleicht ein anderes Modul???

Hoffe es kann mir jemand helfen.

Danke

Pat

Hallo Pat, ich stehe vor dem selben Problem. Hab die Gambio-Erweiterung installiert aber ich kann nur 2stellige Versandkosten in der Artikelverwaltung angeben. Hast Du mittlerweile eine Lösung gefunden?

Share this post


Link to post
Share on other sites

Mhm,, hört sich gut an , aber mal ne Frage dazu an die Profis bevor ich es mir installe:

Ist es so, dass ich im prinzip meine pauschalen versandkosten bis preis x belassen kan. Und lediglich zum Bsp. für Produkt a-f hinterlegen kann, das immer! Betrag y dazu kommt unabhängig von der Pauschalen Befreeiunng? Geht um Sonderlänge- ist also immer dazuzurechnen.

??danke

Share this post


Link to post
Share on other sites

Hallo

Mir geht es ähnlich. Ich würde gerne einen einzigen Artikel versandkostenfrei anbieten, alles andere soll bleiben. Wie kriege ich das hin?

Danke

Rosshauptnerin

Mhm,, hört sich gut an , aber mal ne Frage dazu an die Profis bevor ich es mir installe:

Ist es so, dass ich im prinzip meine pauschalen versandkosten bis preis x belassen kan. Und lediglich zum Bsp. für Produkt a-f hinterlegen kann, das immer! Betrag y dazu kommt unabhängig von der Pauschalen Befreeiunng? Geht um Sonderlänge- ist also immer dazuzurechnen.

??danke

Share this post


Link to post
Share on other sites

Habe ein Problem mit dem Modul von gambio.

Im Prinzip funktioniert alles einwandfrei bis zu einem Versandpreis von 100.- Euro. Sobald bei einem Artikel ein Versandpreis größer 100.- Euro (also z.B. 130.- Euro) angegeben wird, zeigt der Shop nur 100.- Euro an. Auch im Admin beim Artikel selbst ist dann immer nur 99.9999 Euro angegeben.

Scheinbar kann das Modul keine 3-stelligen Versandkosten.

Das liegt am zu sparsamen Datentyp DECIMAL(6,4) für nc_ultra_shipping_costs.

Du musst den in der Datenbank erweitern, zum Beispiel auf DECIMAL(8,4).

Oder gleich beim Installieren in der install-gambioultra.php:

ALTER TABLE `products` 

ADD `nc_ultra_shipping_costs` DECIMAL(8,4) DEFAULT '0' NOT NULL

Gruß franc

Share this post


Link to post
Share on other sites

Hallo,

ich stehe vor dem gleichen Problem wobei es bei mir bis zur vorletzten Bestellung noch ohne Probleme funktionierte. Auf einmal geht es nicht mehr, es werden nur noch max. 99.9999 berechnet. Kann mir bitte einer kurz erklären wie und wo ich das ändern muss. (Datenbank erweitern ??)

Vielen Dank im vorraus !

Jürgen

Share this post


Link to post
Share on other sites

...kann mir bitte einer kurz erklären wie und wo ich das ändern muss. (Datenbank erweitern ??)

Kommst du überhaupt auf die Datenbank drauf? Mit z.B. phpmyadmin oder so?

Wenn ja, dann schnapp dir die tabelle "products" und dort das Feld "nc_ultra_shipping_costs" (Struktur der DB anzeigen), das bearbeitest du und trägst bei "Länge/Set" ein: 8,4

Wenn du kein phpmyadmin o.ä. hast dann wird es etwas schwieriger, dann musst du dir ein Skript basteln, das dieses Feld anpasst...

Share this post


Link to post
Share on other sites

Hallo franc,

ich habe die Änderungen in phpmyadmin vorgenommen und auch gleich im Shop ausprobiert.....es funktioniert ;-))

Hast Du super erklärt !! Danke für Deine schnelle Hilfe ...alleine hätte ich das nicht gefunden !

Mit vielen Grüßen aus Schweden

Jürgen

Share this post


Link to post
Share on other sites

Hallo, ich habe leider auch ein Problem mit diesem Modul.

Ich benutze xtc 3.0.4, im Adminbereich, wo man einen artikel einstellt oder bearbeitet, kann ich die versandtkosten auch angeben. Allerdings werden diese auf der Seite direkt, sprich bei der artikelansicht, im Warenkorb oder bei der Bestellung nirgens angezeigt. Weiss Jemand einen rat?

Installation lief ohne Probleme.

Liebe Grüße

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...