Jump to content
xt:Commerce Community Forum
Sign in to follow this  
1stMagic

Mehrere Artikelbilder?

Recommended Posts

Hallo!

Wie kann man denn mehrere Bilder für einen Artikel hochladen/auswählen?

Im Forum stand, dass unter "Bildoptionen" die Anzahl eingestellt werden kann. Diese steht bei mir auf "3". Aber wenn ich z.B: ein zweites Bild hochlade und dann auswähle, dann ersetzt er immer das erste...?

Danke und Gruß!

Share this post


Link to post
Share on other sites

oh man, hab ich mich tot gesucht.

vielen dank (vor allem für den screenshot). "bilder hochladen", "bilder durchsuchen" und "weitere bilder einstellen" an drei komplett unterschiedlichen stellen. ich fand, das war bei der 3er version deutlich besser (und vor allem schneller).

nun gut. nochmals danke!!!

Share this post


Link to post
Share on other sites

Hallo,

obwohl ich in meinen Shop 5 weitere Artikelbilder eingestellt habe und ich weitere einfüge, tauchen diese nicht auf. Wenn ich auch ein reinbringe, werden die im Admin bei allen anderen Artikelbilder auch angezeigt bzw. sogar auch den ben anderen Produkten. Muss ich noch was einstellen?

Gruß Grubi

Share this post


Link to post
Share on other sites

Hallo,

ich habe "zusätzliche Artikelbilder" auf 5 eingestellt und mehrere Bilder unter "Weitere Bilder" hochgeladen und den Artikeln zugeordnet. Trotzdem wird nur je ein Bild angezeigt. Muss man zusätzlich noch was einstellen?

DvSchuetz

Share this post


Link to post
Share on other sites

selbstverständlich nicht, aber es kam ja schon öfters vor, dass xtc irgendwelche Templates vermisste...

Benutzt wird das unveränderte "product.html" und "product_list_default.html".

Edited by dvschuetz

Share this post


Link to post
Share on other sites

Hallo Leute,

ich habe das gleiche Problem, anfangs hat das mit mehreren bildern funktioniert, an den templates habe ich 0 verändert.

Folgende Problematik, ich habe die weiteren Bilder auf 4 gestellt.

Der Media Manager ist aus in der Konfiguration.

Die Bilder sind per FTP in den org Ordner hochgeladen und über die Bilder importieren Funktion zugänglich gemacht.

Ich weis wo sich der 'weitere Bilder Button' befindet und nutze ihn, ich wähle die bilder aus, sie werden dort angezeigt. Sobald ich auf Speichern klicke kommt kurz 'laden' und dann ist artikel bearbeiten zu.

> Auf der Seite verändert sich dabei auch alles AUSER die weiteren Bilder,

Wenn ich wieder in die Admin gehe und den Artikel auswähle sind keine weiteren Bilder eingetragen.

Ich hab schon alle Browser benutzt sie ich kenne,

In der Datenbank nach den Namen der Bildern gesucht (gefunden in der Media Tabelle) aber nirgends anders, kann mir jemand weiter helfen ?

:-( Gibt es den eine Neuere Version wo eventuell das Problem behoben ist ?

Share this post


Link to post
Share on other sites

Bei mir ist es genauso wie bei meinem Vorposter (13.05.). Weitere Bilder werden nicht angezeigt.

Übrigens: Früher gab es für Kategorien doch 2 Bilder (Teaser+Header). Jetzt sehe ich nurn och eins. Für unser neues Projekt brauchen wir sogar insgesamt 3.

EDIT: Ok, es liegt wohl daran, dass ich ein Bild aus den Kategorien als Produktbild einsetzen wollte. Wenn ich also Bilder per FTP übertrage gilt wohl dasselbe. Es ist nicht in Kategorie Bilder, also wird es nicht übernommen, wohl aber bei der Auswahl angezeigt.

Edited by Simpsonight

Share this post


Link to post
Share on other sites

Wenn der Media Manager auf true steht, kommt der Reiter weitere Artikelbilder nicht. Du musst ihn auf false stellen.

Ich bin eh hier mega genervt...gut ich bin verwöhnt mit einem popeligen Strato Shop...aber da hat wenigstens die Anleitung gestimmt :P

Hier: ich bekomm nur ein Artikelbild rein. Faszinierenderweise habe ich beim nächsten Artikel gleich als erstes mehrer Artikelbilder eingegeben, BEVOR ich das Standardartikelbild eingegeben hab. Dies ist nun der einzige Artikel mit mehrern Bildern :rolleyes: Bei allen anderen das übliche Spiel...auswählen, speichern...und weg :eek:

Zu den Versankosten will ich schon gar nichts mehr hören :mad: aus lauter Frust hab ich das Beispiel mit DE/AT nachgearbeitet...war ja klar, das das auch nicht geht. Kann ich hier auch aufs UPDATE hoffen :o

LG

Amelie

Share this post


Link to post
Share on other sites

Hallo Zusammen,

wenn wir schon mal bei Bildern sind, habe ich doch glatt noch ein Frage.

Bei xt:C3 ging es relativ einfach ein Bild, an eine bestimmte Stelle, in der Produktdatei zu platzieren:

z.B.

{if $PRODUCTS_IMAGE_3 != ''} <A HREF="{$PRODUCTS_POPUP_LINK_3}"><IMG SRC="{$PRODUCTS_IMAGE_3}" ALT="{$PRODUCTS_NAME}"/></A>{/if}

Bei Yeyton werde ich irgendwie nicht schlau. Kann man hier auch ein bestimmtes Bild ansprechen?

Ich habe nur gefunden wie man das Hauptbild:

{if $products_image!=''}<DIV ID="productinfoimages"><A REL="gallery" HREF="{img img=$products_image type=m_popup path_only=true}" CLASS="thickbox">{img img=$products_image type=m_info alt=$products_name}</A></DIV> {/if}

oder alle anderen Bilder anzeigt:

{if $more_images !=''}

<div class="greybox">

<div class="more_images">

{foreach name=aussen item=img_data from=$more_images}

<a rel="gallery" href="{img img=$img_data.file type=m_popup path_only=true}" class="thickbox">{img img=$img_data.file type=m_thumb alt=$products_name}</a>

{/foreach}{/if}

Aber wie spreche ich das Bild mit der Nummer 2 oder 3 an?

Für einen Tipp danke ich.

Steffen

Share this post


Link to post
Share on other sites

Eigentlich sollte das ja so gehen:

das erste Bild unter "weitere Bilder" (4.0.11) kannst du so aufrufen:

{if $more_images.0.file}<a href="{img img=$more_images.0.file type=m_popup path_only=true}">{img img=$more_images.0.file type=m_info alt=$products_name}</a>{/if}"

...allerdings hat sich das mit den "weiteren Bildern" in der 4.0.12er Version geändert!

Gezielt die Bilder ansprechen geht leider immer noch nicht (zumindest nicht bei mir), weil das editieren der Reihenfolge in der neuen Version nicht funktioniert....bei mir....

Es gibt hierzu auch schon zwei Threads,schau mal hier:

http://www.xt-commerce.com/forum/fragen-zur-software/71899-artikelbilder.html

...und hier:

http://www.xt-commerce.com/forum/fragen-zur-software/73271-nach-4-0-12-update-mediamanager-und-sumas.html

...ich habe nun ein Ticket gelöst und hoffe auf eine Lösung des Problems!

Share this post


Link to post
Share on other sites

Hallo,

"data." mal mit reinschreiben:

Also wie folgt probieren:

{if $data.more_images.0.file}<a href="{img img=$data.more_images.0.file type=m_popup path_only=true}">{img img=$data.more_images.0.file type=m_info alt=$data.products_name}</a>{/if}"

Hoffe es klappt.

Gruß

Jeckoso

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...