Jump to content
xt:Commerce Community Forum
Sign in to follow this  
CarPaint-Zollernalb

Bilder Import

Recommended Posts

Nee, die Datein sind zwischen 15000 und 300000 byte, und von denen sind bereits einige importiert worden.

Wenn ich allerdings die Bilder einzeln mache, geht es (manchmal)....:eek:

Würde es helfen, wenn ich die Bilder mit dem Upload hochlade ???

Und das mit dem einzelnen zuweisen muss doch anders zu lösen sein, bei über 9000 Artikeln sitze ich da doch Tage dran...:confused:

Share this post


Link to post
Share on other sites

Hallo Experten,

hierzu habe ich auch noch vier kleine Verständnisfragen zum speichern:

1. Nehmt Ihr einfach die Bilder in Originalgröße oder kleinere Versionen?

2. Was macht Ihr, wenn die Bilder alle unterschiedlich groß sind (Veyton wird die ja dann vermutlich verzerren)?

3. Wie speichert Ihr die Bilder, also wie sieht die optimale Bildbezeichnung aus, da die ja vermutlich auch in den Suchmaschienen so angezeigt werden (reine Art.-Nr. bringt vermutlich nichts)?

4. Die Zuordnung der Bilder zu den Artikeln erfolgt wohl manuell?

Dankeschön. :D

Dankende Grüße

Nils

PS: Hintergrund: Im alten 1&1 Shop habe ich nur 2 Bilder angelegt: th & normal - hier geht es ja jetzt einfacher.

Share this post


Link to post
Share on other sites

kannst du mir bitte mal erklären wie das genau geht mit den bildern und eventuell einmal eine csv datei bereitstellen? habe bisher immer mit dem bigware shop gearbeitet und der ist irgend wie einfacher zu handhaben. habe noch nicht wirklich den Vorteil des xtcommerz endeckt. würdest mir wirklich helfen.

danke

juergesolo

Share this post


Link to post
Share on other sites

Habe meine Bilder zum Testen 8 Stück mittels FTP in das richtige Shopverzeichnis kopiert.

Beim Importieren der Bilder im Admin - Bereich wird auch keine Fehlermeldung angezeigt.

Nach : NEU LADEN sehe ich das er die Namen der Bilder. Angelegt hat und auch eine Laufende Nummer !!! , NUR... Die Bilder sehe ich nicht . Diese sind einfach nicht da.....

Ich habe im Verzeichnis zur kontrolle im Provider nachgeschaut....Dort sind die Bilder vorhanden....

:confused::confused::confused:

Habe rumgespielt, und festgestellt, dass ich für die Bilder, um diese sichtbar zu machen folgendes machen muss :

IMAGEPROCESSING !!! dies geht aber nicht im Media-Ordner. Dor bekomme ich Fehlermeldung :

Forbidden

You don't have permission to access /shop/cronjob.php on this server.

Apache/2.2.14 (Ubuntu) Server at billig.......de Port 80

Wenn ich den Artikel einzel bearbeite geht das aber !!!

Hat sich erledigt . Fehler wurde behoben

Edited by Oliver T.
Problem gelöst

Share this post


Link to post
Share on other sites

Hallo Oliver T.

kannst du mir bitte sagen, was du konkret gemacht hast um den Fehler zu beheben. Ich kann seit 7 Tagen kein einziges Bild mehr im Backend hochladen.

Über FTP habe ich Bilder hochgeladen, aber im Ordner Media sind nur die Bildnamen vorhanden und ein Platzhalter für Bilder. Keine Spur von den Bildern.

Was muss ich jetzt machen???

Vielen Dank im Voraus.

Grüsse

newbear

Share this post


Link to post
Share on other sites

Hallo, hab auch dieses Bildimportproblem.

Irgendwie funktioniert hier in dem Shop vieles nicht.

Ich habe auch ca. 4000 Bilder einzufügen. die liegen alle im org-Ordner. Sie sind also schon auf dem server. Trotzdem funktioniert es nicht. ich drücke auf Datei Import und eine Sekunde später ist auch schon Erfolg zu sehen. er hat aber nur ca. 80 Bilder eingefürgt / erkannt. Hochgeladen sind sie ja schon. Ich hab es auch mal mit nur 30 Bildern getestet. da hat er nur 10 eingetragen. Wo ist nur das Problem ?

Die Größe kann es nicht sein. Die Bilder sind max 60kb groß. Ich möchte ungern schon wieder selbst die Abfrage schreiben.

Share this post


Link to post
Share on other sites

Hallo schafx,

naja mit Bilder in das /org/ Verzeichnis zu kopieren ist es nicht getan - da müssen noch einträge in der in der Datenbank gemacht werden und anschließend das Imageprocessing noch angeworfen werden..

Gruß

Alois

Share this post


Link to post
Share on other sites

dragon das stimmt nicht, das wird alles während dem import automatisch erledigt.

Bei mir leider nicht mehr :(

Seit geraumer Zeit kann ich per FTP nicht mehr Bilder hochladen.

Ich lade z.B. ein Bild hoch, im Backend Datei Import und was passiert?

Unter dem Dateinamen wird eine "Bild" erstellt mit ID usw. aber das Bild selber ist nicht vorhanden.

Wenn ich über Datei Upload die gleiche Datei importiere funktioniert es wunderbar.

Was muss ich verändern, damit der FTP Upload Import wieder funktioniert?

Danke...

Share this post


Link to post
Share on other sites

Habe alle Bilder im Ordner org mit der Bezeichnung Artikelnur.jpg

Steht auch so bei jedem Artikel ind er Datenbank.

Es werden mal gerade 20 Stück bearbeitet - das ist doch ein Witz

Share this post


Link to post
Share on other sites

Ich habe einmal alles schnell überflogen, mir ist nicht aufgefallen, dass die Servereinstellungen erwähnt wurden.

Es müssen folgende Einstellungen entsprechend ausreichend hoch in der php.ini festgelegt werden.

max_execution_time = xxx

max_input_time = xxx

memory_limit = xxxM

upload_max_filesize = xxM

post_max_size = xxM

Share this post


Link to post
Share on other sites

Hallo,

Im moment sind meine bilder in den größen wild durchgemischt und ich brauche dringend 140x140 im product listing.

wenn ich datein unter org lade steht sofort erfolg aber es tut sich nichts leider...

vielleicht kasnn mir jemand hlefen :-)

Share this post


Link to post
Share on other sites

wieviel Bilder sind es denn @sigrun?

Und imageprozessing auch angeworfen?

Zuviel ist manchmal nicht gut, kommt auf Server/Webspace an.

Und die Grösse kannst du unter Dateitypen einstellen.

Und wenn alles nix hilft dann mach es über Dateiupload mal direkt im Ordner Media/Media Gallery/woeshinsoll

Share this post


Link to post
Share on other sites

also es liegen alle unter artikelbilder (ca. 600). die bildgröße habe ich auf 140x140 umgestellt.

Wenn ich jetzt das Imageprocessing durchlaufen lasse startet er, aber ändert die größe nicht.

wenn ich direkt auf den artikel gehe und es durchführe ändert sich auch nichts. nur beim einzeln in den artikel raufladen und anschließendem processing gehts :-/

Den Import habe ich, um es wirklich nur zu probieren nur mit 10 Bildern versucht, also sollte die uploadgröße passen.

Also die schritte wären doch folgende:

pixelgröße umstellen

import aus dem org ordner mit originalgröße

unter artikelbilder im media ordner gehen und imageprocessing, oder?

Klappt leider nix

Share this post


Link to post
Share on other sites

Also alle datein habe ich auf jeden org ordner gelegt die ich finden konnte.

auch beim händischen import in die artikelbilder (also immer nur so 10 auf einmal) im media verzeichnis vändert sich die größe nicht.

nur wenn ich auf den artikel direkt gehe und ihn komplett neu hochlade :-(

Ich finde meinen fehler leider nicht.

alle bilder löschen und neu vielleicht?

Und wenn ja, nach welcher anleitung genau,

DANKE :D

Share this post


Link to post
Share on other sites

Hallo in die Runde...

habt Ihr es alle mit CAO aufgegeben oder hat sich mittlerweile was getan, da hier im Thread nichts mehr los ist... wir sind auch gerade am Umstieg auf die neue Version von xtc und würden unser CAO gerne weiter nutzen...

Gruß

Share this post


Link to post
Share on other sites

Ich habe gestern 11.000 Bilder (700 x 700) auf unseren FTP-Server in den /org Ordner geladen. Anschließend ImageProcessing durchgeführt (knapp 2 Stunden gelaufen). Hat alles einwandfrei funktioniert!

Vielleicht noch als Info für Nutzer eines Templates von 8works mit Lupenfunktion: Der Bilder müssen dauerhaft im /org Ordner verbleiben, da die Lupenfunktion auf diesen Ordner zugreift.

LG

Ride

Share this post


Link to post
Share on other sites

Nein, sie haben mich falsch verstanden, die Bilder können per FTP einfach in das Verzeichnis geschoben werden, also alle gleichzeitig. In der CSV-Datei, die Sie importieren darf dann natürlich nur der Name des Bildes stehen, z.B. "produkt.jpg", nicht der komplette Bildpfad.

Viel Erfolg!

____________________

Sonnenbrille Online

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...