Jump to content
xt:Commerce Community Forum
Sign in to follow this  
clownfish

Bilderupload fatal error

Recommended Posts

Hallo, habe immer wieder Probleme mit dem Bilderupload

Veyton 4.0.12 (Firefox 5.3.5)

Manche Bilder erscheinen gar nicht, andere wieder doppelt.

Ab und zu dann noch diese Meldung:

Fatal error: mysql error: [0: ] in EXECUTE("UPDATE xt_media_link SET ML_ID=101, M_ID=62, LINK_ID=46, CLASS='product', TYPE='images', SORT_ORDER=2 WHERE link_id = 46 and class = "product" and m_id = 62 ") in /is/htdocs/meinshop/xtFramework/library/adodb/adodb-errorhandler.inc.php on line 77

Bitte um Hilfe, DANKE

Share this post


Link to post
Share on other sites

Hallo,

ich habe gleiches Problem, nachdem ich Bilder in der Reihenfolge verschieben wollte. Das "Arbeiten/Wartesymbol" erscheint zwar, aber es ändert sich nichts in der Liste. Danach kam folgende Fehlermeldung:

"Fatal error: mysql error: [0: ] in EXECUTE("UPDATE xt_media_link SET ML_ID=31, M_ID=16, LINK_ID=15, CLASS='product', TYPE='images', SORT_ORDER=2 WHERE link_id = 15 and class = "product" and m_id = 16 ") in /homepages/10/.../.../.../xtFramework/library/adodb/adodb-errorhandler.inc.php on line 77

"

Läßt sich das ohne Programierkenntnisse beheben? :D

Viele Grüße

Nils

Share this post


Link to post
Share on other sites

das ist ein BUG!

habe dies auch schon festgestellt...

lade jetzt nur noch bilder in gewollter reihenfolge nacheinander hoch...

um eine doppelte verlinkung eines nicht existierenden bildes zu entfernen gehe ich in die datenbank, suche wie in deinem fall nach der ML_ID=101 und lösche die zeile...

Share this post


Link to post
Share on other sites

Hallo "NUD",

Dankeschön, habe ich hinbekommen. :D

Es gibt bei der Bildbearbeitung noch einen Fehler, der ab und zu auftritt: Der Produkttext ändert dann wieder die Farbe (also nach Bildsortierung/Upload), z.B. von blau auf schwarz und zwischen den Absätzen erscheint: "\r\n".

Ist der bekannt und muß ich jedes Mal von Hand wieder alles weg und neu machen?? :rolleyes:

Viele Grüße

Nils

Share this post


Link to post
Share on other sites

Hallo "Clownfish",

wenn Du in Deiner SQL-Datenbank bist, suchst Du Dir aus Deiner Fehlermeldung...

"Fatal error: mysql error: [0: ] in EXECUTE("UPDATE xt_media_link SET ML_ID=101, M_ID=62, LINK_ID=46, CLASS='product', TYPE='images', SORT_ORDER=2 WHERE link_id = 46 and class = "product" and m_id = 62 ") in /is/htdocs/meinshop/xtFramework/library/adodb/adodb-errorhandler.inc.php on line 77"

...folgendes raus:

In der linken Spalte klickst Du auf xt_media_link, dann wird Dir eine kleine Tabelle angezeigt.

Dort klickst Du auf ml_id (bei mir direkt die erste Zeile) und dann oben drüber auf den Reiter Anzeigen.

Dann bekommst Du eine Tabelle mit den ganzen Bildern.

In der Überschrift der Tabelle erkennst Du:

ml_id m_id link_id class type sort_order

Jetzt suchst Du in der ersten Spalte ml_id nur noch:

ML_ID=101, M_ID=62, LINK_ID=46... (alles weitere steht daneben in der Zeile)

...klickst auf Löschen und fertig.

Viele Grüße

Nils

Share this post


Link to post
Share on other sites

hallo NilsK,

ich habe bisher nur erlebt, dass " und Umbrüche so wie Aufzählungszeichen in den Metabeschreibungen und Keywords nicht richtig durch die Programmierung gefiltert werden.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...