Jump to content
xt:Commerce Community Forum
Sign in to follow this  
Landixus

Paypal leere Seite nach Bestätigen

Recommended Posts

Hi,

ich dachte ich hätte das hier schonmal gelesen, finde das aber nicht wieder.

Wenn ein Kunde bei mir mit paypal bezahlen will kommt nach Bestellung

absenden eine leere Seite:

h**ps://w*w.blabal.de/index.php?page=checkout

im log und error log meines apache2 steht nichts drinne was auf einen

Fehler deutet, wo könnte das Problem noch liegen?

Share this post


Link to post
Share on other sites

hmmm das doof jetzt....

doch was im LOG

h**p://w*w.quakeit.de:443BebenIT p57a63512.dip.t-dialin.net - - [14/Nov/2009:11:18:27 +0100] "POST /index.php?page=checkout HTTP/1.1" 500 20 "h**ps://w*w.quakeit.de/index.php?page=checkout&page_action=confirmati$

htaccess ist vorhanden in dem template_c Verzeichnis

Aber wo ist der Onkel begraben?

Share this post


Link to post
Share on other sites

wenn ne weise seite angezeigt wird, dann müsste nen error log eintrag im webserver stattfinden.

ansonsten einmal in der tabelle xt_config _SYSTEM_DEBUG auf true setzen, und dann müsste die php fehlermeldung auch angezeigt werden.

Share this post


Link to post
Share on other sites

Ok es läuft, aber dann stimmt was mit dem server_test script etwas nicht.

Das Script sagte mir curl ist installiert, deswegen habe ich nicht weiter darauf

geachtet.

Der Debugger sagte mir aber, noe is nix curl da, anhand der Fehlermeldung halt :(

Wie auch immer, danke für die schnelle und gute Hilfe!

Ich geh jetzt in die Ecke und schäme mich, weils ja eigentlich doch an mir lag :o

....

Share this post


Link to post
Share on other sites

Hallo zusammen,

so, nach langem hin und her bin ich endtlich weiter gekommen. läuft aber immer noch nicht... (Veyton 4.0)

zuerst mal zu curl... war bei mir serverseitig nicht installiert (Fehler vom Hoster) dadurch weisse seite und KEINE EINTRäGE IM LOG!!!

jetzt curl drauf und es kommt fehlermeldung von paypal... wegen technischen problemen und im log sind nun auch einträge.. bei mir ist das dann error 1 "auth error"..

wen noch jemand weiss wie ich den weg kriege bin ich happy ;o)))

Share this post


Link to post
Share on other sites

hi,

ne zuerst paypal löschen da wo man die api's (einstellungen) reinschreibt...

- dannach auf plugin deinstallation..

- dannach wieder installieren...

- dannach wieder einstellungen und api's neu reinschreiben... annsonsten hat man im paypal (einstellungen) paypal doppelt drin... ;o)

Share this post


Link to post
Share on other sites

Das hat bei mir leider auch nichts geholfen.

Nach ca. einer Woche warten auf den Paypal Support habe ich nun eine Antwort bekommen und wollte mal Eure Meinung dazu hören:

Sehr geehrter Kunde,

informieren Sie Ihren Shophersteller (bzw Ihren Developer) das folgender Parameter entfernt werden muss:

"..ADDROVERRIDE=1"

Anschliessend nochmal testen, es sollte funktionieren.

Was haltet Ihr davon und was macht denn dieser Parameter in der Paypal übergabe?

Spannend,oder?

Christian Dressler

MBF Web Administrator

Share this post


Link to post
Share on other sites

Mhh da bin ich ja mal gespannt. Ich habe inzwischen Paypal für den IE komplett deaktiviert, da nur der bei mir Probleme macht. Allerdings funktioniert der Test von meinem und anderen Rechnern hier in der Firma auch mit IE8 problemlos. Trotzdem habe ich täglich "tote" Bestellungen.

@MBF: halt uns doch bitte mal auf dem laufenden.

Share this post


Link to post
Share on other sites

Ich habe scheinbar ähnliches Problem und benötige Dringend abhilfe! Gibt es schon neue Erkenntnisse?

Google lieferte mit folgende Ergebnis zu ADDROVERRIDE (https://www.paypal.com/en_US/ebook/PP_NVPAPI_DeveloperGuide/Appx_fieldreference.html#2679783)

The value 1 indicates that the PayPal pages should display the shipping address set by you in this SetExpressCheckout request, not the shipping address on file with PayPal for this customer.

Displaying the PayPal street address on file does not allow the customer to edit that address.

Character length and limitations: One single-byte numeric character.

Allowable values: 0, 1

Default: 0

Aber wo stellt man das um?

Share this post


Link to post
Share on other sites

Ich habe scheinbar ähnliches Problem und benötige Dringend abhilfe! Gibt es schon neue Erkenntnisse?

Google lieferte mit folgende Ergebnis zu ADDROVERRIDE (https://www.paypal.com/en_US/ebook/PP_NVPAPI_DeveloperGuide/Appx_fieldreference.html#2679783)

Aber wo stellt man das um?

Hallo Old

Hast du inzwischen herausgefunden wo man das ADDROVERRIDE umstellt? bzw. hat jemand von euch das Problem mit PayPal beheben können?

Wir haben langsam alle möglichen Lösungsvorschläge mit und ohne Hoster durchgespielt und nichts funktioniert.

Das neuste was ich habe ist durch den Debumodus:

[curl_error_msg] => Couldn't resolve host 'P '

[nvpReqArray] => Array

(

[METHOD] => SetExpressCheckout

[VERSION] => 1.0

[PWD] => xxxxxx

[uSER] => paypal_xx.xxxx.xx

[sIGNATURE] => xx.xxxx

[Amt] => 38

[PAYMENTACTION] => Sale

[ReturnUrl] => xxxxx

[CANCELURL] => xxxxx

[ADDROVERRIDE] => 1

[LocaleCode] => DE

[CURRENCYCODE] => CHF

)

Scheint ein curl Problem zu sein, aber laut Hoster sollte alles funktionieren ...

Und wieso eigentlich "SetExpressCheckout"? Dachte Veyton hat nur den normalen PP-Zahlungsmodus zur Zeit ...

Share this post


Link to post
Share on other sites

Hallo Old

Hast du inzwischen herausgefunden wo man das ADDROVERRIDE umstellt? bzw. hat jemand von euch das Problem mit PayPal beheben können?

Wir haben langsam alle möglichen Lösungsvorschläge mit und ohne Hoster durchgespielt und nichts funktioniert.

Das neuste was ich habe ist durch den Debumodus:

[curl_error_msg] => Couldn't resolve host 'P '

[nvpReqArray] => Array

(

[METHOD] => SetExpressCheckout

[VERSION] => 1.0

[PWD] => xxxxxx

[uSER] => paypal_xx.xxxx.xx

[sIGNATURE] => xx.xxxx

[Amt] => 38

[PAYMENTACTION] => Sale

[ReturnUrl] => xxxxx

[CANCELURL] => xxxxx

[ADDROVERRIDE] => 1

[LocaleCode] => DE

[CURRENCYCODE] => CHF

)

Scheint ein curl Problem zu sein, aber laut Hoster sollte alles funktionieren ...

Und wieso eigentlich "SetExpressCheckout"? Dachte Veyton hat nur den normalen PP-Zahlungsmodus zur Zeit ...

bei could not resolve host ist warscheinlich ein ausgehender traffic via curl am server durch eine firewall blockiert.

Share this post


Link to post
Share on other sites

Hier nochmal für die die eventuell ein ähnliches Problem haben. Ich hatte auch eine weiße Seite nach dem PayPay Kauf.

Es lag bei mir an dem CleverReach Plugin. Habs deaktiviert und PayPal ging.

hat vielleicht was mit der API zu tun!?

viele Grüße

Greg

Edited by flavor

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...