Jump to content
xt:Commerce Community Forum
Sign in to follow this  
bexpro

Downloadartikel mit Versandkosten schon paar mal - Wo ist das Problem ?

Recommended Posts

Hi an alle.

Ich habe folgendes Problem:

Manchmal werden die Downloadartikel mit Versandkosten berechnet.

Ich habe dafür KEINE Erklärung. wenn ich mich selbst einlogge oder sogar ein Konto eröffne klappt es wunderbar und ich gelange sofort zu Bezahloptionen, jedoch können die Zusammenstellungen und die Email von Kunden nicht lügen!

Tatsächlich passiert es manchmal dass ein Kunde einfach nur einen Downloadartikel bestellt und trotzdem dei Versandkosten berechnet werden. Ich konnte das Problem nicht reproduzieren.

Gruß

Share this post


Link to post
Share on other sites

Hallo!

Ich habe das Problem auch - habe bei mir aber es eingrenzen können auf ausländische Bestellungen. Wenn jemand aus Deutschland einen digitalen Artikel bestellt, dann werden keine Versandgebühren berechnet (für nicht digitale Produkte fallen Versandgebühren an) und wenn die Lieferadresse aber in Österreich liegt, dann fallen Versandkosten an.

Kennt das Problem sonst noch jemand - muss man irgendwo bei den Versandkosten etwas berücksichtigen oder so?

Gruß

Timo

Share this post


Link to post
Share on other sites

hallo,

ich setze gerade eine veyton auf und konfiguriere mich wund ;) und das problem hatte ich bereits ein paar mal. ich kann das problem so beschreiben: ich tätige mehrere testbestellungen kreuz und quer (artikel mit versandkosten, welche ohne, nur mit, nur ohne). inzwischen dieser tests kommt das vor, dass beliebige versandkosten beim digitalen download produkt hinzugefügt werden (ich teste momentan nur deutschland...).

wenn ich meine session lösche, den cache leere und ein neues browserfenster starte, habe ich diese beobachtung noch nie gehabt!

gruss

e.

Share this post


Link to post
Share on other sites

Vielen Dank für deine Infos

mindestens weiß ich dass ich nicht der Einzige mit dem Problem bin.

Das ist einfach nur peinlich und die Kunden sind dermaßen verärgert dass man es gar nicht beschreiben möchte, ist ja auch klar, wer bezahlt gerne Versandkosten wenn er gerade diese bei einem Download sparen möchte.

Share this post


Link to post
Share on other sites

Nun ja ich habe das selbe Problem.

Es kann eigentlich nur an der sessionID liegen!

ShopVersion: 4.0.12

1. Ich meld mich an

2. Lege den Downloadartikel in den Warenkorb

3. weiter zur Kasse

4. Zahlungsart wählen

5. allgemeine Geschäftsbedingungen akzeptieren

6. weiter

7. alles besten es funktioniert :D

ABER!!! Wenn der Kunde vorab sich verklickt d.h. wenn er eine Ware via Postversand bestellt und diese aber doch nicht haben möchte weil er lieber den Download möchte, dann gibt es ein Problem. Es wird ständig wie oben von den anderen USERN schon bemängelt, die Versandkostenpauschale erhoben.

Kann denn keiner vom Support-Team mal ein Statement abgeben, warum der Fehler auftritt? Wenn ihn schon so viele bemängeln! Echt eine Schand wenn man einen Shop hat wo Kunden für etwas zahlen müssen was nicht sein muss! Wir könn doch nicht jeden Kunden vorab darauf hinweisen! Aber eins freut mich dann schon, unten steht ja der link als Werbung mit welchem Shopsystem wir arbeiten, mal schaun wie lange noch!

Pfui des stinkt nach einem BUG :mad:

MfG

Pax

Share this post


Link to post
Share on other sites

Vorab Danke bexpro :cool:

ShopVersion: 4.0.12

Also.. das ganze passiert eigentlich nur wenn der Kunde den Browser offen hat und angemdelt ist. Sobald ein Artikel welcher Postversand hat im Warenkorb liegt und er zur Kasse geht, Zahlungsweise wählt und Geschäftbedingungen akzeptiert.

Danach kommt die Übersicht Bestellung bestätigen! Ab hier könnte sich der Kunde es ja nochmals anders überlegt haben und kehrt zurück in den Warenkorb und löscht den Artikel welcher versandkosten hat. Nach dem der Warenkorb wieder leer ist, schmeißt er sich den Downloadartikel in den Warenkorb und möchte ganz normal wie vorher bestellen.

Leider gibt es nun den Fehler , es ist nicht mal mehr nötig, dass man die Geschäftsbedingungen akzeptieren muss! Er überspringt die Anweisung einfach ob der Haken drin ist oder nicht, es wird nicht kontrolliert.

Des Weiteren hat man nun unter Bestellung bestätigen ja die Gesamtübersicht mit zum Bsp.

Zwischensumme: 15,12 EUR

Postversand: 7,52 EUR

Gesamtsumme: 22,64 EUR

richtig müßte es aber so heißen:

Zwischensumme: 15,12 EUR

Gesamtsumme: 15,12 EUR

und unter Lieferadresse steht nun auch noch die Option

Versandart:

Postversand

Die Ware wird Ihnen auf dem normalen Postweg zugesendet.

[bearbeiten]

aber eigentlich dürfte nur das hier stehen:

[bearbeiten]

Aber schon merkwürdig trotz Downloadartikel. Im Adminsystem steht der Artikel eindeutig auf digital also quasi kein Postversand möglich.

Bleibt also nur noch übrig, dass etwas mit der sessionID nicht stimmt, zumindest wird dem System nicht mitgeteilt das bei Artikeln mit Postversand welche im Warenkorb gelöscht werden der Postversand ungültig wird.

Mfg

Pax

PS: Reicht das?

Share this post


Link to post
Share on other sites

Reicht !

Ich habe den Fehler nie finden können weil beim zweiten Mal wie du den beschreibt, der Shop sofort in Zahlungsweisen springt ,ohne die Versandkosten zu zeigen, was völlig normal ist und auch so wie es sein soll, jedoch ein klick später auf Weiter bei der Bestell Zusammenfassung findet man Versandart und Versandkosten !:mad::mad::mad::mad:

Jetzt weiß ich wo ich suchen soll und werde am WE oder noch früher versuchen ne Lösung zu finden.

Share this post


Link to post
Share on other sites

Na ja, Thema ist schon alt aber hier die Lösung

ist leider in der Version 4.0.13 NICHT gefixt worden !!

Hat mich wieder 2 Stunden Zeit gekostet die Lösung zu suchen :(

xtCore\pages\checkout.php

[Line 338]


if($_SESSION['cart']->type == 'virtual'){
//EDIT BY LUKAS
// if cart only virtual delete session shipping if exist -> no shipping cost for download products
if (isset($_SESSION['cart']->sub_content['shipping'])) unset($_SESSION['cart']->sub_content['shipping']);
if (isset($_SESSION['selected_shipping'])) unset($_SESSION['selected_shipping']);
//EDIT END
if($page_data=='shipping')
$page_data = 'payment';
}
[/PHP]

Share this post


Link to post
Share on other sites

hi,

bei der 4.0.13 noch nicht kontrolliert, bei der 12er passiert das Gleiche mit Zahlungrabatten ( habe das aber genauso gelöst ) - beim Rücksprung nach Eingabe einer Zahlungsart mit Zahlungsrabatt erscheinen "unmögliche"

Preise, weil der Zahlungsrabatt nicht aus der Session gelöscht wird.

Grüsse

Na ja, Thema ist schon alt aber hier die Lösung

ist leider in der Version 4.0.13 NICHT gefixt worden !!

Hat mich wieder 2 Stunden Zeit gekostet die Lösung zu suchen :(

xtCore\pages\checkout.php

[Line 338]


if($_SESSION['cart']->type == 'virtual'){
//EDIT BY LUKAS
// if cart only virtual delete session shipping if exist -> no shipping cost for download products
if (isset($_SESSION['cart']->sub_content['shipping'])) unset($_SESSION['cart']->sub_content['shipping']);
if (isset($_SESSION['selected_shipping'])) unset($_SESSION['selected_shipping']);
//EDIT END
if($page_data=='shipping')
$page_data = 'payment';
}
[/PHP]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...