Jump to content
xt:Commerce Community Forum
Sign in to follow this  
yhs

kein 404 Fehler bei falscher URL

Recommended Posts

Bei Aufruf einer falschen URL wird immer auf die Startseite ohne jede Fehlermeldung (Status 200) umgeleitet.

Sollte doch bei Version 4.0.12 funktionieren dass 404 ausgegeben wird?!

Mod Rewrite URL: false

404 Seite bei falscher Url: true

Hat jemand eine Idee?

Share this post


Link to post
Share on other sites

Ich habe gerade das gleiche Problem und ich kann den Fehler nicht finden. Irgendwie bin ich zu dieser Stunde zu blöd dazu. Ich habe seit zwei Wochen nichts an der .htaccess geändert und irgendwann die letzten Tage ist mir aufgefallen, dass ich alles hinter der Domain meines Kunden tippen kann ohne dass wir eine 404 Fehlermeldung bekommen.

Hat jemand vielleicht gerade einen Ansatz für mich?

ErrorDocument 404 geht nicht. Nur spezielle Teile werden per mod_rewrite behandelt.

Die 404 Seite lässt sich direkt aufrufen.

Share this post


Link to post
Share on other sites

Konkrete Fehlerbeschreibung:

Wird die URL http://www.domain.de/IRGENDWAS aufgerufen, lande ich konstant auf der Startseite, aber nicht per 301 Redirect, sondern so, als würde es die URL tatsächlich geben. Dadurch entsteht doppelter Content für Suchmaschinen etc.

Rufe ich jedoch die URL http://www.domain.de/de/IRGENDWAS auf, erhalte ich prompt die 404-Seite mit den korrekten Header-Informationen.

Das hängt wohl mit den sprachabhängigen URLs zusammen, was jedoch ziemlich schlecht ist. Die Domain habe ich lediglich sprachabhängig gelassen, da die Seite demnächst übersetzt werden soll. Daher war es sinnvoll diese Sprachabhängigkeit drin zu lassen.

Um auch die Frage zu beantworten, die mir der Support als erstes gestellt hat:

Frage: Haben Sie denn auch die Option aktiviert?

Antwort: Selbstverständlich, sonst würde ich keine 404 Seite bei /de/IRGENDWAS erhalten.

Share this post


Link to post
Share on other sites

fast zwei Jahre später, gibt es eine Lösung dazu?

Konkrete Fehlerbeschreibung:

Wird die URL www.domain.de/IRGENDWAS aufgerufen, lande ich konstant auf der Startseite, aber nicht per 301 Redirect, sondern so, als würde es die URL tatsächlich geben. Dadurch entsteht doppelter Content für Suchmaschinen etc.

Rufe ich jedoch die URL www.domain.de/de/IRGENDWAS auf, erhalte ich prompt die 404-Seite mit den korrekten Header-Informationen.

Das hängt wohl mit den sprachabhängigen URLs zusammen, was jedoch ziemlich schlecht ist. Die Domain habe ich lediglich sprachabhängig gelassen, da die Seite demnächst übersetzt werden soll. Daher war es sinnvoll diese Sprachabhängigkeit drin zu lassen.

Um auch die Frage zu beantworten, die mir der Support als erstes gestellt hat:

Frage: Haben Sie denn auch die Option aktiviert?

Antwort: Selbstverständlich, sonst würde ich keine 404 Seite bei /de/IRGENDWAS erhalten.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...