Jump to content
xt:Commerce Community Forum
Sign in to follow this  
oldbear

4.0.13 erste Tests

Recommended Posts

hi,

diese Stille wie Grabesruh .... das war bei der 12er anders.

Ein paar erste Eindrücke aus dem Backend:

- Im Bereich Suchmaschinen-Einträge sind dazugekommen:

SEO-URLs für Seiten (pages):

Meta-keywords automatisch generieren?:

Bin gespannt, was sich dahinter verbirgt. Eine neue Klasse categories_to_mastercat ist auch noch da ... bin noch am Testen.

- Im ganzen Backend gibt es jetzt nicht mehr den Button "Abbrechen" - gut, einen Tab kann man ja auch so schliessen - aber der alte Hund, das auch bei Abbruch ein neuer Datensatz angelegt wird, ist weiterhin vorhanden

- Bei den Kategorien wird jetzt links in der West-Navigation die ID mit angezeigt . Danke !

- In der Installationsroutine ist noch ein dicker Hund: in der verschlüsselten xtAdmin/ejsadmin.php wird versucht, auf die xt_config_ zuzugreifen ( ??? ).

Bypass war ein erneuter Import der xt_config als xt_config_

- bei den Plugins sind dazugekommen:janolaw_agb_hosting,xt_trusted_shops_schutz,xt_gate2shop

- In der xt_products sind auch neue Felder; was die genau machen, suche ich noch, haben aber interessante Namen: products_transactions, products_owner -> das sieht doch nach Fortschritten bei Multishops aus ?

- beim Media-Manager und beim E-Mail-Manager sieht oberflächlich alles aus wie bisher

- bei Konfiguration -> Performance gibt es jetzt einen neuen Punkt: Suchanfragen trennen ( ? )

- bei den Admin-Rechten ist die Anzahl der Einträge deutlich gestiegen ( sind jetzt 3 Seiten )

- lt. Auskunft von Kollegen bleiben bei Master-Slave jetzt die Einträge im Dropdown stehen ... was in dem Bereich allerdings "gehackt" bzw. individuell angepasst wurde, verdient eine eingehende Prüfung.

Also, es hat sich deutlich was getan , aber was ? Da müssen wir wohl noch ein bisschen warten, bis die Doku nachkommt, Handbuch ist noch alter Stand.

Denke, die neue Version ist für Plugin-Entwickler schon eine Herausforderung, und bisher erprobte Eingriffe in die Klassen kann man wohl auch vergessen - "never touch a running system" dürfte für den Rest des Jahres die beste Methode sein, aber für neue Shops, why not .....

Auch die bekannten Modulentwickler dürften ( beim Blick in den Quellcode ) noch nicht mit allen Anpassungen auf die 4.0.13 fertig sein ( wobei BUI dabei bestimmt einen kleinen Vorteil hat ... seis ihm gegönnt )

Sonntägliche Grüsse

euer oldbear

Share this post


Link to post
Share on other sites

Da sich hooks nicht verändern, muss auch bei modulen nicht wirklich was angepasst werden.

Ein tip ist auch noch ein blick unter Sprachen, neben de/en is nun auch in der .13 CN,FR,IT,JP,LT,NL,PL,RU und TW verfügbar ;)

Share this post


Link to post
Share on other sites

in der library ? danke für den Hinweis !

Irgendwie ist aber twitter nicht mein Ding .... wahrscheinlich zu alt :-)

Aber irgendeiner wills bestimmt ! Also muss ich wohl oder über mich damit befassen.

Grüsse

Share this post


Link to post
Share on other sites

wie teste ich am besten obs mit meinem shop läuft?

-local/zweitdomain installieren

-aktueller shop db exportieren und beim .13er importieren?

***

installation bricht bei den plugins ab:

Fatal error: Uncaught exception 'ADODB_Exception' with message 'mysql error: [1062: Duplicate entry 'xt_reviews' for key 'text'] in EXECUTE("INSERT INTO xt_acl_nav (`pid` ,`text` ,`icon` ,`url_i` ,`url_d` ,`sortorder` ,`parent` ,`type` ,`navtype`) VALUES (NULL , 'xt_reviews', 'images/icons/user_comment.png', '&plugin=xt_reviews', 'adminHandler.php', '4000', 'shop', 'I', 'W');") ' in /kunden/herbaculix.com/rp-hosting/12/13/domain.de/xtFramework/library/adodb/adodb-exceptions.inc.php:78 Stack trace: #0 /kunden/herbaculix.com/rp-hosting/12/13/domain.de/xtFramework/library/adodb/adodb.inc.php(918): adodb_throw('mysql', 'EXECUTE', 1062, 'Duplicate entry...', 'INSERT INTO xt_...', false, Object(ADODB_mysql)) #1 /kunden/herbaculix.com/rp-hosting/12/13/domain.de/xtFramework/library/adodb/adodb.inc.php(893): ADOConnection->_Execute('INSERT INTO xt_...', false) #2 /kunden/herbaculix.com/rp-hosting/12/13/domain.de/xtFramework/classes/class.plugin.php(0) : eval()'d code(2): ADOConnection->Execute('INSERT INTO in /kunden/herbaculix.com/rp-hosting/12/13/domain.de/xtFramework/library/adodb/adodb-exceptions.inc.php on line 78

Edited by sams

Share this post


Link to post
Share on other sites

Hallo zusammen,

so, wenn jemand folgende Fehlermeldung erhält:

"Site error: the file /homepages/10/d[xyz]/htdocs/Shop/xtUpdater/index.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator."

Einfach nur seine selbst erstellte php.ini Datei in den "xtUpdater" Ordner reinkopieren und noch mal die index.php starten.

Herzliche Grüße

Nils :D

Edited by NilsK
Fehler selbst gefunden :-)

Share this post


Link to post
Share on other sites

Guten Morgen,

ich habe nach dem 13er Update nur ein leeres, weißes Backend.

Die Ordnerrechte habe ich von 755 auf 777 geändert, die Dateien liegen noch bei 644.

Der Admin Bereich lädt auch, aber zeigt nichts an, der Shop ist ebenfalls vorhanden, scheint also alles funktioniert zu haben.

Hat jemand eine Idee, wie ich den Admin Bereich sehen kann? :D

Herzlichen Dank.

Herzliche Grüße

Nils

Share this post


Link to post
Share on other sites

Lizenzdatei wurde gestern Abend auf Maxversion angepaßt.

Müßen die ganzen Dateien im Ordner auch jeweils auf 777 stehen? Sind wie gesagt auf Voreinstellung 644.

Viele Grüße

Nils

PS: Mail ist raus.

Share this post


Link to post
Share on other sites

Wegen der Lizenz versteh ich nur ein nicht ganz. Warum kommt bei mir die Fehlermeldung:

-License not allowed to use Version 4.0.13, your allowed Version is 4012 - please contact xt:Commerce Support, [email protected]

wenn ich die gleiche Lizenz wie beim 4.0.12 Shop nehme?

Im Prinzip ist es auch fast egal wie oder warum, ich muss das Update so oder so machen, da der Shop permanent abstürzt. Mal die Datenbank und mal der Apache Dienst. Waran es liegt weiß ich und behoben werden kann es nur durch ein Update.

Share this post


Link to post
Share on other sites

Hallo zusammen,

so, alle Ordner sind auf 777 eingestellt (bis auf "conf").

Die Dateien haben meist 644, wobei es auch einige gibt die 777 haben. Ist das falsch oder richtig?

Naja, jedenfalls sehe ich mein Backend immer noch nicht, obwohl es so aussieht, als ob es geladen wird (Quelltext zeigt es an).

Ticket ID: IYW-894581 :D

Herzliche Grüße

Nils

Share this post


Link to post
Share on other sites

-> weisse seite im Admin

Hier wurde der Shop ohne www. installiert, jedoch der Admin mit www. aufgerufen.

Bzw hier war es komplett falsch konfiguriert. Shop Domain ohne www. und Url http mit www.

Bitte Handbuch lesen und den Einstellungen dort folgen :D

-> Adminbereich immer mit der URL aufrufen mitwelcher dieser installiert wurde.

Edited by mzanier

Share this post


Link to post
Share on other sites

Genau das war es - herzlichen Dank auch an Herrn Hinsche, der mir das per E-Mail mitgeteilt hat.

Lag dann wohl doch an der geänderten Lizenzdatei - bei der allerersten Shopinstallation war es genau umgekehrt.

Habe es auch im Adminbereich geändert, damit das Dashboard angezeigt wird. ;)

Dankeschön! :D

Herzliche Grüße

Nils

Share this post


Link to post
Share on other sites

hallo zusammen,

wie auf der ersten seite aufgelistet!... -

- eine neue einstellung ist möglich.....

"Suchanfragen trennen?:"

was bedeutet diese funktion? wann sollte diese auf true gesetzt werden?

vielen dank im voraus

gruß

christian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...