Jump to content
xt:Commerce Community Forum
Sign in to follow this  
giller

PayPal nach Update auf 4.0.13 geht nicht

Recommended Posts

Aufgeführt sind in der Übersicht der Anleitung zunächst:

./xtCore/pages/checkout.html

./xtCore/pages/navigation/breadcrumb.html

./xtCore/pages/product/product.html

./xtCore/pages/account_history_info.html

./xtCore/pages/checkout/subpage_payment.html

./xtCore/pages/checkout/subpage_shipping.html

./index.html

Weiter unten finden wir noch weitere Dateien, die oben fehlen:

./xtCore/product_listing/product_listing_v1.html

./xtCore/pages/adress_book.html

In Summe angeblich nur 9 Dateien, die das Template betreffen. Tausche ich alle 9 Datein meines Templates mit den Originaldatein des XTC-default Templates passiert.... leider gar nichts... sprich meine Änderungen müssten auch korrekt sein und es gibt also weitere Dateien, die angepasst werden müssen (zumindest bei meinem Template)... nur welche?? Welche betreffen das "Problem" überhaupt?

den Ordner "checkout" habe ich testweise komplett überschrieben... hier liegt der fehler nicht.. nichts passiert

Edited by extra

Share this post


Link to post
Share on other sites

Also die Update Anleitung ist komplet

Ansonsten die module deinstalieren und wieder instalieren.

Achtung bei mir war der fehler eine selbst eingebundene javascript in der js.php im tamplate

Share this post


Link to post
Share on other sites

Hallo,

welche Dateien im einzelnen ausgetauscht werden müssen,weiss ich leider auch nicht.

Ich habe jedoch einige von denen, die ich noch nicht in meinem eigenen Template bearbeitet habe durch die Original 4.0.13 Dateien ersetzt, anschließend lief die Zahlung reibungslos.

Ich würde es mit folgenden Dateien probieren:

xtcore/pages/payment/payment_default.html

xtcore/pages/checkout/subpage_confirmation.html

xtcore/pages/checkout/subpage_pay.html

xtcore/pages/checkout/subpage_pay_iframe.html

xtcore/pages/checkout/subpage_payment.html

xtcore/pages/checkout/subpage_shipping.html

xtcore/pages/checkout/subpage_success.html

xtcore/pages/shipping/shipping_default.html

xtcore/pages/checkout.html

xtcore/pages/cart.html

xtcore/pages/address_book.htm

xtcore/boxes/box_cart.html

xtcore/forms/shipping.html

Gruß items4u

Share this post


Link to post
Share on other sites

@giller: Module deinstallieren und installieren kann es bei mir nicht sein, da ich einen Mandanten habe, der nach dem Update problemlos funktioniert. Da es mit dem Original-Template funktioniert muss es muss also an meinem Template liegen.

Ein selbst eingebautes Javascript verwende ich auch, nehme ich dieses raus, funktioniert der checkout allerdings auch nicht.

Share this post


Link to post
Share on other sites

danke items4u, das Ersetzen der angegebenen Dateien durch die Original-Template-Dateien bringt leider auch keine Änderung.

Weder das Ersetzten der 9 geänderten Dateien, noch die von Dir genannten bringen eine Änderung beim Checkout

Share this post


Link to post
Share on other sites

Die Lösung:

wenngleich ich noch nicht genau weiß wo der Haken liegt: bei mir ist es die "index.html", die den ganzen Ärger entstehen lässt. Ersetze ich nur diese durch die im Original-template funktionieren alle Zahlungsweisen / Weiterleitungen..

zumindest weiss ich jetzt wo genau ich ansetzen muss..

Share this post


Link to post
Share on other sites
Guest cleverzoeger

Unser Kunde hat dies auch bemerkt, am Montag werden wir wohl einen Bugfix veröffentlichen :cool:

Share this post


Link to post
Share on other sites

das ist wohl genau das, was die IT bis heute richtig teuer macht.... stundenlanges Fehler suchen... der Teufel liegt im Detail wie man so schön sagt:

Meine Index.html war bis auf einen Punkt in Ordnung:

Ich habe am Anfang (sicher, nicht notwendig, mit der alten Version gings aber dennoch) das Stylesheet im Code eingebunden:

<link href="templates/templatename/css/xy.css" rel="stylesheet" type="text/css" />

Diese eine Zeile entfernen und schon funktioniert die gesamte Funktionalität des Shops bezgl. Zahlungsoptionen wieder..... von daher war der Ansatz gar nicht verkehrt, alles was zusätzlich eingebunden ist könnte Fehler verursachen...

der berühmte Stein, nein, ein Berg voller Steine kullert gerade vom Herzen ;-)...

Share this post


Link to post
Share on other sites

bei mir funzt zwar das frontend einwandfrei. leider bekommt das backend nicht mehr viel davon mit. der bestellstatus bleibt selbst bei abgeschlossener Zahlung via paypal auf "offen"! keinerlei meldung, kein fehler, kein IPN... nüscht!

Share this post


Link to post
Share on other sites

Gibts dazu schon neues? so können unsere Mitarbeiter nicht mehr arbeiten... das ist unglaublich zeitraubend jede bestellung bei paypal zu suchen... Es muss doch irgendeinen anhaltspunkt geben?! KEINE IPN bei paypal mehr!

hat keiner außer mir diese probleme?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...