Jump to content
xt:Commerce Community Forum
Sign in to follow this  
ls24de

SSL und Strato

Recommended Posts

Hallo,

Habe folgendes Problem. Ich versuche die SSL-Verbindung einzurichten aber egal wie es mache, es will einfach nicht klappen. Folgende angaben habe ich:

Der Shop liegt auf einer Domain die Direkt in das Veyton Verzeichnis leitet. Der Hoster ist Strato.

Folgende Einträge habe ich Vorgenommen:

• Shop Domain

http://www.meine-webseite.de

• URL https

https://www.ssl-id.de/meine-webseite.de/

das Problem dabei jetzt ist, wenn man die Seite normal Aufruft und die Artikel betrachtet ist noch alles ok. Wenn man jedoch auf Warenkorbklickt wo die SSL umleitung aktiviert wird, zeigt er nur noch den html code an und nicht mehr die Grafiken.

Share this post


Link to post
Share on other sites

Das Problem ist, dass xt:C an deine lizensierte Domain gebunden ist, da dein SSL über einen sogenannten SSL-Proxy läuft dürfte das eigentlich noch weitere Fehler bringen.

Lösung wäre SSL auf eigenem Server zu betreiben, aber ich vermute du betreibst nur ein Hostingpaket mit geteilter IP, da ist es nicht möglich.

Gruß Marcus

Share this post


Link to post
Share on other sites

habe das gleiche problem, neues lizenzfile beantragt. aber ls24de lässt mich kaum hoffen...

schön vorher alles lokal getest... aber das liess sich nicht testen. nu steh ich da mit meinem live shop

Share this post


Link to post
Share on other sites

Wurde diese Handhabung in 4.0.13 geändert oder besteht das schon immer so? Ich habe nämlich auch nach dem Update bzw. Neuinstallation auf 4.0.13 seit Tagen das Problem, dass die Seiten, die über SSL aufgerufen werden, nicht korrekt zum Ziel führen (z.B. im Checkout Prozess geht es nicht weiter oder beim Kontaktformular wird ein korrekt eingegebener Captcha Code angemeckert etc.) !? In Version 4.0.12 lief alles einwandfrei. Falls dies geändert wurde, wäre ein diesbezüglicher Hinweis im Changelog oder in der Anleitung sehr hilfreich! Ich hatte vorher beim Kauf der Lizenz die SSL Domain auch nicht angegeben und Veyton hat trotzdem funktioniert!!

Danke + Viele Grüße

Share this post


Link to post
Share on other sites

positiv überrascht bekam ich um diese uhrzeit noch einen aktualisiertes lizenzfile.

nur leider behebt das NICHT das problem.

Also ich habe dem ganzen jetzt 8h gewidtmet und kann nur feststellen das hier ganz dolle der wurm drin ist.

liegt das jetzt nur daran das ich nen ssl proxy habe? läufts bei den anderen fein?

Edited by sams

Share this post


Link to post
Share on other sites

Das hat an sich nicht mit 1&1 zu tun, sondern damit ob das gebuchte Paket eine eigene IP-Adresse hat oder nicht. Denn nur dann kann man auch ein eigenes Zertifikat verwenden. Es ist immer die sauberere Lösung mit einem eigenen Zertifikat, schließlich sind die erweiterten URLs nicht gerade kundenfreundlich. Wenn ihr auf eigene vServer/Server verzichten wollte, bleibt nur der SSL-Proxy und da scheint es ja jetzt die Lösung zu geben.

Share this post


Link to post
Share on other sites

Ich bin auch gerade beim Aufbau meines Shops zu gange und habe Probleme mit dem SSL-Proxy von Strato. Ich habe mir den Bugfix aus dem Helpdesk geladen und mir eine neue license.txt zuschicken lassen und diese nach /lic/ kopiert.

Wenn ich nun unter den Mandanten den SSL wie in der Anleitung einrichte, kommt immer, wenn ich in den Warenkorb klicke ein 404 Error.

Meine Einstellungen:

Shop Domain: www.fantasy2go.de


SSL Domain: www.ssl-id.de


Url http: http://www.fantasy2go.de


Url https: https://www.ssl-id.de/fantasy2go.de

Ein Aufruf über https://ssl-id.de/fantasy2go klappt zwar, ein klick in den Warenkorb bringt aber wieder den 404 Error.

Muss ich sonst noch etwas machen? Wo finde ich evtl. diese database_handler.php, von der hier schon gesprochen wurde?

Share this post


Link to post
Share on other sites

Ich bin auch gerade beim Aufbau meines Shops zu gange und habe Probleme mit dem SSL-Proxy von Strato. Ich habe mir den Bugfix aus dem Helpdesk geladen und mir eine neue license.txt zuschicken lassen und diese nach /lic/ kopiert.

Wenn ich nun unter den Mandanten den SSL wie in der Anleitung einrichte, kommt immer, wenn ich in den Warenkorb klicke ein 404 Error.

Meine Einstellungen:

Shop Domain: www.fantasy2go.de


SSL Domain: www.ssl-id.de


Url http: http://www.fantasy2go.de


Url https: https://www.ssl-id.de/fantasy2go.de

Ein Aufruf über https://ssl-id.de/fantasy2go klappt zwar, ein klick in den Warenkorb bringt aber wieder den 404 Error.

Muss ich sonst noch etwas machen? Wo finde ich evtl. diese database_handler.php, von der hier schon gesprochen wurde?

Habe das gleiche Problem. Die database_handler.php hat keine Abhilfe geschaffen. Habe mich für Strato entschieden, da hier das Shopsystem im Paket enthalten ist, und jetzt funktioniert nicht mal die absolute Grundvoraussetzung = SSL.

Wie bringt man das SSL nun zum laufen?

Share this post


Link to post
Share on other sites

Wie bringt man das SSL nun zum laufen?

Ich habe diesbezüglich nun ein Ticket beim xt:commerce Support eröffnet und hoffe, dass sich darüber was tut. Der Fehler scheint ja reproduzierbar.

Sobald es Neuigkeiten gibt, poste ich hier...

Share this post


Link to post
Share on other sites

Lösung für Strato-Kunden mit SSSL Problemen

Falls ihr das Problem habt, dass die Links im SSL Modus nicht richtig verweisen (unvollständige Installation), solltet Ihr das Paket nochmals installieren und erneut den Bugfix einfügen. Dieser behebt auch das Problem des verschwindenden Templates. Der Support hatte Recht und es fehlten scheinbar beim installieren die ein oder andere Datei.

Nachtrag für alle die nach den richtigen Domaineinstellungen suchen:

Shop Domain: www.domain.com

SSL Domain: https://www.ssl-id.de

Url http: http://www.domain.com

Url https: https://www.ssl-id.de/domain.com

Edited by shops

Share this post


Link to post
Share on other sites

Lösung für Strato-Kunden mit SSSL Problemen

Falls ihr das Problem habt, dass die Links im SSL Modus nicht richtig verweisen (unvollständige Installation), solltet Ihr das Paket nochmals installieren und erneut den Bugfix einfügen. Dieser behebt auch das Problem des verschwindenden Templates. Der Support hatte Recht und es fehlten scheinbar beim installieren die ein oder andere Datei.

Nachtrag für alle die nach den richtigen Domaineinstellungen suchen:

Shop Domain: www.domain.com

SSL Domain: https://www.ssl-id.de

Url http: http://www.domain.com

Url https: https://www.ssl-id.de/domain.com

Nach einer Neuinstallation von Veyton funktioniert SSL nun. Leider aber NICHT in Verbindung mit mod_rewrite = true. Diese Option bräuchte ich aber für für SEO!

Share this post


Link to post
Share on other sites

Die SSL Funktion ist momentan nur in Verbindung mit Mod_Rewrite möglich. Schaltet man zu dieser Kombination zusätzlich die 404 Weiterleitung ein, leiten die SSL geschützten Seiten auf die 404er um.

Die gute Nachricht ist, der XT Support hat sich der Sache angenommen und arbeitet an einer Lösung. Hoffen wir mal, dass dieses Problem zeitnah gelöst wird, da ein Einsatz der Software in diesen Zustand nicht richtig möglich ist.

----------

SHOPS

Share this post


Link to post
Share on other sites

1. Neue license.txt bei XT-Commerce anfordern: [email protected] (Lizenznummer angeben)

2.license.txt im Ordner lic ersetzen

3. Shop-Einstellungen/Mandanten/Shop

Shop Domain: www.domain.de

SSL Domain: https://www.ssl-id.de

Url http: http://www.domain.de

Url https: https://www.ssl-id.de/domain.de

4. Folgende Datien runterladen:

Bugfix für 4.0.13: SSL Proxy, Strato Power Plus - Powered By Kayako SupportSuite

5. Dateien ersetzen:

Ersetzen Sie die Datein xtCore/main.php und xtCore/main_slim.php

6. Einstellung/Konfiguration/Suchmaschinen: Mode Rewrite URL: false

Viel Spaß beim verkaufen

Edited by mctony

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...