Jump to content
xt:Commerce Community Forum
Sign in to follow this  
chefjaeger

Leere Mail durch Kontaktformular

Recommended Posts

Es ist natürlich traugig das es seitens Helpdesk, keine Info gibt,

Sicher ist der Fehler reproduzierbar. Bin behelfsweise erstmal auf ein anderes Kontaktformular umgestiegen, aber das ist auch nicht Sinn und Zweck der Sache ein Kontaktformular per Frame einzubinden. :mad:

Aber besser so, anstatt potentielle Kunden zu verlieren.

Share this post


Link to post
Share on other sites

Bei uns hatte sich herausgestellt, das der Fehler immer dann passiert, wenn sich in der Nachricht ein oder mehrere Zeilenumbrüche befinden. Was bei höflicher Schreibweise mit Begrüßung etc durchaus immer vorkommt. Ist also demnach als BUG einzustufen, da der Fehler im System liegt

Lösung kann ich leider nicht anbieten, da ich es selbst nicht gefixt habe. Aber vielleicht hilft manchem ja dieser Hinweis schon weiter. Tretet halt XT auf die Füße deswegen ;)

Share this post


Link to post
Share on other sites

Das es bis heute auch keinen patch gibt, nervt mich ein wenig. Ich habe es ja lösen können, aber halt Quick & Dirty und nicht für den Alltag gebräuchlich. Ich strippe einfach sämtliche Entities und Special Chars weg.

Nun ja, was soll ich dazu sagen. Wie ich das sehe, bekommen es ein paar Leute gar nicht mit, dass es nicht funktioniert. Und was ist schlimmer, als eine Nachricht eines Kunden nicht zu erhalten. Der Kunde denkt, warum antwortet die Firma nicht... ach mit denen will ich nichts zu tun haben. Die Firma fragt sich, warum läuft es so schlecht.

Ganz ganz schlecht. Ich hoffe der Fehler wird gefunden.

Share this post


Link to post
Share on other sites

Es ist natürlich traurig das ich seit dem 15.10.10 vom Support keine Antwort bekommen habe.

Die Antwort auf das Ticket seitens XT ist lachhaft.

Da damit der Shop nicht lahm gelegt wird, hat dieser Fehler auch nicht Vorrang.

Ihr xt:Commerce Team

Wenn es eine kostenlose Software wäre, könnte ich diese Antwort verstehen.

@farbhelden

Kannst Du mir die Lösung mal schreiben, per mail oder PN ?

Share this post


Link to post
Share on other sites

Es ist natürlich traurig das ich seit dem 15.10.10 vom Support keine Antwort bekommen habe.

Die Antwort auf das Ticket seitens XT ist lachhaft.

Wenn es eine kostenlose Software wäre, könnte ich diese Antwort verstehen.

@farbhelden

Kannst Du mir die Lösung mal schreiben, per mail oder PN ?

Bitte bei der Wahrheit bleiben.

Es wurde auch zurückgeschrieben das dieses Problem aufgenommen wurde und überprüft wird.

Ein Bugfix kann nun geladen werden: Bugfix für 4.0.13: Umbruch in Kontaktformular - Powered By Kayako SupportSuite

Share this post


Link to post
Share on other sites

Leider muss ich sagen, dass der Bugfix nicht den gewünschten Erfolg gebracht hat. Bei Sonderzeichen wie <>!"§$%&/()= passiert es ab und zu immer noch, je nach dem wie es verwendet wird. Kann jemand von dem gleichen Problem sprechen?

Share this post


Link to post
Share on other sites

Hallo,

ich bin ja relativ neu hier, und kämpfe mich gerade durch die Forenbeiträge. Alles wird sofort ausprobiert.

Gerade bin ich auf dieses Thema gestoßen. Bei mir bleibt die Email leer. Also wie hier beschrieben.

Gibt es da eine Lösung? Das Bugfix habe ich schon installiert.

Danke.

Share this post


Link to post
Share on other sites

...gibt es dazu etwas Neues? Wir haben das Problem auch. Nicht Zeilenumbrüche sind das Problem, sondern die angesprochenen Sonderzeichen.

Wir benutzen eine Sozusagen Kopie des Kontaktformulars auch, damit Kunden dort Muster von Artikeln bestellen können. Dort werden auch manchmal die gewünschten Muster nicht übermittelt. Das ist echt schlecht!

Lösung?

Share this post


Link to post
Share on other sites

Ich glaub ich dreh durch... ich hab das gleiche Problem seit einem halben Jahr und dachte ich wäre alleine damit. Wie ein bekloppter versuche ich schon seit Monaten herauszufinden wo das Problem liegt. Hier einer meiner Posts

Wir müssen hinter Kunden hinterherlaufen wie Idioten und VERLIEREN Kunden. Angebote und Anfragen gehen verloren. Lieferzeiten können nicht eingehalten werden, oder werden verpasst und Ressourcen, Zeit Geld geht flöten. Unsere Kunden sind verärgert. Kunden verlassen uns mangels Vernachlässigung Ihrerseits. Firmen Image wird geschädigt... das ist kein verdammter Dreck unterm Teppich, dass ist der Mülltransporter im Wohnzimmer.

Von Support bekomme ich nur zu hören das daran gearbeitet wird. Wie lange noch verdammt noch mal? Kann es sein, dass die "wenigen" internen Ressourcen für wichtigere Dinge eingeteilt werden müssen, als meiner Meinung nach, diesen groben und unzumutbaren Fehler zu beseitigen? Könnt Ihr euch nicht vorstellen welche massiven Probleme wir mit unseren Kunden haben, oder könnt Ihr schlicht und einfach diesen Fehler nicht beheben?

Ich befürchte das die dezente Zurückhaltung des xt-commerce Teams darauf hindeutet, das in Veyton ein irreparabler Fehler gemacht worden ist, der wohl erst und bestenfalls frühstens mit einer einer neunen Version behoben wird/werden kann.

Wie dem auch sei. Ich würde mir an dieser Stelle mehr Informationen vom xt Team wünschen, als monatelang im dunkeln stehen gelassen zu werden. Man fühlt sich hier regelrecht im stich gelassen. Der Shop mag zwar gut sein, aber das ist kein Grund den Kunden so im ungewissen zu halten. Schließlich sind wir eure Kunden und da sollte man mehr auf solche Problematik eingehen und Kundenbindung betreiben.

Ich möchte hier niemanden angreifen, aber vielleicht könnte man ja auch durch Erfahrungsaustausch dem Problem auf die Spur kommen!? Weiß der Geier, aber verdammt noch mal REDET!

Danke an @lmbd8 für die Info!

Share this post


Link to post
Share on other sites

Ok und wir haben uns bei 3 Kunden gewundert das wir keinen Text bekommen haben.

Wir haben übrigens auch geupdatet auf .13! Und nach de Update gab es viele massive Probleme (Plugins hatten keinen Funktion mehr und mussten neu installiert werden etc.). Das war alles in allem mit sehr vielen Bugs und Problemen behaftet.

Aber das jetzt immer noch weitere Fehler auftauchen ist schon sehr bedenklich und einer professionellen Shopsoftware eigentlich nicht zuzumuten.

Schade das der Hersteller hier immer sehr spät oder gar nicht reagiert. Wir fühlen uns auch mit den Minor und Major Bugs sehr alleine gelassen. Hier wird immer nur auf die nächste Version vertröstet oder man soll einen Supportvertrag abschließen.

Das ist ehrlich gesagt doch keine Lösung für Massive Bugs?

Sollen wir als Kunden denn dafür bezahlen das das System ohne Bugs läuft? Das kann doch nicht der Ansatz sein oder doch? Auch ein verweis auf die neue Version ist ehrlich gesagt nicht haltbar da diese Timelines ja nicht kommuniziert werden!

Wir sind sehr verärgert! Und was machen wir jetzt alle mit dem hier beschreibenen Problem? Ich hab keine Ahnung und der Hersteller releast ein Bugfix der nicht funktioniert?

hmmm...

Share this post


Link to post
Share on other sites

Dieses Problem hatte ich auch, genau so.

Lehre Emails usw.

Jetzt kommt es allerdings noch schlimmer....

Contact.php wird gar nicht mehr geladen.

Auf den link "Kontakt" drücken und mann bekommt eine lehre Seite.

Helpdesk will nur helfen gegen (pass auf !!) 120 EURO die Stunde.

Und das für ne Fehler die nicht unser ist. Bezahlen für Software dürfen wir allerdings wol für die Software, um heraus zu finden das knapp 2 Monate Später die Software Gratis wird.... na Geil!

Was ich allerding auch komisch finde ist der Link:

Das script heist contact.php

Im Shop ist der vorgeschriebene Link allerdings www.meineseite.de/Kontakt

Gebe ich .../contact.php ein bekomme ich eine 404 Fehler.

Wo soll der Fehler liegen?

Hoffe jemand kann helfen,

vom Xt-commerce brauch ich nichts zu erwarten

Share this post


Link to post
Share on other sites

Wir haben das gleiche Problem mit den Sonderzeichen. Durch den Bugfix wurde anscheinend nur der Zeilenumbruch-Bug behoben. Folgender Nachrichteninhalt führt zu einer leeren Kontaktanfrage:

----

Sonderzeichentest & (test) ! ? 5% "test" 'test1' = 1ß test / test \test

----

Ich scheue mich leider vor einer Quick&Dirty Lösung per JavaScript Replace. Viel lieber wäre mir die endgültige Behebung des Problems. Manuell geht's ja nicht, da die Klasse verschlüsselt ist. Generell sollte hier die Übermittlung der Nachricht nicht unterdrückt, vielmehr sollten verdächtige Zeichen entfernt oder durch Codierung unschädlich gemacht werden.

Wir werden die Kontaktmöglichkeit vorerst deaktivieren. Langfristig ist das allerdings kein tragbarer Zustand gegenüber unseren Kunden.

Share this post


Link to post
Share on other sites

Hi Gemeinde,

in meiner Installation mit 4.0.14 läuft es.

Gibt der Kunde den Text mit Zeilenumrüchen kommt der Text an.

Allerdings dann ohne Zeilenumbrüche.

Auch bei Texten, die erst in einem wilden Editor geschrieben und dann ins Formular kopiert werden alles OK.

Share this post


Link to post
Share on other sites

Dafür gab es ja auch bereits einen Bugfix. Allerdings kommt kein Text an, wenn du folgendes eingibst, oder ?:

Sonderzeichentest & (test) ! ? 5% "test" 'test1' = 1ß test / test \test

Da auch "Sonderzeichen" geblockt werden, die Satzzeichen sind, ist das nicht zufriedenstellend. Zumal nicht, wenn Kunden sich beschweren, dass Sie keine Antwort auf Ihre Kontaktanfrage erhalten bzw. der Shopbetreiber den Kunden fragen muss, was er denn angefragt hat.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...