Jump to content
xt:Commerce Community Forum
Sign in to follow this  
jjfischerprivat

xt-special-products bei Version 4.013 geht nicht

Recommended Posts

Habe einen Shop unter 4.012 laufen, xt-special-products funktioniert einwandfrei. Habe einen weiteren Shop mit 4.013 installiert. xt-special-products werden nicht angezeigt.

Nun habe ich meine ältere Shopsoftware von 4.012 auf 4.013 upgedatet, alles funktioniert, aber jetzt werden hier auch keine special-products mehr angezeigt.

Spiele ich den älteren Shop auf, funktionierts und umgekehrt eben wieder nicht.

Was tun?

Share this post


Link to post
Share on other sites

heute vormittag mit alter version alles einwandfrei. fehler nur nach update. plugin aktiv, preise korrekt vergeben. auch ein neuer testartikel funktioniert nicht.

habe letzte woche für einen kunden einen neuen shop installiert, hier ebenfalls das gleiche problem. egal was man einstellt, die box special-products wird nicht aufgerufen,obwohl sonst alles bis auf das kontaktformular einwand frei funktioniert.

Share this post


Link to post
Share on other sites

Sehr geehrter Herr Zanier

Plugin aktiv

neuer Testartikel angelegt mit Preis

Sonderpreis korrekt angelegt mit Datum

wie gesagt, vor dem Update gings ja auch.

Und der Shop für unseren Kunden wurde komplett neu installiert, hier geht alles bis auf die Sonderpreise. Mir scheint, als ob das Modul gar nicht aufgerufen wird.

Share this post


Link to post
Share on other sites

Hallo Herr Zanier

ich habe nochmals die Installation komplett neu durchgeführt, die special-products erscheinen nicht. auch im artikel, dem ein sonderpreis zugewiesen wurde, wird nur der reguläre preis angezeigt.

ich habe den zugang zum adminbereich und den link zum testartikel gestern an den support gemailt. ich bin am verzweifeln. können sie sich nochmals mit dem problem befassen?

danke

Share this post


Link to post
Share on other sites

Hallo

Ich weiss nicht, wo die Kundengruppe ausgewählt werden muss, damit die Anzeige funktioniert. Habe das gleiche Problem.

Sonderpreis ist definiert:

Artikel ID: 9

Angebotspreis:70

Erscheinungsdatum: 2010-09-28 12:00:00

Ablaufdatum: 2010-10-31 12:00:00

Status: aktiviert (Häkchen ist gesetzt)

Beim entsprechenden Artikel habe ich bei Kundengruppe/Staffelpreis:

Mengengrenze: 0

Preis: 0

Kundengruppe: all

Tja, die Kundengruppe all hat es nicht. Die habe ich dann auch noch angelegt, aber das bringt auch nichts.

Mir ist auch aufgefallen, dass in den Kundengruppen die Option für die Sonderpreise fehlt. Bei mir gibt es nur diese:

Mindestbestellwert

Maximaler Bestellwert

Preisanzeige

Preis incl USt

USt in Bestellung ausweisen

Staffelpreise

FSK 18

FSK 18 Anzeige

Übergeordnete Kundengruppe

Im Template sollte alles richtig sein. Bei product.html rufe ich den Preis so auf:

{if $smarty.const._CUST_STATUS_SHOW_PRICE eq '1'}{$products_price.formated}{/if}

Im index.html rufe ich die Box so auf:{box name=xt_special_products type=user order_by='rand()'}

Es wird einfach nichts angezeigt. Ich bin am verzweifeln. Hat jemand eine Idee?

Danke viel mal.

Liebe Grüsse

Daniel

Share this post


Link to post
Share on other sites

Hallo noch einmal.

Jetzt habe ich die Berechtigung gefunden. Im Fenster Sonderpreis bearbeiten gibt es noch einen Reiter der Berechtigung heisst.

Da habe ich alle angewählt und jetzt wird aber der Preis mit 0,00 angezeigt.

Hat da vielleicht jemand eine Idee?

Lieben Dank.

Grüsse

Daniel

Share this post


Link to post
Share on other sites

also liebe Leute, ich bin weiter gekommen :-)

Die Sonderpreise werden jetzt angezeigt. Das Problem war, dass ich bei Kundengruppen/Staffelpreise einen Eintrag hatte. Dieser übersteuert wohl den Sonderpreis.

Hoffe diese Info hilft mal jemandem.

Bis bald und liebe Grüsse

Daniel

Share this post


Link to post
Share on other sites

Hallo Zusammen,

auch ich hab die selbe Erfahrung gemacht. Lokale Installation (xampp) mit Version 4.0.12 funktioniert und Version 4.0.13 auf HostEurope Server funktioniert NICHT.

Leider ist es mir mit keinem der Tipps hier gelungen die Box mit den aktuellen Angeboten auf der Startseite erscheinen zu lassen.

Der Sonderpreis wird beim Produkt einwandfrei angezeigt, aber die Box auf der Startseite nicht.

Meine Einstellungen:

- Sonderpreis (inkl. Preisangabe)

- von - bis Datum sind beide gültig

- es gibt keinen Eintrag in Kundengruppe / Staffelpreise

- Berechtigung für den Sonderpreis: "ALLE" (Häckchen)

- Status Sonderpreis: "aktiv"

Ich rufe die Box in meinem Template so auf:

{box name=xt_special_products type=user order_by='rand()'}

Andere Boxen, die in der selben if-Schleife stehen, werden einwandfrei angezeigt.

Was mache ich falsch?

Vielen Dank schon mal im Voraus.

Share this post


Link to post
Share on other sites

Moin,

gleiches Problem bei 4.13. Plugin wird nicht angezeit.

Sonderpreis:

Preis: ok

Erscheinungs- und Ablaufdatum ..ok

Status Haken gesetzt.

Berechtigung Haken alle gesetzt.

Index.html im Template xt_default folgendes eingegeben:

{box name=xt_special_products type=user order_by='rand()'}

Plugin auch neu installiert. Keine Änderung

Nonne

gelöst..

habe gedacht das er den Bruttopreis nimmt und das ist flasch man muss den nettopreis nehmen

Edited by Nonne.biz

Share this post


Link to post
Share on other sites

Info an alle, bei denen auf der Startseite die Box mit den Sonderangeboten

nicht angezeigt wird:

Zusammen mit dem Helpdesk habe ich herausgefunden, dass (in meinem Fall) lediglich die reduzierten Slaveartikel nicht angezeigt werden. Da ich es selber nie mit einem reduzierten Masterartikel versucht hatte, bin ich lange nicht auf den Fehler gestoßen.

Lösung:

Damit reduzierte Slaveartikel auch auf der Startseite in der Box mit den Sonderangeboten angezeigt wird, muss man dafür sorgen, dass Slaveartikel als vollwertige Artikel behandelt werden. Dies schafft man, indem man folgenden Hookpoint beim Plugin "Master/Slaveartikel" deaktiviert:

class.getProductSQL_query.php:F_Listing

Bei mir hat's geklappt und die Box wurde plötzlich angezeigt.

Viel Spass beim Ausprobieren...

Share this post


Link to post
Share on other sites

Also bei mir haben alle Hinweise nichts gebracht. Der Artikel hat keine Kundengruppen/Staffelpreise, er ist kein Slave-Artikel. Und trotzdem wird er nicht angezeigt, wobei schon die gesamte Box auch nicht angezeigt wird.

Hat jemand sonst noch eine Idee?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...