Jump to content
xt:Commerce Community Forum
Sign in to follow this  
bornafreak23

Jquery Slider Veyton 4.13

Recommended Posts

Hallo,

ich versuche jetzt schon seit Stunden den Easyslider in meinem Shop SupTech - Your professionell Fitness Onlinestore ein zu binden, hab auch alles richtig gemacht, aber die BIlder erscheinen immer noch untereinander und kein Fade Effekt.

Jetzt habe ich das von Awkward Showcase - Demo #1 schon probiert, ebenfalls ohne Erfolg.

Wer kann mit mir bitte Helfen, es soll ähnlich wie bei

BSN - The World Leader In Cutting Edge Physique And Performance Products

bzw.

fitpoint24.de

aussehen am Ende, das ich mhere Bilder mit Links zu den Produkten hinterlegt auf der STartseite anzeige.

Bitte helft mir!

MfG

Alex

Share this post


Link to post
Share on other sites

Also

in die js.php unter templates/xt_suptech/javascript/js.php

hab ich unter den bereits vorhandenen Code

<script type="text/javascript" src="<?php echo _SYSTEM_BASE_URL . _SRV_WEB; ?>xtFramework/library/jquery/jquery-1.2.6.min.js"></script>

<script type="text/javascript" src="<?php echo _SYSTEM_BASE_URL . _SRV_WEB; ?>xtFramework/library/jquery/thickbox-compressed.js"></script>

<script type="text/javascript" src="<?php echo _SYSTEM_BASE_URL . _SRV_WEB; ?>xtFramework/library/jquery/easySlider1.7"></script>

<script type="text/javascript" >

$(document).ready(function(){

$("#slider").easySlider({

auto: true,

continuous: true,

numeric: true

});

});

</script>

letzeres habe ich auch schon in der default.html mit literal tags versucht.

meine default.html sieht folgendermaßen aus und hab zum testen erstmal die bilderlinks aus easyslider 1.7 so gelassen um zu schauen ob es geht.

<div id="slider">

<ul>

<li><a href="http://templatica.com/preview/30"><img src=" 01.jpg" alt="Css Template Preview" /></a></li>

<li><a href="http://templatica.com/preview/7"><img src=" 02.jpg" alt="Css Template Preview" /></a></li>

<li><a href="http://templatica.com/preview/25"><img src=" 03.jpg" alt="Css Template Preview" /></a></li>

<li><a href="http://templatica.com/preview/26"><img src=" 04.jpg" alt="Css Template Preview" /></a></li>

<li><a href="http://templatica.com/preview/27"><img src=" 05.jpg" alt="Css Template Preview" /></a></li>

</ul>

</div>

<h1>{$title}</h1>

<p>{$text}</p>

{page name=xt_special_products type=user order_by='p.date_available' tpl_type='product_listing'}

{page name=xt_startpage_products type=user order_by='p.products_sort' tpl_type='product_listing'}

{page name=xt_upcoming_products type=user order_by='p.date_available' tpl_type='product_listing'}

und den css code in meine stylesheet.css ans ende eingefügt

#slider ul, #slider li,

#slider2 ul, #slider2 li{

margin:0;

padding:0;

list-style:none;

}

#slider2{margin-top:1em;}

#slider li, #slider2 li{

/*

define width and height of list item (slide)

entire slider area will adjust according to the parameters provided here

*/

width:696px;

height:241px;

overflow:hidden;

}

#prevBtn, #nextBtn,

#slider1next, #slider1prev{

display:block;

width:30px;

height:77px;

position:absolute;

left:-30px;

top:71px;

z-index:1000;

}

#nextBtn, #slider1next{

left:696px;

}

#prevBtn a, #nextBtn a,

#slider1next a, #slider1prev a{

display:block;

position:relative;

width:30px;

height:77px;

background:url(../images/btn_prev.gif) no-repeat 0 0;

}

#nextBtn a, #slider1next a{

background:url(../images/btn_next.gif) no-repeat 0 0;

}

/* numeric controls */

ol#controls{

margin:1em 0;

padding:0;

height:28px;

}

ol#controls li{

margin:0 10px 0 0;

padding:0;

float:left;

list-style:none;

height:28px;

line-height:28px;

}

ol#controls li a{

float:left;

height:28px;

line-height:28px;

border:1px solid #ccc;

background:#DAF3F8;

color:#555;

padding:0 10px;

text-decoration:none;

}

ol#controls li.current a{

background:#5DC9E1;

color:#fff;

}

ol#controls li a:focus, #prevBtn a:focus, #nextBtn a:focus{outline:none;}

jedoch erscheinen die bilder immer untereinander und das script funktioniert aus irgendwelchen gründen nicht. Das Problem hab ich bei jedem Jquery Slider Script.

Share this post


Link to post
Share on other sites

könnte es sein das hier was fehlt ?

<script type="text/javascript" src="<?php echo _SYSTEM_BASE_URL .  _SRV_WEB;  ?>xtFramework/library/jquery/easySlider1.7"></script>
sollte doch eher so aussehen:
<script type="text/javascript" src="<?php echo _SYSTEM_BASE_URL .  _SRV_WEB;  ?>xtFramework/library/jquery/easySlider1.7.js"></script>[/code]

mal fürs erste :) ... prüfen ob das script überhaubt geladen wird... !

Share this post


Link to post
Share on other sites

ne daran liegts nicht, hab ich im shop richtig drin. ....js hab ich nru hier vergessen, woran erkenne ich ob das script geladen wird???

sende mir mal die Shop URL als PN bitte dann gucke ich da mal drauf

Share this post


Link to post
Share on other sites

ne daran liegts nicht, hab ich im shop richtig drin. ....js hab ich nru hier vergessen, woran erkenne ich ob das script geladen wird???

Hei,

Bornafreak hat die Jquery Slideshow schon bei dir geklappt?

(verfolge den Thread nämlich Spannung)

Gruß

Share this post


Link to post
Share on other sites

nein leider nicht, alles richtig eingefügt und an die richtigen stellen, sowie richtig hochgeladen aber es funktioniert nicht, hab jetzt eine alternative.

die sieht bei mir folgendermaßen aus, funktioniert ähnlich wie der slider aber leider ohne flüssigen übergang :(

{literal}

<script language="JavaScript">

<!--

var aktlupe = "http://suptech.de/index.php?page=manufacturers&mnf=19"

var i = 1

images = new Array

alts = new Array

links = new Array

images[1] = "http://suptech.de/templates/xt_suptech/img/index/efx.jpg"

alts[1] = "EFX"

links[1] = "http://suptech.de/index.php?page=manufacturers&mnf=19"

images[2] = "http://suptech.de/templates/xt_suptech/img/index/bsn.jpg"

alts[2] = "BSN"

links[2] = "http://suptech.de/index.php?page=manufacturers&mnf=9"

images[3] = "http://suptech.de/templates/xt_suptech/img/index/bodyattack.jpg"

alts[3] = "BodyAttack"

links[3] = "http://suptech.de/index.php?page=manufacturers&mnf=18"

images[4] = "http://suptech.de/templates/xt_suptech/img/index/weider1.jpg"

alts[4] = "Weider"

links[4] = "http://suptech.de/index.php?page=manufacturers&mnf=5"

images[5] = "http://suptech.de/templates/xt_suptech/img/index/olimp.jpg"

alts[5] = "Olimp"

links[5] = "http://suptech.de/index.php?page=manufacturers&mnf=14"

images[6] = "http://suptech.de/templates/xt_suptech/img/index/weider2.jpg"

alts[6] = "Weider"

links[6] = "http://suptech.de/index.php?page=manufacturers&mnf=5"

images[7] = "http://suptech.de/templates/xt_suptech/img/index/gaspari.jpg"

alts[7] = "Gaspari Nutrition"

links[7] = "http://suptech.de/index.php?page=manufacturers&mnf=10"

function zeig_bildlupe(){

self.location.href = aktlupe;

}

function gallery(){

if (i == 1){

document.gallery.previous.value=""

}

}

function nextimg(){

if (i != 7) {

i ++

document.gallery.previous.value="< Vorheriges"

image = images

document.img.src = image

aktlupe = links

document.img.alt = alts}

if (i ==7){

document.gallery.next.value="";

}

}

function pickrand(){

var imagenumber = 7 ;

var randomnumber = Math.random() ;

var rand1 = Math.round( (imagenumber-1) * randomnumber) + 1;

var randimage = images[rand1]

document.img.src = randimage

i = rand1

window.setTimeout('pickrand()', 4000);

if (i == 1){

document.gallery.previous.value="";

}

}

function stoperror(){

return true

}

window.onerror=stoperror

// -->

</script>

{/literal}

<img name="img" alt="EFX" src="http://suptech.de/templates/xt_suptech/img/index/efx.jpg" style="cursor: pointer;" onClick="zeig_bildlupe();" border="0" hspace="0" vspace="0" width="791">

Share this post


Link to post
Share on other sites

Wolen auch nen Slider auf der Startseite - habens auch noch nicht geschafft :-(. Vielleicht kann XTC hier mal schreiben ob der eventuell in der neuen Version kommt mit dem Update was wir endlich hoffen. Dann könnten wir noch 2 Wochen warten.

Share this post


Link to post
Share on other sites

Wolen auch nen Slider auf der Startseite - habens auch noch nicht geschafft :-(. Vielleicht kann XTC hier mal schreiben ob der eventuell in der neuen Version kommt mit dem Update was wir endlich hoffen. Dann könnten wir noch 2 Wochen warten.

Ich kann dein Problem echt nicht nachvollziehen, hier im Forum gibt es mehr als eine Anleitung dazu. Zudem glaube ich kaum das ab Werk solche Spielereien verbaut werden da sowas eher zum Template gehört als zum Shop-Engine.

Vielleicht solltest du mal den Quelltext deines Versuches hier posten dann könnte man dir auch helfen.

Share this post


Link to post
Share on other sites

Ich kann dein Problem echt nicht nachvollziehen, hier im Forum gibt es mehr als eine Anleitung dazu. Zudem glaube ich kaum das ab Werk solche Spielereien verbaut werden da sowas eher zum Template gehört als zum Shop-Engine.

Vielleicht solltest du mal den Quelltext deines Versuches hier posten dann könnte man dir auch helfen.

Nope, schau Dir mal die Konkurrenz an da sind solche Module im Shopcore verankert und einfach aus dem Backend auf der Startseite und den Kategorien zu integrieren. S h o p w a r e ist nur ein Beispiel einer Software die das hat. Standardmäßig und zudem haben die auch einen integrierten Bannermanager. Beides vermissen wir schmerzlich bei Veyton

MfG

Share this post


Link to post
Share on other sites

Nope, schau Dir mal die Konkurrenz an da sind solche Module im Shopcore verankert und einfach aus dem Backend auf der Startseite und den Kategorien zu integrieren. S h o p w a r e ist nur ein Beispiel einer Software die das hat. Standardmäßig und zudem haben die auch einen integrierten Bannermanager. Beides vermissen wir schmerzlich bei Veyton

MfG

nein.... ich muss mir die Konkurrenz nicht ansehen , ich kenne Shopware und bin froh das ich mich damit nicht beschäftigen muss. Wenn Du sagst das Du bereits versucht hast einen Slider einzubauen dann lass doch einfach mal gucken warum dieser nicht läuft, das wäre das einfachste :)

Share this post


Link to post
Share on other sites

Hi Stwinger,

ne musst Dir ja nicht anschaun war ja nur die Antwort auf Deine Aussage ;-)

"Zudem glaube ich kaum das ab Werk solche Spielereien verbaut werden"

Danke für das Angebot. Wir hatten uns 2-3 Tage abgemüht und können aktuell hald nicht noch mehr Zeit investieren und warten auf die .14 und hoffen das das hier vielleicht kommt. Sonst müssen wir uns das nochmal ansehen und posten dann gerne hier unsere Sachen - Danke nochmal fürs Angebot drüber zu schauen!

Wollen nur nicht jetzt noch was basteln was vielleicht dann in der .14 kommt. Ist hald schade das man keinerlei Infos bekommt welche neuen Funktionen in .14 kommen.

MfG

Share this post


Link to post
Share on other sites

Hi,

bitte nicht falsch verstehen, aber Ihr könnt mit dem Template doch machen was Ihr wollt.

Wenn Ihr so eine Kleinigkeit dann in innerhalb von 2 Tagen nicht hinbekommt, spricht das nicht gerade für eure Programmierer. :D

MfG. Hansen

Share this post


Link to post
Share on other sites

Kann mich amilo nur anschließen, sollte eigentlich für jemanden mit HTML / JS / Smarty-Kenntnissen kein größeres Problem sein.

bei 8works (xt:Commerce VEYTON 4.0) z.B. in einem fertigem Template mit:

Coda-Slider 2.0 - Niall Doherty's dot biz und

JQuery Cycle Lite Plugin

Man kann so Slider halt nur schwer als Plugin anbieten, weil es A jeder Kunde anders will und B jedes Template vom Aufbau verschieden ist.

Share this post


Link to post
Share on other sites

Kann mich amilo nur anschließen, sollte eigentlich für jemanden mit HTML / JS / Smarty-Kenntnissen kein größeres Problem sein.

bei 8works (xt:Commerce VEYTON 4.0) z.B. in einem fertigem Template mit:

Coda-Slider 2.0 - Niall Doherty's dot biz und

JQuery Cycle Lite Plugin

Man kann so Slider halt nur schwer als Plugin anbieten, weil es A jeder Kunde anders will und B jedes Template vom Aufbau verschieden ist.

ich kann die Probleme auch nicht nachvollziehen, was gibt es da grosses zu Coden ausser das html Markup des gewünschten Listings anzupassen ???

Share this post


Link to post
Share on other sites

Naja ich hab mir das ganze nochmal angesehen. Auch angenommen wir bekommens hin ist es für unsere Leute die den Shop pflegen und auschließlich aus dem Backend arbeiten nicht möglich da was zu tauschen.

Wir haben keine Lust bei jeder Änderung im Template die Deeplinks anzupassen, die Bilder auf den FTP zu laden die Reihenfolge irgendwie im Code anzupassen etc.

Ist hald schlichtweg auch eine Sache der Pflegbarkeit und das muss aus unserer Sicht einfach aus dem Backend von Veyton geschehen. Alles andere macht absoult keinen Sinn.

Auch gehts ja schon los wenn man den Slider nicht nur auf der Startseite sondern z.B. auf Ketegorieebene haben will... das wird ein riesen durcheinander...

Hoffe da gibts bald ein Plugin oder Veyton unterstützt das von Haus aus. Wir arbeiten auf einem anderen Projekt mit einem Konkurrenzprodukt das das wunderbar abbildet. Und nein wir werden nicht die Shopsoftware wegen dieser Sache wechseln ;-) nur wäre so eine Funktion aus dem Backend steuerbar für uns einfach extrem schön.

Naja vielleicht kommt ja bald sowas...

Share this post


Link to post
Share on other sites

Naja ich hab mir das ganze nochmal angesehen. Auch angenommen wir bekommens hin ist es für unsere Leute die den Shop pflegen und auschließlich aus dem Backend arbeiten nicht möglich da was zu tauschen.

Warum das ? Du kannst einen Slider für Kategorien bauen, die kannst du aus dem Admin heraus pflegen, das ganze geht auch für Artikel. Wo liegt da das Problem ?

Wir haben keine Lust bei jeder Änderung im Template die Deeplinks anzupassen, die Bilder auf den FTP zu laden die Reihenfolge irgendwie im Code anzupassen etc.

musst Du nicht, das ganze wird aus dem Admin heraus gesteuert, siehe meine Antwort oben.

Ist hald schlichtweg auch eine Sache der Pflegbarkeit und das muss aus unserer Sicht einfach aus dem Backend von Veyton geschehen. Alles andere macht absoult keinen Sinn.

siehe oben :-)

Auch gehts ja schon los wenn man den Slider nicht nur auf der Startseite sondern z.B. auf Ketegorieebene haben will... das wird ein riesen durcheinander...

Warum das ? Ein Slider für Kategorien wird innerhalb dieser angezeigt, Bei Produkten ist es abhängig davon welches Plugin Du als Slider umgebaut hast. Startpage_Products gehen sogar überall wenn man die "Page" nicht aus der content.html sondern aus der Index heraus aufruft.

Hoffe da gibts bald ein Plugin oder Veyton unterstützt das von Haus aus. Wir arbeiten auf einem anderen Projekt mit einem Konkurrenzprodukt das das wunderbar abbildet. Und nein wir werden nicht die Shopsoftware wegen dieser Sache wechseln ;-) nur wäre so eine Funktion aus dem Backend steuerbar für uns einfach extrem schön.

Naja vielleicht kommt ja bald sowas...

wenn Du wirklich ein modulares Slider Plugin haben möchtest das Du kreuz und quer aus dem Admin heraus steuern kannst gibt es sowas auch schon als Plugin. Slider_Container für Produkte oder Kategorien sogar mit alternativen Texten und Bilder, Ankertexte können frei vergeben werden und das ganze kannst Du sogar noch via Hookpoints individuell steuern, heisst: Du kannst x-beliebig viele Slider_Container anlegen und diese da erscheinen lassen wo Du möchtest, sogar innerhalb von Blog oder Content Seiten. Zu jedem angelegten Slider kannst Du ein eigenes Template anlegen ect. etc. modular eben. Infos ??? PM an mich .

Share this post


Link to post
Share on other sites

Guten Morgen, wenn ich mir deinen Shop anschaue sehe ich das du das Problem gelöst hast. Kannst du bitte die Lösung mal posten, oder eben wo dein Fehler lag? Ich bin auch schom rumbasteln. Danke

Dieser bitte möchte ich mich unbedingt anschließen, es wäre wirklich sehr sehr freundlich ...

Share this post


Link to post
Share on other sites

ich scheitere am scriptaufruf. man muss ja die slide immer aufrufen und dabei geht mein template auf die bretter sobald ich as einfüge in die index.html:

<script type="text/javascript">

$(document).ready(function() {

$('#coin-slider').coinslider();

});

</script>

alles andere funktioniert: man kann die bilder sehen und die description. nur der effekt selbst geht nicht, wegen diesen blöden aufruf. ich nehme an die syntax passt nicht. aber was passt da nicht?

Share this post


Link to post
Share on other sites

Moin,

spontan würde ich sagen, dass es an den geschweiften Klammern liegt. Diese sind in Smarty als Identifier vorgesehen und aus diesem Grund wird alles in {} versucht von Smarty auszuwerten. Anstelle den Klammern könntest du {rdelim} und {ldelim} benutzen oder dein kopmplettes javaScript von {literal}{/literal} umrahmen.

http://www.smarty.net/docsv2/de/language.function.literal.tpl

LG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...