Jump to content
xt:Commerce Community Forum
Sign in to follow this  
mmx

One-Step-Checkout von Bui-Hinsche - Erfahrungen!

Recommended Posts

Hallo zusammen,

wir haben uns das one-step-checkout Plugin von Bui-Hinsche zugelegt und waren anfangs auch sehr begeistert davon. Es macht den Checkout-Prozess einfach und übersichtlich und macht Spaß zu nutzen!

ABER:

Nach einigen Tagen des Testens (natürlich nach dem Kauf, ist ja immer so:):)) habe ich folgende Bugs entdeckt, die im normalen Checkout nicht auftreten. Vorab sei noch gesagt, das unser Template auf dem xt_default der Veyton-Installation aufbaut, also weder irgendwelche Klassen oder IDs geändert wurden. Optische Anpassungen und andere Texte natürlich schon.

Zu den Bugs:

- Kommentarfeld wird nicht übermittelt (Danke an xenon777)

- Bei aktivem Widerspruchs-Plugin ist der Widerspruchs-Haken ohne Funktion (Kunden können bestellen, ohne den Haken im Bestellprozess gesetzt zu haben)

- Zahlungsinformationen werden bei Kunden mit ausländischer Rechnungsadresse nicht in der DB gespeichert (und somit z.B. weder im Backend noch in der Bestätigungsmail ausgegeben)

Deswegen jetzt meine Frage: Wer hat das Plugin instaliert und hat ähnliche Probleme? BUI-Hinsche behauptet, es liege an meinem Template. Das kann ich nicht nachvollziehen, da bei ausgeschaltetem One-Step-Checkout Plugin keiner dieser Fehler auftritt.

Mir wurde von BUI-Hinsche angeboten, auf eigene Kosten Fehlersuche betreiben zu lassen. Gerne, aber erst wenn ich überzeugt bin, dass der Fehler bei mir liegt und das ist nicht der Fall. Ansonsten finde ich, dass ein Plugin, das inkl. MwSt. €236 kostet, auch durchaus funktionieren darf.

Bitte schildert mir doch Eure Erfahrungen, damit ich abschätzen kann, wo das Problem liegt. Vielen Dank.

Alex

Edited by mmx

Share this post


Link to post
Share on other sites

Hallo,

also Deine Erfahrungen kann ich durchaus teilen!

Wir hatten das Optionsplugin von BUI Hinsche gakauft und es gab einen Fehler das die Optionen nicht im Warenkorb angezeigt wurden.

Nach ewigem hin uns her sind wir dann draufgekommen das das Hauseigene Plugin von XTCommerce das die Master/Slave Optionen im Warenkorb anzeigt aktiviert war und das zu einer fehlerhaften Funktion des Optionsplugins geführt hat.

Lösung gab es von Bui Hinsche nicht - nur ein Angebot das kostenpflichtig zu korrigieren. - Was wir ehrlich gesagt schon ein starkes stück fanden!

Zertifizierte und getestete Zweitanbieter Plugins durch den Hersteller wären hier eine Lösung. Aber leider gibt es solch einen Service bei XTC nicht. Man hat also immer das Risiko ein Plugin von externen Herstellern zu erwerben das einem was anderes zerschießt.

Wie es in deinem Fall ist weis ich leider nicht. Aber kann mir gut vorstellen das es ein Problem mit einem anderen aktiviertem Plugin ist.

MfG

Share this post


Link to post
Share on other sites

Zertifizierte und getestete Zweitanbieter Plugins durch den Hersteller wären hier eine Lösung. Aber leider gibt es solch einen Service bei XTC nicht.

Gibt es nach der Cebit mit dem Start des neuen Plugin Marktplatzes.

Share this post


Link to post
Share on other sites

@amelie: das die Optionen vom Master Slave gekillt werden im Warenkorb liegt an dem Zusatzplugin fürs Master Slave von xt. Dieses überschreibt die nötigen variablen bei allen Artikeln ohne Rücksicht auf Verluste.

Share this post


Link to post
Share on other sites

@amelie: das die Optionen vom Master Slave gekillt werden im Warenkorb liegt an dem Zusatzplugin fürs Master Slave von xt. Dieses überschreibt die nötigen variablen bei allen Artikeln ohne Rücksicht auf Verluste.

Hallo Matthias,

ja genau das ist ja das Problem. Kann mich noch erinnern das hat uns auch Tage gekostet ... weil man immer zuerst denkt das es am eigenen System liegt.

Hier muss definitv mal eine Platform her wo sich die Leute über die Plugins austauschen können und wo solche "Bugs" einfach reportet werden (denke ja sowas kommt mit der neuen Version).

Aber was ich hald bei Euch (Bui Hinsche) nicht ganz verstehe ist das dieses Problem ja bekannt war/ist. Wenn ich mir jetzt aber das Plugin auf Eurer Seite ansehe finde ich keinerlei Hinweis zu diesem Problem oder habe ich das übersehen?

Schreibt das doch einfach dazu dann macht Ihr uns es leichter wenn schon Fehler auftreten mit diesen umzugehen.

MFG

Share this post


Link to post
Share on other sites

Hallo,

auch wir haben mit dem one-step checkout Modul massiv Probleme.

Bankdaten werden nicht abgefragt und auch nicht mein Vorgänger beschrieben werden diese auch nicht gespeichert zum Auslesen.

Bei Rückfragen an den Hersteller wurde mir am Telefon nur mögliche Hilfestellung an den Kopf geworfen oder natürlich gegen Entgeld würde man den anscheinenden Fehler beheben.

Alles eine Lobby.

pagelib

Share this post


Link to post
Share on other sites

und was ist mit diesen Punkten:

- Bei aktivem Widerspruchs-Plugin ist der Widerspruchs-Haken ohne Funktion (Kunden können bestellen, ohne den Haken im Bestellprozess gesetzt zu haben)

- Kontodaten werden im Kundenkonto nicht gespeichert

grüße

pagelib

Share this post


Link to post
Share on other sites

zu 1. Ja hatte ich.

Natürlich werden die Bankdaten gespeichert, sonst macht das Kundenkonto mit Bankverbindungen ja keinen Sinn.

Fazit: Keiner will euch hier angreifen. Ihr habt viele Module und gute Module, aber in diesem Fall ist es einfach dass ihr die Kundenfeedbacks in dem Modul korrigiert und es dann zum Update auf eurer Internetseite anbietet.

Dann haben alle was davon und keiner muss sich explizit an euch wenden.

Danke

Share this post


Link to post
Share on other sites

So, nun melde ich mich auch nochmal diesbezüglich zu Wort.

Liebes BUI-Hinsche-Team (oder @Matthias):

Ich habe Euch den Fehler mit dem Kommentarfeld (Kundenkommentar wird nicht in die DB geschrieben) schon lange, mindestens schon vor 6 Wochen, gemeldet. Bis Dato noch kein Feedback, nichts. Wieso dauert es so lange einen Fehler zu fixen? Bei der ersten Meldung wurde mir gesagt es liegt an meinem Template, dies konnte ich widerlegen indem ich den Fehler mit dem xt_default ebenfalls reproduzieren konnte. Ich sagte Euch es MUSS an Eurem Plugin liegen da beim 3-step-default-Checkout dieser Fehler nicht vorhanden ist. Ich kann nicht nachvollziehen warum das Bugfixing solange dauert. Mein Kunde (bin nur der Webmaster und für den Shop/Technik/Code verantwortlich) hat das Plugin gekauft, bezahlt, und möchte es verwenden, allerdings hindert uns der o.g. Grund daran es im Live-Betrieb einzusetzen. Nun hat mein Kunde Geld bezahlt und muss trotzdem den Default-Checkout verwenden :( Kein Wunder dass er mittlerweile etwas ungehalten darauf reagiert.

Viel schlimmer jedoch finde ich dass Ihr ein Plugin zum Kauf anbietet welches mit Bugs ausgeliefert wird.

Sagt mal, testet Ihr Eure Plugins nach der Programmierung eigentlich?

:confused:

So einen Fehler MUSS man im Vorfeld finden, ist ja wohl nicht gerade schwierig. Ich meine, wenn die Kommentare nicht mehr in die DB geschrieben werden ist dies ja wohl keine Kleinigkeit mehr.

Nun meine Fragen:

Wann wird dies gefixt?

Wie erfahre ich von dem Bugfix?

Mein Kunde hat ein individuelles Plugin bei Euch in Auftrag gegeben, ich hoffe dass dies dann Bugfrei ausgeliefert wird, kostet ja auch eine schöne Stange Geld.

PS: Bei meinem Problem mit dem "Options- und Freitextmodul" wurde mir bis Dato auch noch nicht geholfen, ich hatte dir Email und PM gesendet :(

Nicht falsch verstehen, dies ist KEIN persönlicher Angriff, ich möchte doch lediglich ein fehlerfreies Plugin welches ja bezahlt wurde. Dies sollte doch nicht zuviel verlangt sein ;)

Edited by xenon777

Share this post


Link to post
Share on other sites

Hallo xenon,

das kann ich dir sagen.

Da arbeiten nur Entwickler und kein Vetrieb.

Wenn du da ne Email bekommst, hat diese nicht mal einen Adressat noch wird man höfflich behandelt etc.

Gibt es aber oft. Entwickler denken anders.

Bin es auch Leid dauernd Kunden vertrösten zu müssen weil die Module Fehler haben.

Bei mir wurde lokal mal direkt etwas behoben, dann habe ich gesagt, dass dies auch auf der HP als Download für andere Kunden erscheinen muss.

Bis heute (ist schonn mehrere Monate her) gab es kein Update für das Modul auf der HP.

Keine Ahnung.

Einfach mehr Kontrolle, besserer Service für das Geld.

Grüße

pagelib

Share this post


Link to post
Share on other sites

@xenon: Bitte Mails an mich direkt über die BuI Adressen. Hier im Forum oder PM geht das unter in der Masse.

@pagelib: ja mit den Entwicklern hast du da recht. Dies ist aber auch gerade im Umbau.

Die letzte Aktualisierung vom One Step war am 7.2. also nicht Monate her :).

Von daher wenn da Probleme sind bitte Mail direkt an [email protected] Dann kann ich auch den zuständigen Personen auf die Finger hauen wenn ich es weis ;)

Edited by Matthias

Share this post


Link to post
Share on other sites

@xenon: Bitte Mails an mich direkt über die BuI Adressen. Hier im Forum oder PM geht das unter in der Masse.

@pagelib: ja mit den Entwicklern hast du da recht. Dies ist aber auch gerade im Umbau.

Die letzte Aktualisierung vom One Step war am 7.2. also nicht Monate her :).

Von daher wenn da Probleme sind bitte Mail direkt an [email protected] Dann kann ich auch den zuständigen Personen auf die Finger hauen wenn ich es weis ;)

Alles klar, ich sende direkt Email an Euren Support ;)

Share this post


Link to post
Share on other sites

Hallo,

hatte mir auch das Optionsmodul von BUI gekauft, da die Artikel einfach bei M+S zu viel wurden.

Nachdem der Bug erkannt wurde, dass die Größen und Farben in der KUndenbestätigung nicht geschrieben wurden, kam von BUI nur der Hinweis, dass die Angelegenheit in der Kalkulationsabteilung liege. Dieselbe Auskunft nach mehreren Mailanfragen und das ist jetzt ein halbes Jahr her.

Ich kann nur sage BUI = Nein danke !!

Share this post


Link to post
Share on other sites

@harleyschorsch: geb ich dir recht, letztes Jahr sind ab Mitte des Jahres ein paar Angebote untergegangen. Als Konsequenz daraus wurde das Team vergrößert und Ende des Jahres die Projektleitung ersetzt. Also wie du siehts wir arbeiten dran :)

Edited by Matthias

Share this post


Link to post
Share on other sites

BUG - Bei aktivem Widerspruchs-Plugin ist der Widerspruchs-Haken ohne Funktion (Kunden können bestellen, ohne den Haken im Bestellprozess gesetzt zu haben)

Nicht nur immer kritisieren, sondern auch positives vermelden:D:

Danke an Herrn Benkwitz vom Bui Support, obiger Bug ist hiermit offiziell behoben! Die Zusammenarbeit mit dem xt_payment_restriction Plugin war übrigens das Problem.

Und ich bin sicher, die anderen beiden von mir beschriebenen Bugs haben sich auch bald erledigt...

Beste Grüße

Alex

Share this post


Link to post
Share on other sites

Ich muss hier noch einmal nachhaken was den One Step Checkout betrifft.

Verwendet ihr als Zahlungsweise das Bankeinzug?

Hier wird meiner Meinung nach der Block mit den Bankeinzugsdaten beim Ändern und Verlassen eines Eingabefeldes neu geladen.

Wenn man z.B. schnell ist und zwischen Verlassen von Feld 1 bereits Text in Feld 2 eingegeben hat, dann verschwindet dieser durch das Überladen des Blocks.

Das Problem konnte ich übrigens in allen Browsern nachstellen (IE, Firefox, Chrome, Safari).

Fazit: In normaler Ausfüllgeschwindigkeit ist es nicht möglich alle Daten am Stück einzugeben, sondern es wird zwischendurch immer refresht.

Werd mich mal an den Support hängen.

Kennt ihr das Problem?? Hab es mit der aktuellsten Version getestet. Da tritt es auf.

Share this post


Link to post
Share on other sites

Wir haben in einem Projekt auf Probleme mit dem One-Step-Checkout von BuI. Das Plugin ist nicht kompatibe mit dem Plugin vom Gutscheinmodul.

Leider hat sich auch noch einem Jahr warten an diesem Status nichts geändert. Schlimmer noch - E-Mails werden schlichtweg nicht mehr beantwortet.

Share this post


Link to post
Share on other sites

Wie war wie war.

kann ein problem in 8 shops nachstellen. Dann kommt anwort von BUI.

Auf unseren Testshops kann das Problem nicht nachgestellt werden.

Welch ein Armutszeugnis seine Kunden so allein zu lassen und solche Ausreden zu haben.

Share this post


Link to post
Share on other sites

Weiß nicht ob da Modul dies überhaupt vorsieht, aber ich habe folgendes Problem:

Wähle ich eine Versandart und eine Zahlweise aus müssten diese doch in der Zusammenfassung unten in die Gesamtsumme mit einfließen. Allerdings erscheint dort nichts dergleichen, was ja auch mehr oder weniger logisch ist, da lediglich die Radiobuttons ausgewählt wurden und kein "Submit des Formulars" erfolgt ist. Aber so ist es doch für die Kunden absolut verwirrend, da sie nicht den echten Gesamtbetrag sehen sondern nur die reinen Artikelkosten.

Erst nach Drücken von F5 werden zumindest die Versandkosten mit in den Gesamtkosten mit angezeigt, die Zahlweisekosten dagegen nicht.

Kann mir jemand dazu was sagen, also ob das ein Bug im Plugin ist oder überhaupt nicht vorgesehen ist bzw. wie man das korrigieren kann ?

Für rund 200 Euro sollte man doch ein fehlerfreies Plugin erwarten können. :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...