Jump to content
xt:Commerce Community Forum
Sign in to follow this  
casademobila

Master-Slave funktioniert nicht

Recommended Posts

Guten Tag,

ich möchte gerne daas Modul Master/Slave ausprobieren, habe damit allerdings ein Problem.

Wenn ich das Mobul aktiviert habe, funktioniert unser Onlineshop nicht mehr richtig - d. h. die Seiteninhalte werden falsch formatiert angezeigt und das ganze Layout ist verschwunden. Das Anlegen der Master- oder Slave-Artikel im Admin-Bereich funktioniert auch nicht.

Wo liegt denn hierbei der Fehler?

Wenn ich das Plugin aktiviert habe und auf den Shop zugreife, bekomme ich per Email auch allerhand SQL-Fehlermeldungen zugeschickt (Beispiel unten).

Mit freundlichen Grüßen

Roy Bachmann

mysql error: [1054: Unbekanntes Tabellenfeld 'p.products_master_model' in where clause] in EXECUTE("SELECT p.products_id FROM xt_products p INNER JOIN xt_products_cross_sell pc ON p.products_id = pc.products_id_cross_sell left JOIN xt_categories_permission group_permission ON (group_permission.pid = p.permission_id and group_permission.pgroup = 'group_permission_1' ) left JOIN xt_categories_permission shop ON (shop.pid = p.permission_id and shop.pgroup = 'shop_1' ) LEFT JOIN xt_seo_url su ON (p.products_id = su.link_id and su.link_type='1') WHERE p.products_id != '' and pc.products_id ='153' and pc.products_id_cross_sell=p.products_id and group_permission.permission IS NULL and shop.permission IS NULL and p.products_fsk18!=1 and p.products_status = '1' and su.language_code = 'de' and (p.products_master_model='' or p.products_master_model IS NULL) ")

Share this post


Link to post
Share on other sites

hi,

dann ist das Teil nicht richtig installiert - die Meldung sagt ja , dass das Feld products_master_model in der xt_products nicht existiert, am besten nochmal deinstallieren und neu installieren.

Grüsse

Share this post


Link to post
Share on other sites

ganz normal auf den roten "Löschen" Button klicken.

Allerdings würde ich auch mal kontrollieren, ob in der xt_products die Felder products_master_model und products_master_flag vorhanden sind, wenn nicht, liegt der Fehler schon in der Datenbank ! Die stehen auch ohne installiertes Plugin drin. Ebenso schauen, ob die drei Tabellen xt_plg_ ....attributes.... vorhanden sind.

Grüsse

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...