Jump to content
xt:Commerce Community Forum
Sign in to follow this  
Baldiron

CE-Version/Ioncuber/Strato - Probleme

Recommended Posts

Hallo liebe Community,

ich habe ein Problem bei der Installation der CE von Veyton. Ich habe ein Strato PowerPlus Paket und bekomme bei dem Aufrufen der Installation folgenden Fehler:

Site error: the file /mnt/webc/31/87/xxxx/htdocs/shop/xtInstaller/index.php requires the ionCube PHP Loader ioncube_loader_sun_5.2.so to be installed by the site administrator.
Daraufhin habe ich mir das Strato-Tutorial aus dem Handbuch und das aus FAQ bei Strato angeschaut und mir ioncube_loader_sun_5.2.so heruntergeladen. Die Shopdateien der Version, welche ich gestern heruntergeladen habe sind in /shop. Dann habe ich einen Ordner /ioncube, wo sich neben der ioncube folgende Dateien drin befinden: ioncube_loader_sun_5.2.so ioncube-loader-helper.php ioncube-encoded-file.php index.php php.ini installer.css + 3 Bild-Dateien Zusätzlich habe ich ich mir eine php.ini erstellt mit folgendem Inhalt:
zend_extension=/home/strato/www/me/www.meine-domain.de/htdocs/ioncube/ioncube_loader_sun_5.2.so

safe_mode=off[/code]




(meine-domain natürlich ausgetauscht/Rechtevergabe 777)



Diese habe ich in die folgenden Ordner kopiert:



/shop

/ioncube

sowie die ordner in /shop, welche mit xt beginnen (xtInstaller/xtAdmin etc.)



Beim Aufrufen der ioncube-loader-helper.php kommt folgender Screen:



[code]An ionCube Loader file is required by PHP to read files encoded with the ionCube Encoder. This page will determine how you can install Loaders on this particular server. The loading of ionCube encoded files is not currently working correctly on this server. If you have permission to edit the php.ini configuration file for this server, please follow the php.ini installation instructions. If you do not access to the php.ini file, please follow the run-time loading installation instructions. Please read the online documentation, or review the file readme.txt enclosed with the Loader bundle, for more help with Loader installation.[/code]
Und bei der Run-Time Loading Installation Instructions kommt folgendes:
[code]Run-Time Loading Installation Instructions Testing Server Testing whether your system supports run-time loading... Looking for Loader 'ioncube_loader_sun_5.2.so' Extensions Dir: /opt/RZphp5pl/lib/php/extensions/no-debug-non-zts-20060613 (NOT FOUND) Results The directory set for the extension_dir entry in the php.ini file may not exist, and run time loading will not be possible. Instructions Please ask your hosting provider or system administrator to create the directory /opt/RZphp5pl/lib/php/extensions/no-debug-non-zts-20060613 ensuring that it is accessible by the web server software. They do not need to restart the server. Then rerun this script. As an alternative, your host could install the Loader in the php.ini file.[/code]

----------------

Was habe ich falsch gemacht? Wäre sehr nett, wenn mir hier jemand zur Hand gehen könnte...

MfG

Baldiron

Share this post


Link to post
Share on other sites

Habe genau das selbe Problem...Laut Strato sollte es so aber funktionieren !

Ich bin auch am verzweifeln.

(TIPP: Upgrade dein Space auf PowerPlusL, dann isses vorinstalliert) ^^

Wenn einer ne Lösung hat...bitte posten ^^.

LG JOnas

Share this post


Link to post
Share on other sites

Bitte beachten das bei Strato auch mindestes ein PowerPlus L benötigt wird.

Ich habe dem Support geschrieben. Dieser sagte mir, dass es auch ohne L Paket möglich sei. Allerdings schaffe ich es nicht ioncube zu installieren.

loader-wizard.php zeigt mir nur eine leere Seite an. Habe den Pfad in php.ini die im gleichen Verzeichnis angepasst.

Site error: the file /mnt/webc/12/34/567890/htdocs/shop/index.php requires the ionCube PHP Loader ioncube_loader_sun_5.2.so to be installed by the site administrator.[/CODE]

So sieht meine Fehlermeldung aus, kann aber rein gar nichts machen. Habe alle Anleitungen abgeklappert, aber bringt alles nichts.

Phpinfo meint:

System SunOS localhost 5.10 Generic_139556-08 i86pc

Deshalb bräuchte ich eigentlich die x86 Version. Euer Tutorial empfiehlt aber die sparc version: xt:Commerce VEYTON 4.0

Keine Ahnung warum da nichts passiert. Habe beide Versionen ausprobiert.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...