Jump to content
xt:Commerce Community Forum
Sign in to follow this  
squip

Zahlungsgebühr berechnet falsch

Recommended Posts

Ich habe in meinem Shop bis 500,- EUR 5% Rabatt eingestellt. Alles was darüber hinaus geht, erhält man 10% Rabatt.

Wenn jetzt aber jemand z.B. 546,- EUR Warenwert hat, wählt er die Versandart, dann die Zahlungsweise wo auch die 10% angezeigt werden und kommt dann zur Bestellbestätigung wo wiederum die 10% angezeigt werden.

Alles soweit OK....doch dann...

...erhält der Kunde die Bestätigungs-Mail mit nur 5% Rabatt!!! Warum das???

Ich habe zu dem folgenden Test gemacht:

Wenn ich auf der Bestellbestätigungsseite bin (dort werden ja noch 10% Rabatt angezeigt) und nun F5 drücke, dann werden aus den 10% wieder 5%....nochmal F5 gedrückt, und siehe da, es werden wieder 10%, usw.

Er rechnet den prozentualen Wert jedes Mal neu aus. Da der Betrag von 546,- EUR minus 10% auf 491,40 EUR fällt, meint sas System nunmehr nur noch 5% abzuziehen....somit kommt ein falscher Endbetrag zustande.

Aktualisier ich nun wieder die Bestellbestätigungsseite im Bestellvorgang, werden wieder 10% Rabatt draus, weil der Betrag ja wieder über 500,- EUR liegt.

Isdt das ein genereller Bug? Wie kann ich das lösen? Brauch schnelle Hilfe!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...