Jump to content
xt:Commerce Community Forum
Sign in to follow this  
Sussanne

Admin Bereich Button wird nicht angezeigt

Recommended Posts

Hallo erst mal,

habe mir heute XT:commerce neuste Version installiert. Läuft nach vielen hin und her auch. Allerdings habe ich keine Ahnung wie ich in den Admin Bereich komme. Habe scho viel gelesen. Angeblich kann man sich mit der bei der Installation angelegten email und dem dort vegebenen Passwort erstmalig anmelden und bekommt dann den Button angezeigt.

Ist das bisher so richtig?

Ich kann mich allerdings nicht einloggen.

Bekomme dann diese Bild:

Sie haben einen falschen Benutzernamen oder ein falsches Kennwort eingegeben. Gehen Sie bitte die richtigen Daten ein. Haben Sie vielleicht Ihr Kennwort vergessen?

Sie haben bisher 3 mal versucht, sich anzumelden. Nach dem 5. fehlerhaften Versuch ist eine Anmeldung für die nächsten 20 Minuten nicht mehr möglich.

Hab schon ein 2. Mal den Shop installiert und auch vorher die Datenbank gelöscht und neu angelegt.

Ich habe keine Ahnung was ich jetzt machen muß.

Bin übrigens bei 1&1

Schon mal Danke.

Share this post


Link to post
Share on other sites

Bei Veyton gibts kein Button für den Adminbereich, das gabs mal bei der alten 3.04 :)

Probier mal deineurl.tld/xtAdmin ;)

Man achte auf das grosse A!

Übrigens wird dir das im letzten Schritt der Installation angezeigt, also nächstes mal erst lesen, dann klicken^^

Share this post


Link to post
Share on other sites

Joup, so wäre es richtig.

Das /de/ sagt du hast die Suma-URLs an, entweder in der DB ausschalten oder mal probieren, ob du über subdomain.deinedomain.tld/ordner/de/xtAdmin reinkommst.

Bei der Installation hast du Veyton auch über/mit der Subdomain installiert?

Share this post


Link to post
Share on other sites

So hab den Shop nochmals installiert

Nach der Installation auf backend gedrückt und dann kommt das:

Site error: the file /homepages/14/d364163393/htdocs/xtcommerce/xtAdmin/login.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.

Es wurde aber angezeigt, das alles ohne Problem installiert worden ist.

Meine ini.php sieht so aus:

zend_extension = /homepages/14/d364163393/htdocs/xtcommerce/ioncube/ioncube_loader_lin_5.2.so

Liegt im /xtcommerce und in xtInstaller

xtInstaller nach der Installation gelöscht

Hab ich hier was falsch gemacht?

Edited by Sussanne

Share this post


Link to post
Share on other sites

So, habe heute nochmals alles neu installiert.

Also Dateien und Verzeichnisse nach /xtcommerce (mein angelegter Ordner unter eshop.domainname.de) kopiert per FTP.

Dann Verzeichnis unter erstellt (/xtcommerce/ioncube).

Dort alle Dateien aus dem Download "ioncube_loaders_lin_x86" reinkopiert.

Dann die .htaccess ergänst um RewriteBase

.htaccess

# RewriteEngine on

# RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php

AddType x-mapp-php5 .php

DirectoryIndex index.php

RewriteEngine on

RewriteBase /

RewriteCond %{REQUEST_URI} !^/media/

RewriteCond %{REQUEST_URI} !^/extAdmin/

RewriteCond %{REQUEST_URI} !^/skin/

RewriteCond %{REQUEST_URI} !^/js/

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php

php.ini sieht wie folgt aus

zend_extension = /homepages/14/d364163393/htdocs/xtcommerce/ioncube/ioncube_loader_lin_5.2.so

Diese in /xtcommerce/xtInstaller und in /xtcommerce kopiert

Wenn ich dann die Installation starte klappt alles Problem los.

Angaben eingeben und bis zum Schluss keine Fehler.

Wenn ich dann aber auf Backend klicke kommt:

Site error: the file /homepages/14/d364163393/htdocs/xtcommerce/xtAdmin/login.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.

Habe dann noch mal die php.ini auch in den Ordner /xtAdmin kopiert.

Dann

http://www.exxxx.xxxxxx.de/xtcommerce/xtAdmin/login.php

und er springt auf

http://xxxxx.xxxxx.de/de/404

Wenn ich allerdings dieses eingebe

http://www.xxxxx.xxxxxx.de/xtAdmin/login.php

komme ich ich auf den Admin Login (schon mal ein Stück weiter)

Allerdings kommt nach Eingabe des Benutzernamens und das Passworst, die am Ende der Installation angezeigt worden, folgender Hinweis:

Sie haben einen falschen Benutzernamen oder ein falsches Kennwort eingegeben. Gehen Sie bitte die richtigen Daten ein. Haben Sie vielleicht Ihr Kennwort vergessen?

UND NUN?

Kann es sein, das die php.ini noch in andere Verzeichnisse muss?

Update:

So, habe jetzt noch das Admin Passwort zurückgesetzt und siehe da, komme in den Adminbereich.

Die Frage ist nur, wie kann ich jetzt sehen ob wirklich alles korrekt installiert ist.

Muß die php.ini noch in andere Verzeichnisse kopiert werden?

Beim Aufruf des Shops zeigt er unter XT:Commerce News "login required?

Wenn ich dann auf Register Bestellungen, Kunden oder Verkäufe klicke, wird so ein Pfad angezeigt:

http://xxxxx.xxxxx.de/xtAdmin/chart-data.php?resource=orders&type=mamount

Woran liegt das denn?

Edited by Sussanne

Share this post


Link to post
Share on other sites

Hier noch mal eine Installationsanleitung direkt von 1&1 kommt.

Bitte beachten folgenes beachten:

Punkt 4

Da wird /htdocs/ioncube als Pfad genannt. Bei 1&1 sieht man das Verzeichnis /htdocs nicht

Legt /ioncube im Verzeichnis an wo auch die anderen Ordner drin sind

Als z.B. /xtcommerce/ioncube

Punkt 5

Die "loader-wizard.php" direkt nach der URL aufgerufen wird. Also www.xxxxxx.de/loader-wizard.php

Nur so funktioniert der Wizard

Ich mußte dann zusätzlich noch die php.ini in das Verzeichnis /xtAdmin kopieren und habe in der php.ini noch rewritebase / ergänzt.

"Der ioncube Loader ist Standardmäßig nicht installiert.

Sie können den ioncube Loader jedoch selbst installieren.

Wie wird der ioncube Loader installiert?

Damit der PHP-Quellcode vor Beobachtung, Änderung und Diebstahl geschützt wird, kann der "ionCube Loader" installiert werden. Mit dem ionCube Loader werden diese kodierten Dateien "ausgeführt".

Wenn Ihr das so macht, sollte es funzen.

Anleitung ohne Shell

1. Von der ionCube Webseite (PHP Encoder, protection, installer and performance tools from ionCube: Loader Download) das passende Archiv herunterladen (Linux x86 für Shared-Hosting und Homepage-Server, 32Bit). Der Archivtyp ist von Ihnen nach eigener Vorliebe wählbar.

2. Das Archiv entpacken.

3. Die Datei "loader-wizard.php" per FTP in das gewünschte Zielverzeichnis hochladen.

4. Die .so Dateien aus dem entpackten Archiv gehören in /htdocs/ioncube, ist der Ordner nicht vorhanden bitte erstellen.

5. Über einen Domain-Namen, von dem aus man das Verzeichnis in dem wizard liegt erreichen kann, die Datei "loader-wizard.php" aufrufen.

6. Der Anleitung gemäß "Shared" wählen und "Next" klicken.

7. Als Hosting Provider bitte 1und1 oder 1and1 angeben

8. Als URL des Hostingproviders bitte 1und1.de oder 1and1.pl

9. Auf der nachfolgenden Webseite liefert Punkt 3 alle weiteren notwendigen Informationen.

* Nach Bestätigung ist der Wizard soweit fertig. Die php.ini wird im Rootverzeichnis abgelegt bzw. eine bestehende php.ini

im Rootverzeichnis wird ergänzt (nicht überschrieben!).

* Die php.ini aus dem Rootverzeichnis gegebenenfalls in das Verzeichnis kopieren in dem der wizard abgelegt ist.

* "Click here to test the Loader" wählen. Es sollte nun angezeigt werden, dass ioncube korrekt installiert und verwendet werden kann.

Wir freuen uns, wenn wir Ihre Frage umfassend beantworten konnten.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...