Jump to content
xt:Commerce Community Forum
Sign in to follow this  
MartinSK

Plötzlich alle Seiten leer bei laufendem Shop

Recommended Posts

Hallo zusammen,

ich habe ein großes Problem mit einem laufenden Shop und bitte dringend um eure Hilfe, falls ihr Ideen habt/ähnliche Probleme hattet - habe schon hier im Forum und per Google gesucht/gelesen, nichts hat bisher geholfen:

Nachdem nur Produkte editiert wurden sind plötzlich alle Seiten leer (kein html-Code, kein Fehler), egal ob im Front- oder Backend. Der Shop lief schon einige Monate ohne Probleme.

Soweit ich weiß gab es außer an Produkten (Beschreibungen/Bilder) keine Änderungen, auch der Hoster sagt an der Server-Software/Config hat sich nichts geändert, server_test zeigt auch keine Probleme, phpinfo sagt ionCube geladen usw.

Details zum Shop/Server:

Shop-Version: 4.0.13 Ultimate

Linux mit Apache 2 bei ebiz-webhosting, PHP Version: 5.2.17, mySQL: 5.0.51a

Verwendete Nicht-xt-Plugins:

janolaw_agb_hosting, pay_ipayment, vt_paymorrow

Änderungen am Shop: Nur bei den Produkt-Beschreibungen zusätzliche Html-Felder in der DB, Standard-Template kopiert und nur im Aussehen/Texten etwas verändert, lief aber schon ein paar Monate mit allen Änderungen, an Dateien/DB schon länger nichts mehr gemacht.

Was ich schon versucht habe:

in xtCore/main.php am Ende vor ?> eingefügt:

error_reporting(E_ALL & ~E_NOTICE);

ini_set("display_errors", "1");

in der Datenbank xt:config:

_SYSTEM_DEBUG = true

in .htaccess:

php_flag display_errors on

Trotzdem bekomme ich noch nicht mal eine Fehlermeldung! Logs gibt es leider keine oder ich habe keinen Zugriff.

Zuletzt habe ich noch versucht /templates_c und /cache zu leeren, Templates bis auf Standard gelöscht, Plugins entfernt - hat nichts gebracht, ich komme noch nicht mal in den Admin-Bereich (/xtAdmin), auch hier nur leere Seiten.

Hat jemand noch Ideen / ähnliche Probleme gehabt?

Vielen Dank!

Gruß

Martin

Share this post


Link to post
Share on other sites

Erstmal von einem andrem Netzwerk auf den Shop zugreifen. Mit einem andren Browser um auszuschlißen das es nur am eigenen Rechner Liegt.

Wenn das Problem weiterhin besteht.

Template Cache

Plugin Cache

und sonstige Cache datein Löschen

Wenn das Problem weiterhin besteht.

DB zurücksetzen.

oder alle Plugins manuel deaktivieren.

Wenn das Problem weiterhin besteht.

Template Kontrolieren ob die Datein nicht verändert wurden.

Wenn das Problem weiterhin besteht.

Produktbeschreibung in der DB durchsuchen

und fehler entfernen wie z.b

MOS=airiwrq halt das was tiny produziert bei drag and drop

Wenn das Problem weiterhin besteht.

hier posten und betten

Share this post


Link to post
Share on other sites

Hallo,

das Problem besteht von verschiedenen Netzen mit div. Browsern.

Cache (/cache, /plugin_cache, /templates_c) hatte ich schon geleert.

Die Verzeichnisse bleiben aber auch leer, d.h. es ist so als würden die Seiten überhaup nicht mehr erzeugt?!

Plugins und alle Templates bis auf Standard hatte ich gelöscht, da die Seiten im Admin-Bereich auch leer bleiben kann ich nichts mehr ändern, in der DB habe ich bei _SYSTEM_TEMPLATE zum Test xt_default eingetragen.

Produktdaten alleine können doch sowas nicht anrichten, oder? Also dass ich nicht mal in Admin-Bereich komme und überhaupt keine Seiten mehr erzeugt werden?!

Gruß

Martin

Share this post


Link to post
Share on other sites

Hallo zusammen,

ich glaube ich habe das Problem nach einer Fehlermeldung in der Tabelle 'adodb_logsql' gefunden:

ERROR: Incorrect key file for table xxx/xt_seo_url.MY'...

ERROR: Table 'xxx/xt_seo_url' is marked as crashed and should be repaired...

Beim Ändern einer Produkt-Beschreibung scheint das Update in der Tabelle 'xt_seo_url' diese beschädigt zu haben.

Nach ein paar mal CHECK / REPAIR / OPTIMIZE TABLE in

phpMyAdmin scheint wieder alles zu funktionieren.

Falls das Entwickler/Supoort lesen: Wäre toll, wenn für den Fall eines DB-Problems noch irgend eine Fehlermeldung kommen würde statt komplett leerer Seiten, dann hätte man schneller einen Anhaltspunkt ;)

Danke und viele Grüße

Martin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...