Jump to content
xt:Commerce Community Forum
Sign in to follow this  
Phan

Mehr als 1 Artikelbild nur über Direkt-Upload möglich?

Recommended Posts

Hallo,

bei xt:Commerce 4.0.14 kann man ja einmal beim Anlegen eines neuen Artikels die Artikelbilder direkt über "Multi-Datei-Upload" hochladen oder alternativ die Bilder schon vorher in die Media Gallery hochladen und dann in der Artikelbeschreibung bei "Bilder bearbeiten" aussuchen, mit einem Häkchen anklicken und über "Auswahl übernehmen" dann mit dem Artikel verknüpfen.

Jetzt habe ich das Problem, daß ich zwar die Bilder aus der Media Gallery auswählen und speichern kann, es wird allerdings nur ein Bild übernommen (sowohl im Frontend als auch im Adminbereich). Nur wenn ich direkt per Multi-Datei-Upload hochlade, werden alle Bilder angezeigt.

Außerdem bleibt bei der Media-Gallery-Variante der Reiter "Bilder" leer, den man bei "Bilder bearbeiten" in dem Popup-Fenster angezeigt bekommt. Bei Direkt-Upload werden die Artikelbilder aufgelistet und man kann dann auch die Sortierreihenfolge ändern...

Ich würde schon gerne die Media Gallery nutzen (weil beim Direkt-Upload sonst ja alles in einem einzigen Ordner landet), aber irgendwie scheint da der Wurm drin zu stecken. Kennt da vielleicht jemand eine Lösung?

Share this post


Link to post
Share on other sites

Hallo Phan,

ich habe das gleiche Problem, dachte jedoch es hängt mit dem Update zusammen. Es taucht aber schon bei der Neuinstallation auf.

Mehrere Bilder einem Artikel zuzuordnen funktioniert nur über "Multi Datei Upload" im Reiter "Artikel bearbeiten", d.h. eine alle hochgeladenen Bilder landen dann im Mediaordner "Artikelbilder". Bist du mit dem Problem schon weiter?

Share this post


Link to post
Share on other sites

Nach dem jetztigen Stand der Dinge ergeben sich 2 Möglichkeiten:

1. man verzichtet auf Unterordner in de Media Gallery (alle Artikelbilder in das Verzeichnis "Artikelbilder" packen oder

2. man benötigt zur besseren Strukturierung der Mediagallery Unterordner, dann obiges Bugfix laden und installieren. Bis jetzt funktioniert es wieder, d.h. ich kann neue Media-Unterordner anlegen, vorher meine Artikelbilder (Achtung: kein Double Content sprich Dateinamen anlegen, egal wo die Bilder später liegen sollen) in meine eigenen Rubriken laden und den Artikeln entsprechend zuordnen. Direktupload via Artikeleingabemaske ist möglich aber nicht nötig.

Dank an essenzia für den Hinweis.

Gruß Matze

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...