Jump to content
xt:Commerce Community Forum
Sign in to follow this  
mzanier

[BETA] xt:Commerce Orders Edit

Recommended Posts

[uPDATE] Die Funktion ist nun Bestandteil der xt:Commerce Professional+/merchant/Ultimate Versionen

Beta-Test für eine neue xt:Commerce 4.1.1 Funktionalität - Bestellungen bearbeiten.

Voraussetzungen für den Betatest:

- Version 4.1.0

- PHP Version >= 5.3.0

- ionCube Loader Version >= 4.0

Neben dem Order Edit Plugin muss auch das Order Source Plugin installiert werden (erlaubt in 4.1.1 die Zuweisung von Bestellungen zu Kanälen (eBay/Preisvergleiche/Facebook etc pp).

Anregungen/Fehler/Funktionswünsche bitte hier in diesem Thread Posten.

Funktionen:

- Bearbeiten von Bestellungen (Produkte, Adressen, Zahlung/Versand, Gutscheine)

- Anlegen von neuen Bestellungen (über Row-Action in Kundenliste)

Versionshistory:

15.09.2013 1.0.0 - initial release

08.01.2014 1.0.1

- Kompatibel mit PHP 5.1 > 5.4

- Sprache Brasilianisch hinzugefügt

- Neue Bestellungem als Admin im Kunden-Frontend sind nun auch per http möglich

- Zahlungsweise/Versandart lässt sich aktualisieren wenn xt_order_source nicht installiert ist

- Funktion 'Gutschein einlösen' hinzugefügt

- Kompatibilität zu xt_stock_per_shop hergestellt

- Fehler in Produktsuche behoben

post-2-14337915407622_thumb.jpg

post-2-14337915407917_thumb.jpg

post-2-14337915408207_thumb.jpg

Edited by mzanier

Share this post


Link to post
Share on other sites

Hallo xt:mzanier,

eine Frage hätte ich bezüglich der PHP-Version 5.3.

Meine Ioncube- und meine Shop-Version passen, jedoch läuft bei 1und1 nur 5.2 und 5.4, 5.3 wird also nicht unterstützt.

Kommt noch eine Version für 5.4 oder wie sehen die Pläne da aus?

Die Installation von xt_order_source kann ich ohne weiteres durchführen, bei xt_order_edit bekomme ich jedoch den Fehler, dass die Datei mit 5.3 encoded wurde.

Ich nehme an das hängt miteinander zusammen?

Share this post


Link to post
Share on other sites

Hi,

dann hast du warsch. PHP5.1 aktiviert. Lass deinen Account auf 5.4 umstellen und es sollte funktionieren. Wie Mario geschrieben hat, funktioniert das Plugin ab der Version gleich oder größer 5.3.

Share this post


Link to post
Share on other sites

Hallo,

ich habe das Plugin ein wenig testen können. Soweit läuft es stabil mit meinem Shop.

Jedoch ist mir aufgefallen, dass einige Icons im Actions Menü unter "Bestellpositionen bearbeiten" und "Position hinzufügen" nicht angezeigt werden:

actions.PNG

Fährt man mit der Maus drüber (hover), werden die Title Tags aber angezeigt und man kann auf die gewünschte Aktion klicken und sie wird auch ausgeführt.

Caches sind alles gelöscht, Templates_c und mein Browsercache ebenfalls.

Glaube deshalb dass etwas am Plugin nicht stimmt.

Die Pfade zu den Icons im "xtAdmin/images/icons" Verzeichnis in der zugehörigen CSS zum Plugin passen jedoch, denke ich.

Gruß Viktor

Edited by viktortoews

Share this post


Link to post
Share on other sites

Hm, komisch. Habe die beiden Plugins wieder deaktiviert und vom FTP Server gelöscht, dann noch mal frisch von dieser Seite heruntergeladen und wieder auf den Server hochgeladen. Unter deinstallierte Plugins sehe ich die nun wieder:

0.PNG

Was mir hier auffällt ist, dass das xtCommerce Logo fehlt?!

Dann habe ich beide Plugins erneut installiert:

1.PNG

und mit diesen Einstellungen aktiviert:

2.PNG

und

3.PNG

Danach ALLE Caches gelöscht, abgemeldet und wieder angemeldet.

Ergebnis. Icons werden NICHT angezeigt. Echt schräg.

Share this post


Link to post
Share on other sites

Neue Bestellungen anlegen funktioniert leider nicht. Nach Klick auf "Neue Bestellung" lande ich im Frontend:

...domain.xyz/de/customer/login?sr=MDE0NGU4MDZmM2E1YjA1NWQ1NmZlNDUxOGU2M2M4MjhkMGI4M2Q4NWY0MWYyMzg2MjAxYjc2ZWZkNmIwYTY4Zg.eyJhZG1pblVzZXIiOnsidXNlcl9pZCI6IjEiLCJ1c2VyX25hbWUiOiJhZG1pbiIsImdyb3VwX2lkIjoiMSIsImdyb3VwX25hbWUiOiJTdXBlciBBZG1pbiIsImxvZ2luX3RpbWUiOjEzNzk2NzA0NDJ9LCJ1c2VyRW1haWwiOiJjaHJpc3RpYW5AZWl3ZWlzcy5jb20ifQ

Share this post


Link to post
Share on other sites

Hallo,

bei mir werden ebenfalls die Icons unter "Postion hinzufügen" und "Bestellposition bearbeiten" nicht angezeigt.

Ebenfalls funktioniert der Link "Neue Bestellung" bei mir nicht. Tut sich gar nichts. Hier fehlt auch das Icon.

Unter "Gutscheine bearbeiten" kann ich zwar einen Gutscheincode angeben, dieser wird auch gespeichert. Berücksichtigt wird er jedoch nicht in der Bestellung. Vielleicht verstehe ich hier auch etwas falsch.

Gut fände ich, wenn man unter "Bestellposition bearbeiten" für jeden Artikel einen Rabatt angeben könnte, so wie es ja auch mit dem Gutscheinmodul funktioniert und ausgeworfen wird.

Artikel hinzufügen, löschen und bearbeiten funktionieren bis auf die fehlenden Icons gut.

Share this post


Link to post
Share on other sites

Hallo,

bei mir werden ebenfalls die Icons unter "Postion hinzufügen" und "Bestellposition bearbeiten" nicht angezeigt.

Ebenfalls funktioniert der Link "Neue Bestellung" bei mir nicht. Tut sich gar nichts. Hier fehlt auch das Icon.

Unter "Gutscheine bearbeiten" kann ich zwar einen Gutscheincode angeben, dieser wird auch gespeichert. Berücksichtigt wird er jedoch nicht in der Bestellung. Vielleicht verstehe ich hier auch etwas falsch.

Gut fände ich, wenn man unter "Bestellposition bearbeiten" für jeden Artikel einen Rabatt angeben könnte, so wie es ja auch mit dem Gutscheinmodul funktioniert und ausgeworfen wird.

Artikel hinzufügen, löschen und bearbeiten funktionieren bis auf die fehlenden Icons gut.

bitte zugangsdaten an den helpdesk senden, können wir aktuell bei uns nicht nachvollziehen.

Share this post


Link to post
Share on other sites

Hm soweit ganz gut bisher. Kleine Verbesserung. Wenn man auf Adresse Bearbeiten geht wärs schon besser wenn die Adresse direkt schon unten drin steht und nicht in einer Zeile wie bisher so das wenn man dann unten bei der jetztigen neu eingabe zum einen die bereits vorhanden Adresse drin steht und man diese dann so ändern kann. Bei bestellweg wäre noch Amazon als angabe von vorteil.

Wenn ich eine bereits vorhanden Bestellung den Bestell Weg änderen will und auf Laufkunde gehe und übernehmen will erhalte ich einen Internal Error. Zudem sollte in der Bestellübersich auch die gewählte Versandmethode vom Kunden angezeigt werden.

Zudem kann ich nirgendswo eine neue bestellung anlegen?

Edited by Checcker

Share this post


Link to post
Share on other sites

hm wieso is es dann möglich das ein Kunde was kauft mit einer falschen mail adresse. Wenn er nun seine Mail allerdings übern Account ändert wird die Mail für die bereits getätigte Bestellung leider nicht angepasst.

Das Icon hab ich gefunden gibts wohl nur wenn man auf einen Kunden geht und für diesen dann eine Neue Bestellung anlegt etwas umständlich besser wäre wenn man das direkt bei den Bestellungen machen könnten hier einfach nen Icon für neue Bestellung wäre doch um einiges einfach und wenn man dann ggfs darüber einfach den passenden Kundne über die KundenID auswählt.

Zudem kann ich nicht mal eine neue Bestellung für einen Kunden anlegen sobald ich hier auf Neue Bestellungen klicke passiert nichts. Keinerlei Funktion ist beim Plugin auch angeschalten.

Share this post


Link to post
Share on other sites

sobald das order source installiert ist, bleibt die "Bestellungen" liste leer. ohne das source modul wird alle richtig angezeigt, aber die änderungen werden bei den bestellungen mit einer fehlermeldung quittiert.

Share this post


Link to post
Share on other sites

nach oben schieb. gibts hier weitere Entwicklungen zu?

Es ist etwas nervig meinen Bürodamen zu erklären wie sie bestellungen direkt in der MySQL datenbank änern sollen.

Share this post


Link to post
Share on other sites

nach oben schieb. gibts hier weitere Entwicklungen zu?

Es ist etwas nervig meinen Bürodamen zu erklären wie sie bestellungen direkt in der MySQL datenbank änern sollen.

bei welcher shopversion hast es am laufen ?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...