Jump to content
xt:Commerce Community Forum
Sign in to follow this  
Shinzon

Shop Von Einem Server Zum Anderen Verschieben

Recommended Posts

Hi ihr Lieben

Ganz grosses Problem..

Euer Super gemachter Shop mag uns nicht mehr..

Also wir haben den Shop auf einem Webpaket gehabt.. dieses wird aber zu klein also haben wir uns nen Server zugelegt.

Der ist nun auch online und alles ist schick.. nun m?chte ich den Shop komplett so wie er ist mit all seinen daten (?ber 5000 Produkte) ?bertragen. Andere Domain neue Daten bank usw..

Habe den Shop auf die platte geladen, ihn dann auf den server ?bertragen, alle rechte neu gesetzt und die config dateien umgeschrieben, desweiteren komplette Datenbank sicherung eingespielt.. Datenbank ist vorhanden und dann tabellen sind alle da.. auch aufm server ist alles vorhanden.. Index.php bleibt aber weiss.. es passiert einfach nix.

Sagt mir bitte nicht das da? nicht m?glich ist? Ich habe nicht die zeit und auch nicht lust nochmal 5000 produkte neu zu schreiben. Das muss doch gehen!! Bitte bitte

Habe vieles versucht, aber die index will einfach nicht.

Der server ist aber notwendig.. shop muss unbedingt da drauf.. und halt auch alle dateien..

Was habe ich da nun f?r m?glichkeiten!! Das die index bzw der shop das nicht merkt das ich ihn umschiebe. haben die config datein auch alle umgeschrieben auf die neuen daten. die 4 st?ck

ist es m?glich den Shop neu zu installieren und dann die datenbank einzuspielen, und die bild dateien extra hochzuladen? Findet er dann alles wieder?

Bitte Bitte suchen Fachrat.. Wollen euren Shop nicht aufgeben und halt auch nicht alles neu schreiben nur wegen server wechsel.. DANKE DANKE DANKE

Share this post


Link to post
Share on other sites

Hi.

Hast Du auf dem neuen Server auch XT:C neu installiert oder nur alles vom alten Server r?berkopiert und dann die Backups eingespielt?

Ich denke das zweite. Gelle? Zumindest liest es sich so.

Versuch es bitte mal mit einer Neuinstallation. w?hrend des Installationsvorgangs kannst Du ja dann bereits die Sicherung Deiner Datenbank (***.sql) mit einem Trick importieren lassen. Mache eine Kopie Deiner original ***.sql Datei und benenne sie um in xtcommerce.sql. Diese kopierst Du dann VOR DER INSTALLATION in den Ordner XTC_INSTALLER.

Wenn Du nun die Installation durchf?hrst, sollten alle Deine Daten importiert werden.

Danach musst Du dann nat?rlich Dein Layout/Template wiederherstellen. Das sollte sich jedoch mit kopieren des alten Template Ordners machen lassen.

Feedback, ob?s geklappert hat w?re sch?n! :pint: :D

Hartmut

Share this post


Link to post
Share on other sites

Jo habe noch viel gespielt.. und mir dann gedacht OK machste neu install und dann

die datenbank datei umbenennen..

Produktbilder hochgeladen und auch das Template mit reingehauen..

DER SHOP L?UFT!!! :z: :z: Man muss nur geduld haben.. sind nur computer die machen keine fehler.. *meistens* sind aber sehr pingelig....

Jetzt habe ich noch ein kleines problemchen..

Der kann keine umlaute mehr.. alle umlaute sind "?"

hat da die sprachdatei ne macke.. ? war aber bei der installation schon so.

Hat der nu dummerweise das englische layout genommen? Finde ich schon raus..

Aber LOB Eurer Shop ist einfach nur GEIL! musste mal gesagt werden. k?nnen sie 1000? teuren dinge mal ne scheibe abschneiden..

Wenn ich die 3. version kaufe.. geht dann auch das DB backup.. m?chte gerne langsam mal investieren.. die jungs haben das verdient.. und 100? sind l?cherlich f?r nen shop..

Aber muss dann ja halt auch funzen.. die produkte schreib ich nicht alle neu..

mfg!!

Aber auch dann sollte die db funktionieren..

Share this post


Link to post
Share on other sites

Bitte Bitte in dem Punkt noch mal helfen..

es gehen keine umlaute!! es ist aber die deutsche sprach file.. oder ordner..

Die Bilder die umlaute enthalten gehen auch nicht!! ist das jetzt eventuell nen server problem das der das nicht rafft.. oder liegt das an dem shop..? es geht nicht..

habe paar bild dateien mit ??? und auf dem alten space gingen die auch ohne probleme.. aber jetzt im neuen sind alle umlaute ???? und die bilder mit umlaut werden nicht angezeigt.. schn?f... also noch 3h basteln... fehler suche.. grml

Share this post


Link to post
Share on other sites

Bist ja schon von allein drauf gekommen. :)

Hauptsache l?uft!

Wenn ich die 3. version kaufe.. geht dann auch das DB backup.. m?chte gerne langsam mal investieren.. die jungs haben das verdient.. und 100? sind l?cherlich f?r nen shop.

Meines Wissens ist ein Update auf die V3 nicht m?glich. Die V3 ist wohl zu mehr als 50% neu programmiert und (leider) nicht mehr mit dem Vorg?nger kompatibel. :cry:

Aber ich kann Dir die V3.02 nur w?rmstens empfehlen. Ich pers?nlich finde Sie um Welten besser, als die V2 (was jetzt nicht heissen soll, das die schlecht ist).

Aber ich komme damit besser klar. :dafuer:

Und die 98,- Euro sind nicht Kaufpreis, sondern eine Geb?hr f?r 12 Monate Support, durch die Entwickler im V3 Forum. Da kommt man als Nicht-Sponsor nicht rein.

Da ich im Moment noch allein zurecht komme, bin ich noch kein Sponsor. Ich will ja keine Monate verschenken :i:. Aber die 98,- Euro finde auch ich, im Gegensatz zu einigen anderen hier im V2 Forum, mehr als gerechtfertigt. :dafuer:

Support durch die Entwickler f?r die V2 wird nicht mehr geleistet.

Wie lautet denn die URL von Deinem Shop? Bin neugierig .... :pst:

Hartmut

Share this post


Link to post
Share on other sites

Darf ich leider noch nicht sagen.. weil wir noch nicht alle Lizenzen haben.. und der Shop noch nicht public ist.. Wird einschlagen wie Bombe im Net.. sind einmalige Produkte die aber jeder im Haus hat.. *r?tsel*

Wie bekomme ich die umlaute nun weg.. Die Produkte neu schreiben, ggf. neu hochladen?

hm naja das ist ?rgerlich.. weil w?rde ihn gerne kaufen, weil der Preis ist OK ..der shop muss nicht ?bernommen werden.. nur die produkte..!!! 5000 an der zahl da bin ich dann wieder nen jahr besch?ftigt die reinzumalen.. ne ne lass gut sein... sry.. mal schauen.

Share this post


Link to post
Share on other sites

Hast Du Deinen Apache Server auch auf "AddDefaultCharset ISO-8859-1" konfiguriert

Wenn der n?mlich, wie so oft, auf "UTF-8" steht, dann k?nnte es daran liegen.

Hartmut

Share this post


Link to post
Share on other sites

Probiere ich eben mal aus..

Naja in der datenbank stehts mit ???

Nur auch die Men?s mit umlauten sind fragezeichen.. kann sein das der apache das nicht gerafft bekommt..

hm ich habe Fedora linux aufm server..

Die einstellungen bringen auch nix.. hmpf.. muss ich doch noch ssh machen..

zu so sp?ter stunde..

Share this post


Link to post
Share on other sites

Naja muss aufn server greifen.. mit putty.. auch sprich ssh

Habe root server.. und nu muss ich sehen wie ich an den ganzen kram rankomme

Ist grausam.. server habe ich erst seit gestern.. scheint aber da nen problem zu sein.. nur das komische ist ja.. wenn ich mit hand die dinger umschreibe dann macht der des im Browser auch

als bsp content manager.. das Privatsph?re und datenschutz.. war ? im ?

mit hand umgeschrieben nu ists nen ? auch im Browser.. !!

also nu bin ich hmpf.. kann es sein das die datenbank das nicht mag. die ? richtig ?bertragen.? weil wenn das nen server problem w?re dann w?rde das ? da jetzt nicht stehen .. glaub ich zumindest..

Sehr merkw?rdig..

Share this post


Link to post
Share on other sites

MySQL-Problem denke ich nicht. die DB frisst eigentlich alles.

Wie gesagt, so solltest Du als erstes Apache auf "AddDefaultCharset ISO-8859-1" setzen.

Dann in XT:C im Pfad ./lang/german/german.php auf @setlocale(LC_TIME, 'de_DE'); stellen, wenn der Server unter Linux l?uft. Vieleicht reicht ja sogar das allein schon.

Hartmut

Share this post


Link to post
Share on other sites

Ach... und Dein Browser muss nat?rlich auch auf ISO-8859-1 eingestellt sein.

Hier bei Firefox: ANSICHT-->ZEICHENKODIERUNG-->WESTLICH ISO-8859-1

Hier beim IE: ANSICHT-->CODIERUNG-->WESTLICH (ISO)

Hartmut

Share this post


Link to post
Share on other sites

Korrektur:

Ich schrieb vorhin:

Meines Wissens ist ein Update auf die V3 nicht m?glich. Die V3 ist wohl zu mehr als 50% neu programmiert und (leider) nicht mehr mit dem Vorg?nger kompatibel.

Das stimmt so nicht mehr. Mittlerweile gibt es ein Updatescript. :D Aber das gibt es nur im Downloadbereich f?r Sponsoren. Sorry f?r die falsche Info. War keine Absicht. Wusste ich nicht, da ich ja nicht in den Downloadbereich der Sponsoren gucken kann. Habe das eben durch Zufall gelesen.

Hartmut

Share this post


Link to post
Share on other sites

das Problem mit den Umlauten habe ich auch.

Wenn ich eine Datenbanksicherung per PHPMyAdmin auf meinem lokalen xampp einspielen will.

Dann sind die Umlaute weg. Beim einspielen beim lokalen PHPMyAdmin steht dann was mit Codierung UFT-8. Allerdings ist bei den conf-Files alles mit dieser ISO-Codierung drinnen.

Sind das "Versionsprobleme" ?

Share this post


Link to post
Share on other sites

Originally posted by Data-X@Jan 10 2005, 09:14 AM

Korrektur:

Ich schrieb vorhin:

Das stimmt so nicht mehr. Mittlerweile gibt es ein Updatescript. :D Aber das gibt es nur im Downloadbereich f?r Sponsoren. Sorry f?r die falsche Info. War keine Absicht. Wusste ich nicht, da ich ja nicht in den Downloadbereich der Sponsoren gucken kann. Habe das eben durch Zufall gelesen.

Hartmut

Also kann man jetzt 100% updaten? Weil uich wollt jetzt mit dem V2 anfangen und wenn es sich lohnt dann auf V3 wechseln...sonst muss ich mir jetzt was ?berlegen. ;)

Share this post


Link to post
Share on other sites

Also mit dem sofortigen Wechsel zur V3 w?rdest Du Dir viel Arbeitszeit sparen.

Alleine aus gesetzlichen Gr?nden, muss sehr viel angepasst werden in der V2. Sonst riskiert man unn?tig Abmahnungen.

Aber wenn Du erst mit der V2 anfangen willst, dann kannst Du sp?ter updaten.

Mein pers?nlicher Rat: Nimm gleich die V3. Besser, schneller und komfortabler. :dafuer:

Die 98,- Euro Supportgeb?hr sind Witz, wenn Du das allein mit der Zeitersparnis aufrechnest. Also die Zeit die Du f?r Anpassung und sp?ter f?r?s Update brauchst. Die ersparte nervliche Belastung kann man ja gar nicht in Geld aufwiegen.

Hartmut

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...