Jump to content
xt:Commerce Community Forum
Sign in to follow this  
ochmonek

4.2 Installation hängt, läuft nicht weiter

Recommended Posts

Hallo,

beim Installer zeigen 3 rote Kreuz dass ich folgendes nicht hätte:

Magic quotes on

Mode rewrite

PHP Soap Libery

erstes wurde aber expizit eingeschalten und auch überprüft

Fehler beim ersten Installationsschritt:

oben am Fenster kommt:

Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295 Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170

und der Installer sagt nur installieren, updating.

Es geht aber nicht weiter. im Log wizard steht nur Installation gestartet...

im Server Log steht:

[Thu Nov 27 15:20:11 2014] [error] [client 193.28.229.197] PHP Warning: mysql_connect(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /srv/www/htdocs/web4/html/xtFramework/library/adodb5/drivers/adodb-mysql.inc.php on line 443

[Thu Nov 27 15:20:11 2014] [error] [client 193.28.229.197] PHP Warning: mysql_connect(): [2002] php_network_getaddresses: getaddrinfo failed: Name or service no (trying to connect via tcp://_SYSTEM_DATABASE_HOST:3306) in /srv/www/htdocs/web4/html/xtFramework/library/adodb5/drivers/adodb-mysql.inc.php on line 443

[Thu Nov 27 15:20:11 2014] [error] [client 193.28.229.197] PHP Warning: mysql_connect(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /srv/www/htdocs/web4/html/xtFramework/library/adodb5/drivers/adodb-mysql.inc.php on line 443

[Thu Nov 27 15:20:11 2014] [error] [client 193.28.229.197] PHP Fatal error: Call to a member function getStores() on a non-object in /srv/www/htdocs/web4/html/xtFramework/library/adodb5/xtcommerce-errorhandler.inc.php on line 91

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=license&next=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=license&next=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=license&next=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=license&next=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=license&next=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=license&next=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=license&next=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=license&next=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=language&lng=de.en&sel_country=DE&sel_language=de&demodata=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=language&lng=de.en&sel_country=DE&sel_language=de&demodata=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=language&lng=de.en&sel_country=DE&sel_language=de&demodata=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=language&lng=de.en&sel_country=DE&sel_language=de&demodata=1&install_lang=de&WizardType=1

[Thu Nov 27 15:21:31 2014] [error] [client 193.28.229.197] PHP Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170, referer: http://www.domain.de/xtWizard/index.php?script=StartPageScript&wpage=language&lng=de.en&sel_country=DE&sel_language=de&demodata=1&install_lang=de&WizardType=1

Wer weiß hier Rat?

lg ochmonek

Share this post


Link to post
Share on other sites

War deine Version vorher die 4.1.10?

Wichtig ist wohl:

1. Version auf 4.1.10 updaten

2. Den Fix einspielen http://www.xt-commerce.info/index.php?_m=downloads&_a=viewdownload&downloaditemid=413&nav=0,3,24

3. Anschließend dieses Paket laden http://www.xt-commerce.info/index.php?_m=downloads&_a=viewdownload&downloaditemid=423&nav=0,5,7

4. Aus dem Paket den xtWizard (nur den xtWizard) auf den Server laden und den Wizard starten

5. Wenn der Wizard durchgelaufen ist, wird er mitteilen, wann die restlichen Dateien aus dem Paket hochgeladen werden sollen.

Share this post


Link to post
Share on other sites

Hallo,

es war eine Neuinstallation, kein Update.

Habe gerade gesehen, dass 2 kleine Änderungen der Download Version vom 28.11 da sind, versuche nochmals die Neuinstallation und gebe Bescheid, ob es nun geht bei mir.

danke und lg

War deine Version vorher die 4.1.10?

Wichtig ist wohl:

1. Version auf 4.1.10 updaten

2. Den Fix einspielen http://www.xt-commerce.info/index.php?_m=downloads&_a=viewdownload&downloaditemid=413&nav=0,3,24

3. Anschließend dieses Paket laden http://www.xt-commerce.info/index.php?_m=downloads&_a=viewdownload&downloaditemid=423&nav=0,5,7

4. Aus dem Paket den xtWizard (nur den xtWizard) auf den Server laden und den Wizard starten

5. Wenn der Wizard durchgelaufen ist, wird er mitteilen, wann die restlichen Dateien aus dem Paket hochgeladen werden sollen.

Edited by ochmonek

Share this post


Link to post
Share on other sites

Habe neueste Version nun versucht, selber Fehler leider.

Wo kann ich den Fehler eingrenzen? bzw wo zu suchen anfangen?

Nach Eingabe der Daten für die Datenbank kommt auf der nächsten Seite dieser Fehler, geht auch nicht weiter dann. Hängt einfach.

lg

Hallo,

es war eine Neuinstallation, kein Update.

Habe gerade gesehen, dass 2 kleine Änderungen der Download Version vom 28.11 da sind, versuche nochmals die Neuinstallation und gebe Bescheid, ob es nun geht bei mir.

danke und lg

Share this post


Link to post
Share on other sites

auch bei mir klappt die neu installation nicht. nur mod_rewrite besitzt ein kreuz... obwohl alles richtig ist.

auf der nächsten seite alle datenbankdaten eingegeben und dann sagt der wizard, ich bräuchte eine MYSQL5 datenbank.

dabei habe ich eine mysql5 datenbank angelegt... so nun kann ich seit tagen das shopsystem nicht installieren. SUPER!

weiß jemand rat, wo der wizard hier die falsche datenbank version ausliest?

Share this post


Link to post
Share on other sites

Habe heute die Version vom 03.12 versucht, selbiger Fehler. Software lässt sich nicht installieren.

MySQL Version ist die 5.1.63 auf PHP 5.3.5

Wer weiß wo ich suchen kann um den Fehler einzugrenzen??

lg

Habe neueste Version nun versucht, selber Fehler leider.

Wo kann ich den Fehler eingrenzen? bzw wo zu suchen anfangen?

Nach Eingabe der Daten für die Datenbank kommt auf der nächsten Seite dieser Fehler, geht auch nicht weiter dann. Hängt einfach.

lg

Share this post


Link to post
Share on other sites

ich habe den wizard vom server gelöscht und den aus dem download vom 03.12. auf den server gepackt. und siehe da: ES LÄUFT! :D

Sind jeden Tag patches für den wizard hinzugekommen, die auch die strangesten server abfangen. 05.12. release sollte bei 99% aller server/hostings problemlos gehen

Share this post


Link to post
Share on other sites

Hallo Alex,

mit Version vom 05.12 versucht. Selber Fehler. Installation läuft nicht weiter.

ich glaube ja auch nicht unbedingt, dass mein Fehler die Server conf ist, die anderen Versionen sind ja immer gelaufen, sagt dir im ersten Bericht die Fehlermeldung was?

Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170

??

lg

Sind jeden Tag patches für den wizard hinzugekommen, die auch die strangesten server abfangen. 05.12. release sollte bei 99% aller server/hostings problemlos gehen

Share this post


Link to post
Share on other sites

Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170

der sollte in der version vom 05.12 behoben sein. sicher dass du diese version genommen hast? (Siehst du am dateinamen)

Share this post


Link to post
Share on other sites

mit Version vom 5 und auch vom 8 versucht,

selbiger Fehler, bei Installationsbeginn ( Bach Eingabe der Datenbank Daten) kommt oben am Schirm folgendes:

Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295 Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170

und die Installation hängt, wenn ich mit f5 aktualisiere kommt an stelle von installieren....-> updating, geht aber nach wie nichts weiter

Leider :-)

lg

bin mir ziemlich sicher, ich versuche es nochmal und gebe Bescheid.

lg und danke

Share this post


Link to post
Share on other sites

mit Version vom 5 und auch vom 8 versucht,

selbiger Fehler, bei Installationsbeginn ( Bach Eingabe der Datenbank Daten) kommt oben am Schirm folgendes:

Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295 Warning: Invalid argument supplied for foreach() in /srv/www/htdocs/web4/html/xtFramework/classes/class.language.php on line 295 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 85 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 137 Warning: Variable passed to each() is not an array or object in /srv/www/htdocs/web4/html/xtFramework/classes/class.cart.php on line 170

und die Installation hängt, wenn ich mit f5 aktualisiere kommt an stelle von installieren....-> updating, geht aber nach wie nichts weiter

Leider :-)

lg

der Fehler könnte passieren wenn alle sprachen für einen store deaktiviert sind:

bestes Beispiel ist, wenn man Whitleist Konfiguration benutzt und hier keine Haken bei "Lokalisierung => Sprachen => *Sprache* Reiter: "Shop"" setzt.

( Hier fehlt der Whitelist Hinweis und ein Fallback im Shop verhindert, dass das Problem im FE des Shops sichtbar wird. )

Share this post


Link to post
Share on other sites

Bekomme auch Fehler von der DB zugesandt per Mail:

mysql error: [1048: Column 'language_code' cannot be null] in EXECUTE ....

und bei Install habe ich Haken gesetzt bei Demo, Deutsch und Englisch.

lg

der Fehler könnte passieren wenn alle sprachen für einen store deaktiviert sind:

bestes Beispiel ist, wenn man Whitleist Konfiguration benutzt und hier keine Haken bei "Lokalisierung => Sprachen => *Sprache* Reiter: "Shop"" setzt.

( Hier fehlt der Whitelist Hinweis und ein Fallback im Shop verhindert, dass das Problem im FE des Shops sichtbar wird. )

Share this post


Link to post
Share on other sites

Hallo,

auch bei der Version vom 11.12 gleiche Probleme.

Installation bis jetzt nicht möglich.

lg

Bekomme auch Fehler von der DB zugesandt per Mail:

mysql error: [1048: Column 'language_code' cannot be null] in EXECUTE ....

und bei Install habe ich Haken gesetzt bei Demo, Deutsch und Englisch.

lg

Share this post


Link to post
Share on other sites

Bekomme auch Fehler von der DB zugesandt per Mail:

mysql error: [1048: Column 'language_code' cannot be null] in EXECUTE ....

und bei Install habe ich Haken gesetzt bei Demo, Deutsch und Englisch.

lg

1. Bitte dem Support mailen ( helpdesk@xt-commerce.com ), das Forum wird nicht von xt:Commerce betreut

2. Nicht den interessanten Teil der Fehlermeldung entfernen

3. Wann genau kommt den diese Mail, noch während der Installation oder danach?

Share this post


Link to post
Share on other sites

Hallo,

an Support habe ich geschrieben, Ticket zugewiesen, wird wohl etwas dauern.

Mail kommt im Zuge der Installation, die DB wurde angelegt bzw zumindest teilweise, ab dann hängt es vermutlich.

Wie gesagt schaut bei mir der Installationsvorgang so aus: Aufruf, Eingabe der Daten, Installation läuft ..... ab dann hängt alles :-(

Melde mich wenn es eine Lösung gibt.

lg und schöne Feiertage.

1. Bitte dem Support mailen ( helpdesk@xt-commerce.com ), das Forum wird nicht von xt:Commerce betreut

2. Nicht den interessanten Teil der Fehlermeldung entfernen

3. Wann genau kommt den diese Mail, noch während der Installation oder danach?

Share this post


Link to post
Share on other sites

Habe meinen Webhoster gewechselt, alles IO jetzt.

Support hatte sich noch gemeldet, war aber schon am wechseln.

danke.

lg

ochmonek

Hallo,

an Support habe ich geschrieben, Ticket zugewiesen, wird wohl etwas dauern.

Mail kommt im Zuge der Installation, die DB wurde angelegt bzw zumindest teilweise, ab dann hängt es vermutlich.

Wie gesagt schaut bei mir der Installationsvorgang so aus: Aufruf, Eingabe der Daten, Installation läuft ..... ab dann hängt alles :-(

Melde mich wenn es eine Lösung gibt.

lg und schöne Feiertage.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...