Jump to content
xt:Commerce Community Forum
Sign in to follow this  
flavor

Strato Managed Level X Server + Weiße Seite

Recommended Posts

Moin,

haben gerade von einem Root Server auf einen Strato Managed Level X Server gewechselt. Leider bekommen wir trotzt PHP 5.3.21 und Ioncube 4.2.2 (läuft beides) eine weiße Seite. Die Datenbank Debug-Funktion liefert nichts.

Was kann denn noch für eine weiße Seite verantwortlich sein. Plugins von Drittanbietern vielleicht?

Ach ja, auf dem Root-Server haben wir PHP Version 5.3.10 und Ioncube 4.7.3

Share this post


Link to post
Share on other sites

Danke!

In der log steht

[Sat Jan 10 17:58:37 2015] [warn] [client XXX] mod_fcgid: stderr: PHP Fatal error:  The file /pages/ec/3d/XXX/home/htdocs/ssd/index.php cannot be decoded
[Sat Jan 10 17:58:37 2015] [warn] [client XXX] mod_fcgid: stderr: by this version of the ionCube Loader.
[Sat Jan 10 17:58:37 2015] [warn] [client XXX] mod_fcgid: stderr: If you are the administrator of this site
[Sat Jan 10 17:58:37 2015] [warn] [client XXX] mod_fcgid: stderr: then please install the latest version of the ionCube Loader.
[Sat Jan 10 17:58:37 2015] [warn] [client XXX] mod_fcgid: stderr: in Unknown on line 0[/PHP]

verstehe ich nicht - in der Systemanforderungen für 4.2 steht Ioncube Loader >= version 4, warum sollte die dann nicht reichen?

Share this post


Link to post
Share on other sites

Hi,

warum weiß ich nicht - hatte ich aber auch schon mal, daß sich irgendwas nicht vertragen hat oder auch Zend nicht wollte, habe dann die Versionen getestet, bis es ging.

Cache immer leeren und evtl. auch ein paar Minuten warten (ca. 5 Minuten) und dann noch mal schauen ob es geht. Irgendwann ging es dann.

Und nun überlege ich, ob ich nicht den akt. Ioncube 4.7.x aufspiele, habe 4.6.x.

Schön wäre hier natürlich eine Art Plugin, damit das ganze Geraffel mal/noch einfacher wird... ;):D

Kannst ja mal Bescheid geben, welche Version funktioniert hat.

Erfolgreiche Grüße

Nils

Share this post


Link to post
Share on other sites

Könnte sein, da einige von den Spezis auf die IP/Domain Lizenzieren, muss aber nicht...

Das Problem hatte ich allerdings auch schon mal früher.

Und nun überlege ich, ob ich nicht den akt. Ioncube 4.7.x aufspiele, habe 4.6.x.

Habe nun die Ioncube auf 4.7.x aktualisiert und es geht.

Hier sollten mal die Shop-Betreiber den Punkt "Systemanforderungen" in der Anleitung auf dem neusten Stand bringen, denn entgegen der Anleitung geht's mit den Ioncube 4.2.2 nicht! Sowas kann viele unnötige Stunden kosten.

Share this post


Link to post
Share on other sites

Schön wäre hier natürlich eine Art Plugin, damit das ganze Geraffel mal/noch einfacher wird... ;):D

Tatsächlich und erfreulicherweise gibt es bei einer Neuinstallation von xtC4.2 einen Ioncube Installer in neuem xtWizard. Ein großes Plus! Allerdings erkennt er nur ob ein Ioncube drauf ist oder nicht. Welche Version ist wohl egal.

Share this post


Link to post
Share on other sites

Neues Problem - Weiße Seite bei der Datenbank Installation.

Ich versuche mit dem xtWizard nun eine Neuinstallation und somit eine Installation einer neuen Datenbank. Sobald ich die Datenbank-Daten eingegeben habe und auf weiter drücke, kommt wieder eine weiße Seite.

Leere Datenbank vorhanden und Zugangsdaten sind richtig.

Bei der Installationsprüfung des xtWizard's bekomme ich folgende fehlende Systemanforderungen;

- PHP - GDlib v2 - missing - X
- PHP - GDlib GIF Support - missing - X
- PHP Funktion imageftbbox (PHP Freetype unterstützung) X
- PHP SOAP Library (für BillSafe Plugin) X[/PHP]

Die ersten drei werden wohl durch die fehlende PHP GD Erweiterung am Server verursacht - obwohl GD auf dem Managed Server unter PHP Erweiterung aktiviert ist. Hierzu muss ich wohl bei Strato anrufen.

Der letzte Punkt "Soap" ist wohl unwichtig. Andrerseits sind alle Fehler wahrscheinlich nicht für die weiße Seite verantwortlich, da nur für GIF Bilder nötig.

Share this post


Link to post
Share on other sites

Error-Reporting an machen https://xtcommerce.atlassian.net/wiki/pages/viewpage.action?pageId=22151181 und dann erst mal schauen was der Fehler ist

Bin nochmal auf deine Antwort zurückgekommen, und bekomme folgende Fehlermeldung

Fatal error: Call to undefined function mysql_connect() in /pages/ec/3d/d0010719/home/htdocs/ssd/xtFramework/library/adodb5/drivers/adodb-mysql.inc.php on line 442[/HTML]

Hab die Zugangsdaten nochmal überprüft, schein alles ok zu sein. Ideen?

Share this post


Link to post
Share on other sites

Hi,

Danke für die zahlreichen Infos. :D

Ideen hätte ich nur eine, aber wirst Du vermutlich selbst schon alles haben: aktuellste Version vom 9.1. (ggf. noch mal die Daten übertragen)?

Weiter weiß ich leider nicht.

Erfolgreiche Grüße

Nils

Share this post


Link to post
Share on other sites

Ich habe nun die Ursache ausfindig gemacht, allerdings noch keine Lösung dafür.

Die erstellten php.ini durch den xtWixard kompromittieren auf irgendeine Weise die php.ini im Wurzelverzeichnis des Servers.

Wenn ich z.B. eine php.ini in meinem Shop-Verzeichnes mit dem Inhalt zu der aktuellen Ioncube 4.7.3 anlege, werden einige Erweiterungen wie MYSQL oder GD deaktiviert, bzw. nicht mehr aufgelistet (zu sehen in der phpinfo). Wodurch natürlich die neue Datenbank nicht mehr angelegt werden kann. Und was auch die Fehler in den Systemanforderungen des xtWizard's hervorruft.

Wenn ich die php.ini wieder lösche, zeigt mir die phpinfo wieder alle Erweiterungen an wie MSQL, GD Support und FreeType Support. Allerdings habe ich dann auch nur die alte Ioncube 4.2.2 Version, welche mit xtC nicht funktioniert.

Ich habe es auch schon mit .user.ini versucht, wird allerdings vom Server nicht berücksichtigt. Diese wirkt sich sogar wenn ich mich nicht irre, im Gegensatz zu der eignen php.ini, auch auf die Unterstruktur aus.

Vielleicht hat ja einer noch ne Idee.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...