Jump to content
xt:Commerce Community Forum
Sign in to follow this  
JennyP

Update 4.1 auf 4.2 - xtwizard und alle anderen Seiten zeigen nur weiße/leere Seite

Recommended Posts

Hallo liebe Community,

ich habe mich in diesem Forum angemeldet, weil wir seit gestern ein riesengroßes Problem mit unserem Shop haben. Sollte dieser Beitrag im fahlschen Thema schicken, bitte ich um Entschuldigung.

Wir wollten unseren Shop von 4.1 auf 4.2 updaten. Dazu sind wir Schritt für Schritt die Anleitung durchgegangen bis Punkt 3.0. xtWizard: Durchführen des Datenbank-Update

Unter der URL www.ihr-shop.tld/xtWizard/ erscheint nur eine weiße Seite (ja, selbstverständlich haben wir ihr-shop.tdl durch unseren ersetzt). Wir haben auch den Ioncube Loader aktualisiert, aber auch das zeigte keinen Erfolg. Wir vermuten, dass der Fehler beim Ioncube Loader liegt (obwohl wir hier den Hinweis „Installation erfolgreich“ bekommen haben), sind uns aber absolut unsicher. Eine entsprechende php.ini ist im xtWizard Ordner vorhanden.

Wahrscheinlich noch wichtige Infos: PHP und Ioncube sind beide auf 5.5

Im Moment lässt sich weder das Frontend des Shops, noch das Backend öffnen.

Auf der Suche, wie wir den Fehler beheben oder zumindest auslesen können, sind wir auf folgende Seite gestoßen:

https://xtcommerce.atlassian.net/wiki/pages/viewpage.action?pageId=22151181

Diese scheint jedoch nur für Programmierer und Fortgeschrittene geschrieben worden sein, denn für uns ist nicht ersichtlich, welchen Code wir jetzt wie ändern sollen und was danach passieren soll.

Hat irgendjemand eine Idee, was wir noch machen können? Bitte wir benötigen dringend Hilfe :(

Share this post


Link to post
Share on other sites

Hallo,

Wir vermuten, dass der Fehler beim Ioncube Loader liegt (obwohl wir hier den Hinweis „Installation erfolgreich“ bekommen haben), sind uns aber absolut unsicher. Eine entsprechende php.ini ist im xtWizard Ordner vorhanden.

die php.ini gehört auch in den Hauptordner des Shops, in Ordner xtAdmin und ggf. bei xt_payment. Hört sich an, als wenn ihr die dort noch nicht eingefügt habt.

Auf der Suche, wie wir den Fehler beheben oder zumindest auslesen können, sind wir auf folgende Seite gestoßen:

Den Errorlog findet Ihr im Ordner xtLogs.

LG

Share this post


Link to post
Share on other sites

Ich hatte auch diese Probleme.

Schlußendlich geholfen hat, daß ich mir die aktuellste Version des Shop-Paketes (xtWizard ist enthalten) heruntergeladen habe.

In den älteren Versionen war wohl ein Bug im Wizard.

Noch etwas zu der php.ini:

Ich habe hier des öfteren gelesen, daß die php.ini im Shop-Verzeichnis liegen müsse.

Ist das wirklich erforderlich?

Normalerweise befindet diese Datei sich doch im php-Verzeichnis und wenn der Webserver weiß wo er php findet, müsste das doch ausreichen?

Oder gibt es da Unterschiede bei Verwendung von XAMPP?

Bei mir läuft auf einem Debian Linux der Apache nativ, es gibt die php.ini nur im php5-Verzeichnis und alles läuft wie es soll.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...