Jump to content
xt:Commerce Community Forum
Sign in to follow this  
magma2k15

Artikelimport importiert keine Texte

Recommended Posts

In der CSV habe ich ein Feld für den Produktnamen, diese Felder enthalten auch Text, jedoch wird das nicht importiert, sondern nur die anderen Felder

Sprachabhängig ist aktiviert

Die Texte in der CSV enthalten Umlaute und Sonderzeichen

Share this post


Link to post
Share on other sites

nein,

Du must grundsätzlich bei der Import-Definition "Sprachabhängig" anhaken und in der CSV müssen die sprachabhängigen Texte mit der Spaltenüberschrift z.B. "products_description_de" oder "products_name_en" versehen werden .....

... und im utf-8-Format muss die CSV auch sein, sonst wird alles ab dem ersten Umlaut abgeschnitten !

rtfm

Grüsse

Share this post


Link to post
Share on other sites

das ist alles gemacht, trotzdem wird das im Backend nicht angezeigt bzw geladen, ist aber überall im export enthalten

genutzt wird 4.2.0 ohne Patches

abgeschnitten ist nichts

es wird komischerweise der Text auch erst im Backend geladen, wenn man zB den Artikelnamen ändert und das Produkt speichert

beim erneuten Öffnen sieht man dann endlich alle Texte von dem Artikel, auch wenn man sie nicht bearbeitet hat

Edited by magma2k15

Share this post


Link to post
Share on other sites

und dann erst taucht der Artikel im Frontend auf? und warum fehlen die importierten Artikel grundsätzlich im Frontend bei den Neuigkeiten / New products?

und wieso werden die Texte nicht geladen,wenn man einen der importierten Artikel bearbeitet?

Share this post


Link to post
Share on other sites

interessant

wenn ich bei einem importieren Artikel den Namen erneut eingebe, so wie er importiert wurde und dann den Artikel speicher, wird die URL generiert und der Artikel angezeigt

können die URLs nicht rekursiv generiert werden?

liegt es also ganz allein generell an der fehlenden URLs beim Import? diese kann man aber schlecht vorher wissen.wird deswegen auch der Text nicht angezeigt?

Share this post


Link to post
Share on other sites

rtfm

Die Suma-Url wird automatisch beim Import generiert, wenn eine existierende Kategorie-ID in der Spalte "categories" vorhanden ist

#1#2#3 => Suma wird für Kategorie 1 generiert, der Artikel aber noch in die Kategorien 2 und 3 verlinkt

Wenn z.B. die Spalte "url_text_de" einen festen Wert enthält, wird halt der einfach genommen, wenn sie leer ist, gibts keine Suma-Url und Du hast die von Dir beschriebenen Effekte

mfg

Share this post


Link to post
Share on other sites

aber wieso lädt der Editor erst nachdem eine URL generiert wurde und der Artikel erneut importiert wurde die Texte?

"#1#2#3 => Suma wird für Kategorie 1 generiert, der Artikel aber noch in die Kategorien 2 und 3 verlinkt"

der Artikel ist aber nur in einer Kategorie, also wieso steht dann noch eine weitere Kategorie dort?

Edited by magma2k15

Share this post


Link to post
Share on other sites

weils halt so ist,

Alex hat schon mal hier geschrieben, dass halt Artikel ohne gültige SEO-Url nicht ausgeben werden, da gibts keine Diskussion, ist halt so, basta...

Ich habe sehr viel im Bereich Import gemacht, wenn man sich an die "Regeln hält" klappt das super ...

Grüsse

Share this post


Link to post
Share on other sites

komisch,obwohl die importieren Artikel jetzt einer Kategorie zugewiesen sind, steht diese nicht in der exportierten CSV,wie kann das sein?

komisch, jetzt stehts im erneuten export doch drin

aber der Import verläuft generell problemlos aber warum die Texte dann nicht im Editor geladen werden bzw erst nach der Generierung einer Suma-URL ist für mich nicht ganz nachvollziehbar

Edited by magma2k15

Share this post


Link to post
Share on other sites

kann sein, weil date_added leer ist und auch nicht generiert wird beim Import, dass bei Neuigkeiten die importierten Artikel nicht angezeigt werden? ist da nicht als default NOW() in der DB?

ehrlich gesagt wirkt das für mich ziemlich verbuggt

also trotz verschieben und ändern auf die richtige Kategorie sind noch alte Kategorie-Verknüpfungen in xt_products_to_categories

bei denen,die nicht gelöscht wurden, ist store_id = 0, alle anderen haben store_id = 1, aberwieso?

es gibt nur einen Store und der hat die ID 0?

Edited by magma2k15

Share this post


Link to post
Share on other sites

anscheinend überschreibt der Import generell alle Felder der Tabelle, statt NULL ist sogar ein leerer String im Feld für EAN in der Datenbank

da werden wohl nicht alle Feldern einzeln bearbeitet, die auch wirklich in der CSV sind

denn EAN habe ich in der import-Datei nicht und default value in der DB ist für das Feld NULL

hm ....

Share this post


Link to post
Share on other sites

ich glaub aber, dass es nicht verstanden wurde, was ich meine

im Backend bei Shop - Artikel bei der Auflistung sowie dort beim bearbeiten eines Artikels werden die Texte nicht angezeigt bzw geladen

obwohl ein Artikelname in der DB, im Export sowie Import ist, es wird nicht angezeigt

bis man manuell den Artikelnamen nochmal einfügt (, eine Kategorie zuweist) und dann nochmal importiert

und es sollte ja zumindest möglich sein, das ohne Probleme, ohne Kategorie und ohne URL zu bearbeiten, so kann man erstmal Artikel einpflegen und nachträglich eine Kategorie zuweisen

aktuell ist es nicht gerade benutzerfreundlich oder intuitiv

Share this post


Link to post
Share on other sites

so,jeder Artikel hat jetzt die Kategorie in der zu importierenden CSV.

Jedoch wird die Kategorie im Backend nicht zugewiesen, die Artikel verschwinden wieder aus dem Shop.

Und die Texte fehlen immer noch.

komisch,wieso ist jetzt nach dem Ändern des Artikel und der Neuzuweisung der Kategorie die permission_id von 4 auf 3 geändert worden und die Kategorie jetzt2 Mal drin, mit # getrennt

anscheinend gehen nur die, wo store_id in xt_products_to_categories auf 1 ist, bei einem import wird das jedoch auf 0 gesetzt

ist die store_id nicht immer 0?

wenn man Artikel löscht, werden diese auch nicht bei den Startseiten-Artikeln gelöscht. Importiert man genau den selben Datensatz wieder, steht der Artikel noch im Backend bei den Startseitenkategorien,wird aber nicht im Shop im Frontend angezeigt

sehr sehr seltsam

mache ich einen Export,lösche einen der Beispiel-Artikel, importiere die CSV Datei wieder und der Beispiel-Artikel wird angelegt. Jedoch sieht das dann so aus,wie bei den anderen Artikeln auch:

und der Artikel wird nicht mit der Kategorie verknüpft

das ist doch definitiv ein Bug im Import?

post-341394-14337915517011_thumb.jpg

Edited by magma2k15

Share this post


Link to post
Share on other sites

also wenn man das Feld products_store_id auf 1 setzt in xt_products_description, dann werden die Artikel auch im Backend angezeigt

aber wieso? wieso wird das nicht generell angezeigt bzw auf 1 gesetzt?

so auch bei xt_products_to_categories mit dem Feld store_id

jetzt taucht auf einmal bei Import/Export als zusätzliche Auswahl Mainstore mit der ID 1 auf, wenn man das aber auswählt und den Import/Export startet, bekommt man nur folgende Meldung: TEXT_WRONG_STORE_ID

es gibt aber in xt_stores den Eintrag mit shop_id = 1

aber komisch, wieso war bislang alles auf store_id 0 und jetzt verwendet xtc store_id 1? der Shop hatte immer nur den einen Mainstore

Edited by magma2k15

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...