Jump to content
xt:Commerce Community Forum
LeonDP

xtCommerce 4.2.00 mit PHP 5.6?

Recommended Posts

1&1 stellt seit Juli 2016 keine Sicherheitsupdates für die PHP Version 5.5 mehr zur Verfügung.

Auf Grund dessen möchte ich meinen Webshop gerne auf der PHP Version 5.6 laufen lassen. Gibt es diesbezüglich schon Informationen zur Kompatibilität zum xtCommerce 4.2.00 Shop?

Ich freue mich sehr über jede themenbezogene Antwort :)

Share this post


Link to post
Share on other sites

an sich läuft alles wie gewohnt,

je nachdem, welche Plugins eingesetzt werden, kann es zu erhöhten Einträgen in der phpErrors.txt kommen,

falls diese vorhanden ist ( nicht in der Basis-Installation ) und in der debug.php das Error-Reporting eingestellt ist. Auch der Shop selber produziert einige davon, z.B. durch die class.shipping.php, ist aber leicht zu patchen.

Grüsse

Share this post


Link to post
Share on other sites

Vielen Dank für die Zahlreichen Antworten;). Dann werde ich es denke ich erst einmal mit der PHP Version 5.6 auf dem xtCommerce 4.2.00 versuchen. Da ich diese Version erst vor 2 Monaten gekauft habe will ich noch nicht wieder in eine neue Version investieren (oder wäre dies in diesem Fall kostenfrei, da in der Lizensdatei steht "updatesuntil: 2017...":confused:).

Sollte es bei den von mir verwendeten Plugins Probleme geben werde ich diese hier aufführen.

Edit:

Ich habe den Shop nun auf PHP 5.6 umgestellt. Bei 1&1 ist dabei natürlich zu beachten, dass der IonCube Loader auch angepasst wird.

https://xtcommerce.atlassian.net/wiki/pages/viewpage.action?pageId=917654

Folgende von mir verwendete Plugins funktionieren weiterhin ohne Probleme:

  • xt_auto_cross_sell
  • xt_cross_selling
  • xt_master_slave
  • xt_bestseller_products
  • xt_startpage_products
  • xt_coupons
  • sx_fancy_cloud_zoom
  • xt_privacycheck
  • xt_rescission
  • xt_invoice
  • xt_prepayment
  • xt_sperrgut

über andere Plugins kann ich leider keine Auskunft geben.

Share this post


Link to post
Share on other sites
1 hour ago, LeonDP said:

Da ich diese Version erst vor 2 Monaten gekauft habe will ich noch nicht wieder in eine neue Version investieren (oder wäre dies in diesem Fall kostenfrei, da in der Lizensdatei steht "updatesuntil: 2017...":confused:).

Bei sowas am besten beim Helpdesk fragen. (Ich meine gelesen zu haben, dass Ihr einen recht ordentlichen Rabatt auf xtc5 kriegt, vorausgesetzt, dass ihr in den letzten 6 (?) Monaten die Lizenz gekauft habt.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...