Jump to content
xt:Commerce Community Forum
Pumukl18

CKEditor in XTC5 nicht mehr alle Features

Recommended Posts

Hallo zusammen,

wir haben das Update auf den XTC5er Shop durchgeführt.
Nun ist uns aufgefallen dass es hier im CKEditor (ver.4.5.9) nicht mehr die Möglichkeit der Schriftart,-farbe oder Hintergrundfarbe gibt. (siehe Anhang)
Könnt ihr dies bestätigen? Kann ich das irgendwo leicht umstellen? (erweitern der config.js?)
Da ich nicht glaube bei der Migration etwas falsch gemacht zu haben, habe ich mich mal auf der CKEditor seite umgesehen. Es gibt dort das Plugin in "basic", "normal" und "full" version zum herunterladen. Wie ich vermute hat XTC an der stelle nur die "normal" Version integriert, wodurch nun eben oben genannte features nicht mehr verfügbar sind.

Nach Herunterladen der Full-Version und überkopieren der Dateien im Ordner xtFramework\library\ckeditor\4.5.9 hat sich jedoch nichts im xtAdmin / CKEditor verändert.
Selbst wenn ich den Ordner lösche, läuft der Admin und CKEditor immer noch, so dass ich wohl an der falschen Stelle suche.
Hat jemand eine Idee, wie ich oben genannte Features einschalten, oder den CKEditor updaten/überschreiben kann?

 

Vielen Dank im Voraus & Viele Grüße
Stefan

ckeditor.png

Share this post


Link to post
Share on other sites

Hey Pumukl18,

wir haben das gleiche Problem, dass man in die config.js eintragen kann was man will, aber das sich keine Änderungen ergeben. Hast Du eine Lösung für das Problem gefunden?

Danke Dir für eine kurze Rückmeldung,
Thomas

Share this post


Link to post
Share on other sites

Wir haben das gleiche Problem. Änderungen in der "xtFramework/library/ckeditor/config.js" werden ignoriert. Das gleichte Problem bei Änderungen in der "xtFramework/library/ckeditor/4.5.9/config.js".

Ich vermute die erst genannte config.js sind Überbleibsel aus einer älteren xt Commerce Version.

Wir verwenden xt:Commerce 5.1.4 und ckeditor 4.10.0.

 

Share this post


Link to post
Share on other sites

Hallo zusammen,

es ist wichtig dass ihr das aktuelle CKEditor Paket am besten in der FULL-Version herunterladet, um das bestehende unter xtFramework/library/4.5.9/ zu ersetzen.
Dann könnt ihr auch je nach Belieben die conf/custom_config.js anpassen.

So sieht meine aktuelle custom_config.js aus:

CKEDITOR.editorConfig = function( config ) {
   config.toolbar = [
       { name: 'document', groups: [ 'mode', 'document', 'doctools' ], items: [ 'Source', '-', 'Save', 'NewPage', 'Preview', 'Print', '-', 'Templates' ] },
       { name: 'clipboard', groups: [ 'clipboard', 'undo' ], items: [ 'Cut', 'Copy', 'Paste', 'PasteText', 'PasteFromWord', '-', 'Undo', 'Redo' ] },
       { name: 'editing', groups: [ 'find', 'selection', 'spellchecker' ], items: [ 'Find', 'Replace', '-', 'SelectAll', '-', 'Scayt' ] },
       //{ name: 'forms', items: [ 'Form', 'Checkbox', 'Radio', 'TextField', 'Textarea', 'Select', 'Button', 'ImageButton', 'HiddenField' ] },
       '/',
       { name: 'basicstyles', groups: [ 'basicstyles', 'cleanup' ], items: [ 'Bold', 'Italic', 'Underline', 'Strike', 'Subscript', 'Superscript', '-', 'CopyFormatting', 'RemoveFormat' ] },
       { name: 'paragraph', groups: [ 'list', 'indent', 'blocks', 'align', 'bidi' ], items: [ 'NumberedList', 'BulletedList', '-', 'Outdent', 'Indent', '-', 'Blockquote', 'CreateDiv', '-', 'JustifyLeft', 'JustifyCenter', 'JustifyRight', 'JustifyBlock', '-', 'BidiLtr', 'BidiRtl' ] },
       { name: 'links', items: [ 'Link', 'Unlink', 'Anchor' ] },
       { name: 'insert', items: [ 'Image', 'Table', 'HorizontalRule', 'Smiley', 'SpecialChar', 'PageBreak', 'Iframe' ] },
       '/',
       { name: 'styles', items: [ 'Styles', 'Format', 'Font', 'FontSize' ] },
       { name: 'colors', items: [ 'TextColor', 'BGColor' ] },
       { name: 'tools', items: [ 'Maximize', 'ShowBlocks' ] },
       { name: 'others', items: [ '-' ] },
       { name: 'about', items: [ 'About' ] }
    ];
};

PS: WICHTIG, das dies gecacht wird, müsst ihr diesen natürlich danach leeren, so dass die Änderung wirksam ist.

Falls ihr weitere Unterstützung in der Entwicklung und Umsetzung eures Shops benötigt, auch Plugin-Entwicklung, könnt Ihr mich gerne kontaktieren.
www.Panther-IT-Solutions.com

Viele Grüße
Stefan

Share this post


Link to post
Share on other sites

Das austauschen hat keinen Unterschied gebracht. Änderungen in der config.js des Editors, sowie der conf/custom_config.js bewirken nach wie vor nichts. Es sieht auch nicht so aus als würde der Shop auf den ckeditor im library Verzeichnis zurückgreifen. Im Seitenquellcode des Backends findet sich folgende Zeile Code, die daraufhin weißt das auf ein cdn zurückgegriffen wird:

<script src="//cdn.ckeditor.com/4.10.0/full/ckeditor.js"></script>

 

Share this post


Link to post
Share on other sites

keine ahnung, vlt hilft folgendes weiter in conf/paths.php unten

define('CK_EDITOR_VERSION','4.11.4');
define('CK_EDITOR_DISTRIBUTION','full');

ob das dann mit der config.js geht und/oder alles schon drin ist?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...