Jump to content
xt:Commerce Community Forum
Donja

Installation xt 5 - weiße Seite - ionCube

Recommended Posts

Hallo,

wir versuchen verzweifelt seit einer Weile xt:commerce 5 auf uberspace (Hoster) zu installieren.

 

Wir sind der Installationsanweisung von xt:commerce gefolgt. Haben die Shopfiles runter geladen, entpackt, auf den Server geschoben und die Lizensdatei hinzugefügt.

Danach kamen wir leider nicht mehr weiter. Es ist irgendwie gerade frustrierend schon am ersten Schritt zu scheitern.

 

Es kam die Fehlermeldung das der IonCube nicht geladen werden konnte.

 

Nun sind wir auf

http://www.ioncube.com/loaders.php

gegangen und haben uns die entsprechende Datei runter geladen.

Wir haben dann über loader-wizard versucht das ganze zu installieren.

Hier kamen Hinweise was getan werden sollte.

 

Wir haben soweit alles befolgt, auch nach längerem Suchen die root php.ini angepasst (das geht bei uberspace nur über eine Kopie).

Dann erfolgte endlich die Meldung über den Wizard:

"Loader Installed
The ionCube Loader version 10.2.1 for PHP 5.5 is already installed and encoded files should run without problems."

 

Nun dachten wir an einen finalen Erfolg und ruften den Shop auf.

Hier erscheint nun nur eine weiße Seite.
Dies hatten wir von xt:commerce dazu gefunden:
https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/917710/Lokale+xt+Commerce+Installation

Aber hier wird aber darauf hingewiesen das eben dieser Loader wahrscheinlich nicht korrekt installiert ist.

Desweiteren steht in den xLogs folgende Aussage:

"[10-Jun-2018 14:17:10 Europe/Berlin] PHP Fatal error:  The file /var/www/virtual/XXXXX/html/SHOPORDNER/xtFramework/classes/class.plugin.php cannot be run by the ionCube Loader. Please ask the script provider to supply an encoded file that can run on your version of PHP, 5.5. in Unknown on line 0"

 

Wir drehen uns im Kreis und wir wissen nun nicht wie wir diesen Shop installiert bekommen.

Wir erhalten keine klaren Aussagen-Fehlermeldungen. Auch der "Debug-Modus" bringt nichts, denn die Seite bleibt weiß auch wenn dieser aktiv ist.

 

Habt Ihr Ideen was getan werden kann?
Finde es sehr irritierend das eine Shopinstallation so schwierig zu sein scheint. Das bereitet uns Sorge bezüglich der zukünftigen Nutzung des Shops.

Viele Grüße

Kat

 

Share this post


Link to post
Share on other sites

Hallo,

scheint ja ein ioncube-Fehler zu sein.

Stimmt die PHP-Version mit der (ioncube-)php.ini-Datei überein? Denn wenn php 7.2 installiert sein sollte, aber in der php.ini nur 5.5 steht, stimmt es nicht und dann quittiert xtc das ganz schnell mit einer weißen Seite oder im besten Fall einer Fehlermeldung (in der php.ini Datei 5.5 mit 7.2 ersetzen, bzw. das, was der Hoster anbietet/unterstützt - 5.5 wäre etwas veraltet).

Die php.ini Datei kommt einmal ins Hauptverzeichnis rein und auch in den ioncube-Ordner sowie in den Wizzard-Ordner, denn sonst läßt sich das auch nicht richtig installieren.

Sollte eigentlich in der Anleitung alles richtig drin stehen und wenn man es mal verstanden hat, geht es auch einfach (außer, das der Hoster ggf. mit einem zu kleinen Paket gelockt hat?).

Erfolgreiche Sonntagsgrüße
Nils

Share this post


Link to post
Share on other sites
9 hours ago, Donja said:

The ionCube Loader version 10.2.1 for PHP 5.5 is already installed and encoded files should run without problems.

 

php 5.5 ist aber nicht kompatibel mit der 5.x.x; min. 5.6 besser 7.x.

(Dahingehend hat XT vermutlich auch nur für 5.6-7.2 verschlüsselt und es kommt ein ioncube error)

Share this post


Link to post
Share on other sites

Hallo Ihr,

danke für die vielen Hinweise.

Ich habe nun über Konsole auf meinem Server die PHP-Version auf 5.6 gestellt.
Die php.ini entsprechend angepasst etc.

Dann die Version 5.6 iconCube installiert und jetzt kommt zumindest die Installationsmaske.
Ich bin gerade etwas skeptisch aber hoffe das die Installation nun fruchtet.

Scheinbar lag es an der PHP-Version 5.5 des Servers.
Aber schon seltsam, denn es scheint ja eine iconCube Version für 5.5 zu geben.

Bin gespannt ob ich durch komme.

 

Danke für die Hilfe!

 

Viele Grüße

Kat

Share this post


Link to post
Share on other sites

Es ist mehr als deprimierend.

Nun scheint uberspace nicht die korrekte Datenbankversion zu haben.

Eine neue erhalte ich nur über einen neuen Zugang.

Demnach müsste ich per DNS handieren oder aber einen neuen Lizenskey kaufen, da xt:commerce sich den Domainwechsel bezahlen lässt. Bis jetzt bin ich nicht gerade sehr erfreut über dieses System.

 

Was noch ein Problem ist - was nicht direkt was mit dem Shop zu tun hat - ist das Einloggen in das Forum.
Ich muss jedesmal mein Passwort neu setzen wenn ich mich hier einloggen möchte. Da mein gesetztes Passwort jedesmal nicht funktioniert.
Ich habe es schon 5 mal neu gesetzt seit vorgestern. Wie kann das sein?

 

Viele Grüße

Kat

Share this post


Link to post
Share on other sites

Für einen Shop sollte man dann schon ein ordentliches Hosting Buchen und kein Webspace bei irgendeinem Billig Provider.

PHP 5.5 wurde 2014 veröffentlicht und auch der support dafür ist bereits 2016 ausgelaufen.

Empfohlen wird PHP 7.2 und mysql 5.7 - da dies auch dementsprechende Geschwindigkeitsvorteile mitbringt.

https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/917573/Systemanforderungen

Share this post


Link to post
Share on other sites

Der "Billig Provider" diente als Testserver und hat, bis auf xt:commerce bisher sehr gute Dienste geleistet, da ich hier per Konsole so gut wie alles editieren/konfigurieren kann - auch die PHP Version (siehe oben).

Einziges Manko ist nun die DB-Version. Auch hier gäbe es eine Lösung von dem Hoster, allersdings mit neuem Account.
Solch eine Aussage "sollte man schon ein ordentliches Hosting Buchen" ist nicht hilfreich.

Habe die extra Lizenz nun erworben und installiere den Shop später (wenn die Lizenz da ist) erneut.



 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...