Jump to content
xt:Commerce Community Forum
elektroede

Cache löschen XT:Commerce 5.1.3 | mysqli error

Recommended Posts

Hallo,

ich bekomme immer wieder in unregelmäßigen Abständen (etwa täglich) eine SQL Error eMail. Da steht dann zum Beispiel:

mysqli error: [-32000: Cache write error] in CacheExecute(/mnt/pfad/cache/adodb/fe/adodb_fed96f53aae0f6dc83e847bc6dddf781.cache, SELECT pc.code FROM xt_plugin_code pc WHERE pc.hook = ? AND pc.code_status = 1 and pc.plugin_status = 1 order by pc.sortorder)
#0 /mnt/pfad/xtFramework/library/adodb-5.20.12/adodb.inc.php(2077): ADODB_Error_Handler(...)
#1 /mnt/pfad/xtFramework/classes/class.hookpoint.php(0): CacheExecute(...)
#2 /mnt/pfad/xtFramework/classes/class.content.php(554): PluginCode(...)
#3 /mnt/pfad/xtFramework/classes/class.content.php(521): getSubContent(...)
...

 Current Shop Id = 1 
 All Stores: 
 id: 1 - Name: www.meinshop.de

Nun habe ich den Tipp bekommen, einmal alle Dateien im Cache Ordner zu löschen und dem Ordner dann die Rechte 777 zu geben. Aber ich kann einige der Dateien per FTP gar nicht löschen. Bzw. scheint es so als würden sie gelöscht werden und sind dann im nächsten Augenblick wieder da.

Wenn ich die Cache löschen Funktion im Backend benutze, kommt zwar die Rückmeldung "cache gelöscht" aber im FTP sieht man, dass alle Dateien noch vorhanden sind.

Sollte ich versuchen, den Order cache/adodb, z.B. mit Putty, komplett zu leeren? Also alle Unterordner (00 bis ff) und die darin befindlichen .cache-Dateien? Oder gibt es da Bedenken? Oder gibt es einen ganz anderen Lösungsansatz für dieses Problem?

Vielen lieben Dank!

Elektroede

Share this post


Link to post
Share on other sites

Hi,

 

so wie ich das gerade rauslese hast du die Funktion "Datenbank Hooks verwenden" auf "false". Dadurch werden Plugins-Hooks im Cache gespeichert. Mir sind viele Stellen bekannt wo dies nicht wirklich funktionsfähig ist und ich würde diese EInstellung nicht empfehlen.

 

Im Backend:
Einstellungen -> Konfiguration -> Performance

 

Dort "Datenbank Hooks verwenden" auf "true" stellen und das Problem sollte nicht mehr aufkommen.

 

https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/917615/Performance

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...