Jump to content
xt:Commerce Community Forum
Klocke-Verlag

Update 5.0 auf 5.1

Recommended Posts

Hallo !

Wie ist die korrekte Vorgehensweise für das Update von 5.0 auf 5.1 ?
Leider funktioniert das Update bei mir nicht so wie im Handbuch beschrieben:
https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/493158401/Anleitung+xt+Commerce+5.0.x+auf+5.1.x+updaten

Mein Vorgehen war so:

1. Ich habe die aktuelle Version heruntergeladen (v5.1.4-2018-10-30), entpackt und den Ordner xtWizard in mein Shopverzeichnis geladen.
2. Ich habe die Plugins: xt_addthis, xt_facebook und xt_feedbackplus! deaktiviert.
3. Ich habe die URL www.ihr-shop.tld/xtWizard/ (natürlich mit meinem Server) aufgerufen.

Nun erhalte ich folgende Meldung:
The file /is/htdocs/wp000000_P1X5DXSPVS/www/shop/xtWizard/lib/Loader.php is corrupted. (wp0000000 habe ich hier geändert)

Anschließend habe ich noch alle restlichen Plugins deaktiviert, falls diese das Update stören würden.

Leider bringt dies auch keine Änderung.

Mein Hoster ist Hosteurope und mein Server läuft aktuell auf der PHP 7.0 Version (Den Ioncube loader stellt hierbei Hosteurope in der Version 6.0.9. An dieser Version kann ich leider nichts ändern.)

Ich hoffe ich finde hier etwas Hilfe zu meinem Problem.
Besten Dank im Voraus.

G.Klocke

Share this post


Link to post
Share on other sites

Danke für die Antworten.

Sobald ich aber die PHP-Version auf 7.1 oder 2 stelle, erhalte ich nur noch einen weißen Screen.
In der Anleitung steht ja auch, dass erst nach dem Update der Wechsel von 7.0 auf 7.1 oder 2 möglich ist.

Hier beißt sich die Katze also in den Schwanz ☹️.

Meine Idee wäre das Update lokal (unter XAMPP) zu machen und später wieder hochzuladen. Leider habe ich damit aber noch keinerlei Erfahrungen.
Gibt es dazu irgendwo eine Anleitung wie das speziell für xt:commerce geht?

Habe bisher nur allgemeine Anleitungen zu XAMPP gefunden. Mir ist klar, dass das eine externe Software ist und hier nicht supportet wird. 
Nur falls einer einen guten Link weiß, erspart es mir bestimmt lange suchen.

Besten Dank im Voraus.

G.Klocke

Share this post


Link to post
Share on other sites

Hallo !

Bei mir hat das Update dank XAMPP lokal funktioniert und auch der Upload war dann kein Problem.
Es war definitiv reichlich Arbeit sich dareinzufuchsen, besonders wenn das nicht das eigentliche Aufgabengebiet ist.
Meine bisherigen Anfragen bei Dienstleistern bzgl. Updates warenaber  immer so immens teuer, dass es sich für mich nicht lohnt, da ich mit dem Shop keinen zusätzlichen Gewinn mache, sondern dieser nur ein Plus für bestehende Kunden ist.

Also hat es sich für mich gelohnt.

Bei HE ist man ja auch gekniffen, weil der ioncubeloader nicht aktuell bei der PHP-Version war die man für das Update benötigt. 
Jetzt kam vor ein paar Tagen auch noch die Ankündigung, dass PHP 7.0 zum Anfang Dezember abgeschaltet wird, so dass die 5.0 Version damit schon wieder vor dem aus stand.

Wenn ich dieses Woche etwas Zeit finde, poste ich mal meine Vorgehensweise Schritt für Schritt. Vielleicht hilft dies ja dem ein oder anderen.


Einen schönen Sonntag noch.
LG.
Gunter

PS: Leider funktioniert die SEPA-Lastrschrift nicht mehr, aber das ist ein anderer Post:

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...