Jump to content
xt:Commerce Community Forum
XT-Help

Fehler nach Update von 5.1.3 auf 5.1.4

Recommended Posts

Nachdem wir die Updates von Version 5.1.3 auf 5.1.4 und sämtliche Plugin-updates vorgenommen haben, tauchen folgende Fehler auf:

Mutation vom Artikelbestand im Admin erzeugt immer diese Fehlermeldung: 

DB-Error, check xtLogs/db_error.log
Column 'reload_st' cannot be null

Trotzdem wird die Menge dann richtig mutiert.

hier ist das logfile:

mysqli error: [1048: Column 'reload_st' cannot be null] in EXECUTE("INSERT INTO xt_products_description ( PRODUCTS_ID, LANGUAGE_CODE, RELOAD_ST, PRODUCTS_NAME, PRODUCTS_DESCRIPTION, PRODUCTS_SHORT_DESCRIPTION, PRODUCTS_KEYWORDS, PRODUCTS_URL, PRODUCTS_STORE_ID ) VALUES ( 22136, 'en', null, '', '', '', '', '', 1 )")
#0 /home/httpd/vhosts/aaa.bb/httpdocs/Shop/xtFramework/library/adodb-5.20.12/adodb.inc.php(1264): ADODB_Error_Handler(...)
#1 /home/httpd/vhosts/aaa.bb/httpdocs/Shop/xtFramework/library/adodb-5.20.12/adodb.inc.php(1228): _Execute(...)
#2 /home/httpd/vhosts/aaa.bb/httpdocs/Shop/xtFramework/library/adodb-5.20.12/adodb.inc.php(2164): Execute(...)
#3 /home/httpd/vhosts/aaa.bb/httpdocs/Shop/xtFramework/admin/classes/class.adminDB_DataSave.php(0): AutoExecute(...)
#4 /home/httpd/vhosts/aaa.bb/httpdocs/Shop/xtFramework/classes/class.product.php(1840): saveDataSet(...)
#5 /home/httpd/vhosts/aaa.bb/httpdocs/Shop/xtFramework/admin/classes/class.ExtAdminHandler.php(0): _set(...)
#6 /home/httpd/vhosts/aaa.bb/httpdocs/Shop/xtAdmin/adminHandler.php(0): saveClassData(...)

 

 

ein anderer Fehler auf Kundenseite:

über dem Auswahlfeld "Sortierung" sprachcode:  TEXT_SELECT_SORT

steht auf jeder Seite darüber "Array"

- im Quellcode ist das an dieser Stelle:

id="categorie-description" class="textstyles">Array<div

 

Hat da jemand eine Idee dazu? Danke!

 

 

Share this post


Link to post
Share on other sites

Hallo Nils

Vielen Dank für die schnelle Antwort!

Du hast recht, die Sprachtexte haben wir nicht aktualisiert - wir haben schon seit Version 4 alles auf "Du" umgeschrieben und nach jedem Update müssen wir das erneut tun.

Diesmal wollten wir uns das sparen, es ist recht aufwendig...

Wenn ich nur die neuen Sprachtexte importieren könnte, müssten wir nicht immer alles neu anpassen.

Oder wenn ich wüsste, welche Sprachtexte fehlen, dann könnte ich diese einzeln manuell erstellen.

Das wäre hilfreich. Geht das?

Sonst bleibt nix anderes übrig, als schon wieder alles anzupassen...

Hat der oben erwähnte DB-Error auch was mit den Sprachtexten zu tun?

 

 

Share this post


Link to post
Share on other sites

Hallo,

wenn Du Sprachtexte änderst, dann hast Du ein Häkchen zum setzen/entfernen (weiß ich gerade nicht), sodaß genau diese beim nächsten Update nicht aktualisiert werden. Total einfach & hilfreich... ;)

Ob das mit der DB zusammenhängt, weiß ich nicht (habe da keine Ahnung). Siehst Du aber, wenn die Sprachtexte frisch sind. Es gab aber mal eine Fehlermeldung mit dem "adodb" wegen fehlender Schreibrechte des entsprechenden Ordners.

Ansonsten geh mal in die Datenbank und gib mal bei der Tabelle xt_products_description/Indizes die Werte für reload_st durch, so sehen sie bei mir aus:

[reload_st]  [int]  [11]  [NULL] [leer] [leer] [Häkchen] [Häkchen] [leer] [leer] [leer]

Herzliche Grüße
Nils

Share this post


Link to post
Share on other sites

hallo,

auf das Probem bin ich auch schon gestossen, tritt bei neuen Shops nicht auf, nur bei Updates.

Du musst das Feld "reload_st" in der Datenbank auf "Null" ändern ( Defaultwert ! Passiert auch oft bei eigenen Feldern in der xt_products oder der xt_products_description -

das kann der xtWizard ja schliesslich nicht wissen , z.B. wenn man mal ein Feld products_description_x_html angelegt hat ...

Grüsse

P.S. Es gibt bei den Sprachtexten doch jetzt eine Checkbox "", damit sollte das Problem mit den Updates behoben sein

 

Grüsse

 

 

Share this post


Link to post
Share on other sites

OK - egal - ich hatte nur aufgrund des Beitrags in meiner DB geprüft. Es ist dort 0. Bei der Neuinstallation XTC 6 wird die Tabelle mit

CREATE TABLE `##_products_description` (
  [snip]
  `reload_st` int(11) NOT NULL DEFAULT 0,
  [snip]

angelegt.

 

Share this post


Link to post
Share on other sites

1048: Column 'reload_st' cannot be null

https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/9961568/Fehlermeldungen+MySQL+Datenbank+PHP+und+Smarty
 

On 12/28/2018 at 12:21 PM, XT-Help said:

wir haben schon seit Version 4 alles auf "Du" umgeschrieben und nach jedem Update müssen wir das erneut tun.

 

Nein, einfach "Nicht synchronisieren" bei den gewünschten Sprachtexten auswählen.

https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/917608/Sprachtexte

Share this post


Link to post
Share on other sites

Vielen Dank für die vielen Antworten und den Link im Wiki zum Fehler "reload_st" - habe in der Datenbank da auf "Null" als Standardwert gesetzt und es funktioniert.

Sprachtexte habe ich nun hoffentlich ein letztes Mal alle angepassten mit "Du" auf "nicht synchronisieren" gesetzt und dann die Sprachdateien aktualisiert.

Leider hat das nicht geholfen, um "Array" wegzubringen auf Kundenseite:

über dem Auswahlfeld "Sortierung"

steht auf jeder Seite darüber "Array"

- im Quellcode finde ich das um etwas zu präzisieren an dieser Stelle:

src="https://aaa.bb/Shop/media/images/category/info/AAA.jpg" class="img-responsive" alt="AAA" title="AAA" /></div><h1 class="text-primary">AAA</h1></div>
Array<div
class="clearfix"></div><div
class="row products-sort-pages top"><div
class="col col-md-4 products-sort"><form
name="sort_dropdown1" action="https://aaa.bb/Shop/de/categorie" method="get" >
<input

Ich weiss nicht, was da fehlt...
 

Share this post


Link to post
Share on other sites

Danke oldbear - das hat mir sehr geholfen - "Array" ist weg und neu das  "Hersteller-Dropdown" drauf.

Da wir ein leicht angepasstes template haben wurde das natürlich nicht automatisch aktualisiert.

Ich nahm aus unserem bisherigen template den für uns modifizierten Code raus und hab den im neuen "product_listing_base.html" eingefügt und dieses zu unserem neuen Standard gemacht. Es läuft nun und ich hoffe das ist die richtige Vorgehensweise.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×