Jump to content
xt:Commerce Community Forum
Beisser666

Update 5.0.0.8 auf 5.1.4

Recommended Posts

Guten Tag und vorab Entschuldigung für das Topic, was bei dem einen oder anderen aus den Ohren herauskommt.

Ja, ich habe die Topics gelesen, hänge aber dennoch fest ...
Ausgangspunkt:

Version 5.0.0.8 auf 5.1.4
php 5.6
IonCube Loader ist Version 10.3 ( with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.3.1,  )
Lizenz für bis 5.1.4 liegt vor und liegt auch schon im Lic Ordner

 

Ich gehe nach Anleitung vor:
https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/493158401/Anleitung+xt+Commerce+5.0.x+auf+5.1.x+updaten

Plugins wurden deaktiviert
Wir nutzen ein 5.0 Template von xtx, ich habe es vorsorglich auf das Standard xt_responsive umgestellt
NUR den Ordner xtWizard verschoben und und SHop aufgerufen mit /xtWizard

Auswirkung:
Keine !

Kein Fehlerhinweis, kein Install, kein Wizard-Fenster, einfach nix. Lediglich der Hinweis, ich möge bitte den xtWizard löschen.

Hinweis.JPG.de4e1e7fd2e6910c4cbdd99f88adf1cd.JPG

 

Liegt es ggf. an der https/SSL Adresse ?
Jeman deine Idee wo es haken könnte ?

Herzlichen Dank für eine Rückmeldung

Share this post


Link to post
Share on other sites

Oder mal anders gefragt, da der Wizard nicht klappt...

Neuinstallation einer 5.1.4 Version, Backup einer 5.0.08 Datenbank einspielen um dann den Wizard aufzurufen und zu sagen: Aktualisiere die Datenbank ?!?!
Ob das klappt ? Rest wäre und ist ja aktuell ; man müsste nur noch ggf. die Foto/Image-Ordner verschieben ...

Share this post


Link to post
Share on other sites

Wir habe ja die Lizenz für das Upgrade 5.1.4, also wollen wir es auch nutzen.

Mit dem Thema sind wir leider noch nicht ganz weiter bzw. sehen es nicht als Erledigt an. Wir haben uns an den Support gewandt und bekamen einen grundsätzlich goldenen Tip (herzlichen Dank dafür) - der aber eigentlich , weil es der kostenlose Support war, recht knapp ausfiel.
 

Der Tip war:
ZItat:
Sie haben irgendeine https Weiterleitung welche das aufrufen unterbindet.
Der Shop muss mit full_ssl konfiguriert sein:
https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/917676/Shop-Einstellungen
Und Sie prüfen bitte etwaige Weiterleitungen.


Der Shop steht auf FULL SSL.

2081268521_SSLShop.JPG.d5dfb2b35798075b35492f14b1e443ae.JPG

 

Wir haben auch oben bei Shop Domain und SSL Domain ohne www. gearbeitet - das bringt alles nichts

Wir haben komplett SSL oben ausgeschaltet, gelöscht - es hat nichts gebracht.

 

In der Htaccess war vorher folgendes:

RewriteCond %{HTTP_HOST} !=""
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteCond %{HTTPS}s ^on(s)|
RewriteRule ^ http%1://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/xtAdmin/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

 

Da haben wir den ersten Abschnitt, weil er uns spanisch vorkam, abgeändert in :

RewriteCond %{HTTP_HOST} ^test\.de$ [NC]
RewriteRule ^(.*)$ https://www.test.de/$1 [R=301,L]

 

Wir haben auch im Shop SSL deaktiviert und die nackte Standard-htaccess ohne irgendwelche Zusätze hochgeladen.

Der Wizard lässt sich nicht starten und es wird nach dem Start von www.test.de/xtWizard sofort auf www.test.de verwiesen und man möge den Wizard löschen.

 

Wo kann ich, bzw finde ich noch Umleitungen zu SSL oder htpps ??

Sollten wir, wir sind bei all-inkl.com, das SSL im Kasserver deaktivieren für das Update und das ganze erneut versuchen ?

Wo haben wir einen Denkfehler ?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×