Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'funktion'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 99 results

  1. Hallo Community, ich bin dabei ein Plugin zu bauen, welches den Adminbereich um eine Auflistung aller Kategorien erweitert. Es funktioniert auch schon zum größten Teil, am meisten Schwierigkeiten habe ich allerdings mit dem Suchfeld. Egal was ich hier eingebe es werden nach dem "Loading…" einfach weiterhin alle Kategorien angezeigt. Laut Handbuch muss nur der Parameter display_searchPanel auf true sein und sich die Funktion _getSearchIDs in der class befinden. Ich habe aber die Befürchtung dass diese Funktion bei mir einfach nicht aufgerufen wird. Obwohl sie genauso aussieht, wie in bereits vorhandenen Plugins. Habe ich irgendwo noch etwas übersehen? Muss vielleicht noch eine andere Einstellung vorgenommen werden? Ich bin für jeden Tipp und Hilfe dankbar.
  2. Hallo zusammen Ich bin mir nicht sicher ob ich die Funktionalität nicht verstehe, ob ein Bug vorliegt, oder ob das Modul einfach nicht dafür konzipiert wurde: Gutscheine / Kupons kann man auf gewisse Kategorien einschränken. Nun ist die Frage wie diese Einschränkung programmiert wurde. In vorliegendem Fall möchte ich Artikel nicht per Gutscheincode rabattieren wenn der Artikel einer bestimmten Kategorie zugeordnet ist. 1.) Der Artikel ist ausschließlich der ausgeschlossenen Kategorie zugeordnet = Funktioniert, der Rabatt wird nicht abgerechnet 2.) Der Artikel ist der ausgeschlossenen Kategorie zugeordnet sowie einer oder mehreren weiteren Kategorien die nicht ausgeschlossen sind = Funktioniert nicht, der Rabatt wird abgerechnet. Ist das so gewollt, oder ist das ein Bug ? Ich finde, ein Gutscheinrabatt sollte nicht eingelöst werden, sobald der Artikel auch nur einer ausgeschlossenen Kategorie zugeordnet ist, unabhängig von den weiteren Kategorien. Danke für eure Hilfe, Tom PS: Die Verwendeten Versionen sind XT:Pro 4.1.10 / Gutscheinmodul 1.4.1
  3. Hallo, ich wollt mich mal erkundigen, ob es möglich ist und wenn ja, wie es möglich ist, im System unter Einstellungen -> Cronjobs einen externen Pfad zum MySQLDumper einzurichten?
  4. Hallo zusammen, ich habe das Problem, dass wenn ich Textausgabe über den Befehl truncate auf eine bestimmte Anzahl von Ziffern begrenzen und der letzte Buchstabe ein Umlaut ist der zb. wie ein ä mit ä dargestellt wird, dann wird dort eben ein Fehler > � im Frontend angezeigt. Ich denke es liegt daran, dass nur zb: &au ausgegeben wird,und der Code für den Umlaut dadurch nicht komplett ist. Gibt es dafür eine Lösung? Danke und Grüße
  5. Ist euch schon aufgefallen, dass wenn ein Kunde bei einem Master/Slave Artikel zwischen den Größen, Farben etc. wählt er nicht mehr zurück kommt? Z.B. er wählt Farbe Rot, dann sieht er sich den Artikel in Farbe blau an. Schon ist er gefangen und kann den Zurück Button im Browser nicht mehr nutzen. Egal wie oft zurück gedrückt wird, er steckt auf Blau fest. Ich als Kunde würde dann das Fenster schließen. Das sieht schon bald mehr als EXTREM unprofessionell aus. Hat jemand eine Lösung dafür? Ps. ich nutze den Firefox 32.0.3 (aktuell).
  6. Hallo an die Community, kann mir bitte jemand sagen, wo ich in der Start Version 4.1.10 die "ab" Funktion für Preise finde. Vielen Dank im Voraus.
  7. Hallo, wenn man z.B. 2 Seiten Produktbilder hat und neue Bilder hinzufügt oder austauschen möchte, so werden die ganz am Ende der Liste angefügt. Wünschenswert wäre hier noch ein zusätzlicher Knopf für "ganz nach oben/unten" - jetzt muß man sich leider erst durch alle Positionen klicken, bis ein Bild an der richtigen Stelle erscheint... kostet Zeit. Ein Inlineedditing für die Reihenfolge wäre natürlich einfacher. Leider funktioniert auch der "Pfeil nach unten"-Trick nicht, sodaß das letzte Bild dann nach oben springt. Herzliche Grüße Nils
  8. Hallo zusammen, xtC sendet ja meines Wissens immer sowohl eine html als auch eine TXT-Mail heraus. Nun möchte ich auch die richtige Funktion der TXT-Mails testen. Aber wenn ich in meinem Outlook-Mailclient das Sicherheitscenter anweise, eingehende Nachrichten im NUR-TEXT-Format darzustellen, dann erkenne ich, dass es lediglich aus der eingehenden HTML-Mail die entsprechenden Tags entfernt hat. Das sieht bloß furchtbar aus, aber damit habe ich die echte TXT-Mail aus xtC immer noch nicht getestet. Gibt es irgendwo einen Schalter, der xtC zwingt, nur TXT-Mails zu versenden? Oder kann man wenigstens bei einem Testkunden irgendwo NUR-TXT einstellen? (Im Registrierungsformular findet sich ja kein Schalter). Es gibt ja Shopsysteme, da kann der Kunde wählen, ob er HTML- oder Text-Mails erhält. Wie lässt sich das Test-Problem lösen? Einfach "blind" darauf verlassen, dass es schon richtig wird, ist jedenfalls nicht die geeignete Lösung. Gruß, forensis
  9. Hallo Communitiy, ich habe einen 4.0.16-Version auf die 4.1 upgedatet. Alles lief gut, nur PayPal funktioniert nicht mehr. Ich habe die neue Version 2.11 und 2.14 ausprobiert..Bei beiden wird bei der Kasse das "normal" PayPal-Checkout angezeigt, aber von Express fehlt leider jede Spur.. Wenn ich dann mit dem "normalen" PayPal zahlen möchte kommt diese Meldung: Diese Zahlungsweise steht derzeit wegen technischen Problemen nicht zur Verfügung, bitte kontaktieren Sie unseren Support. Die API-Daten sind natürlich eingetragen.... Hat ja jemand eine Idee ? vg, Torsten
  10. Hallo Forengemeinde, ich habe folgendes Problem mit dem Standard xt-Grid Template, ich möchte in der "Suchen" Schalftfläche den Title "Suchen" entfernen. Original <input type="submit" value="Suchen" title="Suchen"> [/HTML] sollte so in der Richtung aussehen [HTML]<input type="submit" value="Suchen" title="">[/HTML] hinterlegt ist das ganze in der "box_search.html" mit der Zeile [HTML]{css_button text=$smarty.const.BUTTON_SEARCH type='form'}[/HTML] und jetzt komme ich nicht mehr weiter, da der Baustein BUTTON_SEARCH ja nur die Spracheinstellung (Suchen/search) gespeichert hat. Ich bin für jeden wink mit dem Zaunpfahl dankbar, lg. Heinz
  11. Guten Tag, ich habe mir gestern die Kostenlose Shop Software hochgeladen. Die Installation hat funktioniert. Aber das wars auch schon. Egal was man anklickt kommt : Nicht gefunden Das Dashboard läd und läd aber nichts passiert. Ich habe schon ein paar Sachen versucht wie die Bugfixes für den Adminbereich, mit http:// und ohne so wie mit www und ohne nichts geht. Bei den Links hab ich versucht auf ein Unterverzeichniss umzulenken. Das geht auch nicht. Was mir aber aufgefallen ist das die Links alle über ein Ordner wollen www.domain.de/de/.... den es nicht gibt. Woher kommt dieses /de/? Kann mir jemand Helfen das Internet gibt nichts her MfG
  12. Hallo liebe Community ! Suche schon seit einiger Zeit mit der SuFu nach einer erklärung bzw. Lösung, aber ohne Erfolg. Ich habe unter "Kundengruppen" die 3 Standartgruppen mit Gast, Kunden, Händler. Wenn ich meine Benutzer auf Kunden stelle, werden keine Preise angezeigt, bei der änderung von Parameter unter Gast kann ich die Preise sichtbar machen. Irgendwie weiß ich nun nicht mehr weiter und habe auch keinen Lösungsansatz gefunden. Version: 4.1.00 Beste Grüße Christian
  13. Hallo, Ich habe ein paar Schwierigkeiten mit der Konfiguration der Email-Option und würde gern wissen, wie ihr mal es hinbekommen habt und zwar ich bekomme keine Emails raus aus der Application nachdem ich die korrekte (zuvor mit Thunderbird getestet) Zugangsdaten, Benutzername und smtp Servername eingetippt habe. ich habe versucht das password wiederherzustellen mit der Option "password vergessen" aber ich bekomme keine Emails weder bei der Nutzung dieser Option noch nach einer Bestellung noch bei einer Neuanmeldung. Gibt es ein Logfile, ein ErrorFile oder ähnliches ? Meine Einstellungen sind folgende : eMail Transport Methode - smtp Adresse des SMTP Servers - smtp.meineDomain.de SMTP Port - 25 SMTP Username - bestellung@meineDomain.de SMTP Passwort - XXXXXXXXX SMTP AUTH - true (mit der Option false - hat es auch nicht funktioniert !) usw.... (wie bereits gesagt es wurde alles richtig eingestellt und sicherheitshalber mit thunderbird ausprobiert) Ich hoffe, ihr könntet mir schnell helfen,damit ich dieses Shop sobald wie möglich nutzen kann. Vielen Dank im Voraus.
  14. Hallo, ich weiß nicht, ob ich einen Denkfehler habe oder nicht... Zum Problem: Zu Testzwecken habe ich das xt_grid - Template kopiert und dem Ordner einen neuen Namen gegeben (xt_grid_test). Der Kundengruppe GAST habe ich das neu erstellte xt_grid_test zugeordnet. Dieses funktioniert auch. Aber nun der eigentliche Fehler: Klicke ich den Link "Zur mobilen Version wechseln" an, zeigt zwar der Link in der Browserleiste "mobile=true" an, aber es wird weiterhin das xt_grid_test benutzt. Der "Fehler" existiert auch bei direktem Aufruf mittels Smartphone mit entsprechender Einstellung. Mit dem normalem Template xt_grid wird beim Klick auf den Link korrekt umgeschaltet. Wo liegt der Fehler? Gruß Alex.
  15. Hallo, im shop werden die Artikel in einer Kategorie Zeilenweise angezeigt und im Template ist der "Jetzt kaufen" button mit $module_data.BUTTON_BUY_NOW hinterlegt. Dieser Button hat zwei Funktionen. Bei einem minimalen Artikel wird der Artikel einmal in den Warenkorb gelegt und man kommt in den Warenkorb. Wenn der Atrikel jedoch mehrer Optionen (Farbe, Größe....) hat, dann kommt man auf den Artikel selbst und nichts wird in den Warenkorb gelegt. Ich würde das gerne so anpassen, dass immer der zweite Fall in Kraft tritt, sprich, dass man immer bei einem Klick auf "Jetzt kaufen" auf den Atrikel kommt auch wenn der Atrikel keine weitere Auswahlmöglichkeiten bietet. Ich habe schon alle template Dateien noch $module_data.BUTTON_BUY_NOW durchsucht, jedoch kein IF gefunden wo sowas stehen könnte. DANKE schonmal =)
  16. Hi @ all, gibt es eine simple Möglichkeit um beim Plugin xt_coupon den eingegebenen Coupon zu löschen und den eingegebenen Coupon im Warenkorb anzeigen zu lassen? Danke für Rückmeldungen
  17. Hallo, es wäre super, wenn man z.B. beim Crossselling eine "alles Auswählen" Funktion hätte und somit nich alle Artikel einzeln anklicken muss. MfG. Hansen
  18. Hallo, ich möchte einen Teil meiner Kunden exportieren. Aber nicht alle sondern nur welche, die ich vorher ausgewählt habe. Dazu brauche ich einen Exportieren-Button im Backend bei der Kundenübersicht. (Habe schon ein Plug-In geschrieben, welches mir dann die Kunden nochmals anzeigt. (Man soll ja nicht im Code herumprogrammieren, sonst gibts beim Update böse Überraschungen.)) Eine Export-Funktion für Kunden gibt es ja leider nicht (Nur Produkte & Bestellungen). Oder habe ich vielleicht etwas übersehen? Hat jemand eine Lösung oder Idee, wie man einen zusätzlichen Button im Backend (natürlich mit Funktion) einbauen kann? Vielen Dank. Gruß, newby5
  19. Hi, ich weiss nicht was passiert ist, ich kann Hersteller hinzufügen, wegnehmen, deaktivieren oder aktivieren... es ändert sich nichts im Frontend. Hat das schonmal jemand gehabt? Ich weiss nicht wo ich suchen soll gerade^^ Gruß 13
  20. Hallo Leute, mein hoster hat ein Serverupdate gemacht und nun läuft php5. Zuerst war der Shop gar nicht mehr erreichbar, dann hat mein hoster bisschen gebastelt und nun ist der Shop solala wieder zu sehen...davor stehen diese Fehlermeldungen: Deprecated: Function eregi() is deprecated in /is/htdocs/wp1028041_QM2RP5V4VA/koe/xtcommerce/includes/classes/language.php on line 96 Das Problem aber: Ich kann mich nicht mehr als Admin einloggen...dann kommt diese Fehlermeldung: Deprecated: Function session_is_registered() is deprecated in /is/htdocs/wp1028041_QM2RP5V4VA/koe/xtcommerce/includes/functions/sessions.php on line 88 Deprecated: Function eregi_replace() is deprecated in /is/htdocs/wp1028041_QM2RP5V4VA/koe/xtcommerce/inc/xtc_redirect.inc.php on line 29 Warning: Cannot modify header information - headers already sent by (output started at /is/htdocs/wp1028041_QM2RP5V4VA/koe/xtcommerce/includes/classes/language.php:96) in /is/htdocs/wp1028041_QM2RP5V4VA/koe/xtcommerce/inc/xtc_redirect.inc.php on line 29 Jetzt überlege ich ob ich nicht direkt die Version 4 aufspielen soll. Frage ist nur, ob ich alle Artikel und Kundendaten importiert bekommen vom alten 3.04 auf den neuen 4er. Hat das einer schon gemacht? Grüße MArkus
  21. Hallo, gibt es eine Überarbeitung der Funktion "Neues Passwort anfordern" für Veyton Merchant 4.0.13 ? 1. Würde ich gerne die 1. Email "Passwortanfrage bestätigen" ganz weglassen und gleich das neue Passwort schicken. Gibt es dafür eine einfach Lösung? 2. wo liegen die Email-Templates/Vorlagen für diese Funktion, so dass ich einen Shop-Link in die Email "Passwort wurde geändert" einfügen kann? 3. Dauert es ewig, bis die Emails "Passwortanfrage bestätigen" und dann "Ihr Passwort wurde geändert" ankommen. Liegt das an meinem Provider oder an Veyton, dass es so lange dauert? 4. Schön wäre es, wenn der Kunde einfach einen Link geschickt bekommt, wo er gleich sein gewünschtes Passwort eingeben kann, ohne von XT-commerce ein Passwort geschickt zu bekommen. Hat das schon jemand realisiert? Herzliche Grüße, Sandra
  22. Hallo wäre es nicht möglich einen Button Cache löschen in den Adminbereich einzubauen? Ich habe derzeit eine Lösung über ein php Script, das ich über einen extra Adminbereich aufrufe um den Cache zu löschen. Allerdings wäre es schöner (wie bei TYPO3) den cache direkt aus dem xtAdmin Bereich zu löschen. Wäre dies über ein Plugin zu realisieren? Wo bekommt man Infos zur Plugin Entwicklung?
  23. Hallo Zusammen, seit kurzem komme ich nach der Anmeldung über den Button "Administration" nicht mehr in den Adminbereich. (An dem Shop wurde in den letzten Wochen nichts verändert) Wenn ich über offene Bestellungen, in Bearbeitung usw. klicke, dann komme ich in den Adminbereich. Der Button ruft ja die admin/start.php datei auf. Habe die mal per FTP angeschaut, aber letztes Änderungsdatum ist 2008. Somit hat die auch niemand "manipuliert". ADMIN Ordner hat 755 Rechte und die Start.php auch... Folgende Fehlermeldung erhalte ich, wenn nach längerem Warten auf den Button klicke und dann NICHT der Adminbereich erscheint: PS: Das Problem habe ich bei 2 weiteren Shops... Bin für jeden Tip dankbar! Gruß
  24. Hallo Leute, nach nun doch einiger Zeit an Veyton-Templateerstellung und Administration - Einarbeitungszeit klappt es mehr als zufriedenstellend gut Nun stehe ich aber vor einem großen Fragezeichen: Ich meine in einem Veyton Shop gesehen zu haben, dass es eine Funktion gibt um 2 Artikel miteinander zu verknüpfen. Gemeint ist es so, dass wenn ein Artikel angezeigt wird ein passendes(vorher damit verknüpftes) Zubehörteil dazu angeboten wird. Ich habe weder in der Doku noch im Backend etwas diesbezüglich entdeckt.... Gibt es dafür eine Standardlösung oder brauche ich dafür ein Plugin?
  25. Hallo zusammen, ich versuche im Backendbereich einen weiteren Button/Funktion einzufügen. Um konkret zu werden soll in der 'Kunden bearbeiten' Ansicht ein weiterer Button erscheinen, der eine E-Mail versendet. Ich habe mich jetzt durch diverse Dateien gekämpft, allerdings nichts passendes gefunden. Danke.
×
×
  • Create New...