Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'lokal'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 44 results

  1. Hallo, ich arbeite lokal mit xampp xtc4.2 RapidPHP und xdebug. Single PHP-Files lassen sich ohne Probleme debuggen. Beim Shop stellt sich mir jedoch zu allererst die Frage mit welcher Datei muss ich das debuggen starten, schätze main.php aus dem xtCore Verzeichnis?! Wenn ich das versuche erhalte ich folgende Fehlermeldung. (Domain in Licensefile is not Matching the installed Domain, please contact helpdesk@xt-commerce.com) Die URL sieht dabei folgendermaßen aus: http://localhost:89/~S/00XAMPP55190/htdocs/shop_lokal/xtCore/main.php?XDEBUG_SESSION_START=webuilder& Normal läuft die Lizenz aber lokal! was mach ich falsch? Benötige ich eine anderes Startdatei, oder lokale Entwicklerlizenz zum debuggen?
  2. Hallo, ich möchte die 4.1 gerne lokal installieren, bin aber nach einigen Versuchen mit xampp & ioncube gescheietert.. Wieche Versionen der beiden Programme passen dann am besten für die 4.1 ? Und da ich dann auch einige Tempaltes ändern müsste, würde ich gerne das ganze als Multishop mit mehreren Mandanten anlegen.. Geht das überhaupt ? und wenn ja, wie ? Ich hoffe auf Eure Hilfe ! vlg, Torsten
  3. Hallo XT:C Freunde Bis Dato habe ich leider trotz Sf nichts brauchbares gefunden. https://xtcommerce.atlassian.net/wiki/pages/viewpage.action?pageId=917710 Ich bin zum Teil nach der obigen Anleitung vor gegangen. Habe auf C: einen Ordner XAMPP angelegt, dann das xampp installiert, das Panel gestartet und im Browser localhost aufgerufen. Im Ordner htdocs habe ich die Shopsoftware abgelegt und einen Ordner Ioncube angelegt und darin wiederum die Dateien „ioncube_loader_win_5.4.dll“ und „loader-wizard.php“ abgelegt. Mit dem Aufruf localhost im Browser kam dann ein Test und dann die Loader Installation. Bis hierhin hat alles gepasst. Zum Teil hat die Installation von ioncube auch geklappt und zum Teil kamen solche Meldungen „ Notice: Array to string conversion in C:\xampp\htdocs\xtInstaller\functions\ioncube_wizzard.php on line 518“ und am Ende „IonCube konnte nicht erfolgreich installiert werden!“ Bei Veyton 4.0.13 hat es eine tolle Installationsanleitung gegeben, für 4.1. leider nicht. Villeicht könnt ihr mir helfen. Bin ja sicher nicht der Einzige mit diesem Problem. Wäre dankbar wenn mir wer eine Step by Step Anleitung geben könnte. SG Bernd
  4. Hi, ich bin schon am verzweifeln. Habe versucht mit der Anleitung https://xtcommerce.atlassian.net/wiki/pages/viewpage.action?pageId=917710 klarzukommen. Aber es geht einfach nicht los. Frage: wo bekomme ich die xampp php5.4 Version her und wie heiß sie?
  5. Hi, um nötige Updates durchzuführen, benötige ich unseren seit 2Jahren online laufenden Shop lokal gespiegelt. Ich bekomme ihn lokal nicht zum Laufen. Ursprünglich lokal am PC entwickelt, jetzt lokal am Mac erwünscht. Hier im Forum lief schonmal dieser Thread dazu Im Frontend fehlen die Produktilder und entscheidend: Sobald ich auf einen Link klicke (egal ob Kategorien oder Contentseiten), die Seite kann nicht gefunden werden. Im Backend bekomme ich z.B. unter Mandanten "Mein Shop" nicht geöffnet. Der Inhalt bleibt einfach leer. Der Titel des Shops lautet plötzlich wieder Liviana, was nicht sein darf. Ursprünglich, für die Anmeldung des Shops, hieß die Domain www.liviana.de. Das alles wurde auf einen ganz anderen Shopnamen geändert. Es geht um diesen Shop, den ich spiegeln möchte. Ich kann mich erinnern, als ich den Shop online gestellt habe, wurden viele Anpassungen vorgenommen (per htaccess, Integration von SSL comodo secure, etc..., Domainnamenänderung) habe ich mir noch gedacht, Oh Mann, lokal kriege ich das nie wieder hin. Liegt es vielleicht am Lizenzfile? Doch ich benötige ihn jetzt lokal und weiss nicht wo noch versteckte Änderungen zu finden sind. Nun benötige ich wohl echt Hilfe von einem echten xt-commerce Freak. Irgendwo sind fixe Links integriert die ich nicht finden kann. Ich habe schon in der display.php die comodo-Secure-Links auskommentiert, leider ohne Veränderung. Die .htaccess habe ich auch komplett geleert, keine Veränderung. Wer kann mir weiterhelfen? Es geht um die Shopversion xt-Veyton Merchant 4013 Tausend Dank, Sandra
  6. Hallo liebe Gemeinde, ich wolle gerne xt:c 4.0.14 zur Testzwecken lokal mit xampp laufen lassen. Installation: Windows 7 - 64 + Xampp-win32-1.8.1-VC9 + PHP/5.4.7 + Veyton 4.0.14 Merchant - „LoadModule rewrite_module modules/mod_rewrite.so“ ist in der httpd.conf ohne # gesetzt - ioncube ist laut „Wizard Script„ korrekt installiert. - „magic_quotes_gpc = Off“ ist nicht aktiv, da nicht mehr von PHP unterstützt. Folgende Fehler treten auf: Nur die index.php wird ausgespuckt, die anderen Seiten (Links) nicht. Admin funktioniert überhaupt nicht. Wenn ich eine .htaccess mit dem Inhalt DirectoryIndex index.php RewriteEngine on RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php [/PHP] erstelle, funktioniert der Shop und man kann sich im Admin anmelden, aber im Admin Bereich bleiben die Menüpunkte leer. In diesem Zusammenhang hatte ich herausgefunden das der Server wohl „set_include_path()“ unterstützen muss. Da ich es lokal mit xampp betreibe, könnte man das schon fast ausschließen. Jedoch bekomme ich mit einem php test script, welcher den „include_path“ auf Funktion testen soll, die Antwort „boolean “, was soviel bedeuten soll das der „include path“ nicht geladen wird. In der PHPInfo sehe ich aber, dass der „include path“ in der .;C:\xampp\php\PEAR geladen wird. Es werden übrigens in beiden oben genanten Fällen, im Shop und Admin, folgende Fehlermeldungen ausgegeben. [PHP] Strict Standards: Resource ID#34 used as offset, casting to integer (34) in*******C:\xampp\htdocs\shop1\xtFramework\library\adodb\drivers\adodb-mysql.inc.php*******on line*******487 Strict Standards: Declaration of MediaFiles::_get() should be compatible with MediaFileTypes::_get($ID = 0) in*******C:\xampp\htdocs\shop1\xtFramework\classes\class.MediaFiles.php*******on line*******233 Strict Standards: Only variables should be assigned by reference in*******C:\xampp\htdocs\shop1\xtFramework\library\phpxml\xml.php*******on line*******70 [/PHP] Ich wäre über jede Hilfe Dankbar. Liebe Grüße Claudia
  7. Ich habe Veyton 4014 CE zuerst lokal installiert und einige Testdaten eingegeben. Dann habe ich Veyton 4014 CE auf meinem Strato PowerWeb Webspace installiert und die lokal erzeugte Datenbank mit mysqldumper zu Strato übertragen. Hat soweit alles geklappt, bis auf ein Problem: der Adminbereich xtAdmin erscheint auf dem Server merkwürdig blass, vieles kann man dadurch nicht sehen bzw. lesen. Fehlende Funktionen habe ich noch nicht festgestellt, weder im Shop selbst noch bei der Administration, aber es stört halt doch. Hat jemand ein Idee, woran das liegen könnte? Vielen Dank im Voraus Wallice Hallo, hier noch eine Präzisierung des Problems, das leider immer noch besteht: Es fehlt die graue Hintergrundfarbe in den meisten Schaltfeldern. Dadurch tragen die Felder weisse Schrift auf weissem Grund, also nichts sichtbares. Ich habe schon das xtAdmin Verzeichnis gelöscht und neu geladen, ohne Ergebnis. Hat wirklich niemand eine Idee? MfG Wallice
  8. Hallo, ich versuche grade lokal die 4013 zum laufen zu bekommen. Der aufruf von localhost/xtinstaller/index.php funktioniert leider nicht. So wie es aussieht werde ich umgeleitet auf xtInstaller/setup/index.php dann erhalte ich aber nur noch einen 404. ionCube ist Installiert. / Lizenz ist auch vorhanden Was läuft hier falsch?
  9. Willkommen bei meinem "Wie installier ich Veyton auf meinem Rechner im Büro oder zu Hause"(localhost) Tutorial. Als Basis benutze ich ein WindowsXP sollte aber bei Vista und Win7 ähnlich ablaufen. Jede Veyton Lizenz ist auch frei für den "localhost". Das ist für eine lokale Installation gedacht, nicht für einen Live Server! Resourcen beschaffen: Veyton aktuelle Version 4.0.12 Quelle: xt:Commerce Shopsoftware VEYTON 4.0 xampp von den Apachfriends Version 1.7.1 Download XAMPP from SourceForge.net Die Projektseite von ApacheFriends ist immer ein Besuch wert! apache friends - very easy apache, mysql, php and perl installation without hassles IonCubeLoaderDatei:" ioncube_loader_win_5.2.dll " ich darf die nicht mit anbieten einfach mal hier im Forum gucken! Texteditor (Notepad ist gut dafür) FTP Client filezilla zum Beispiel. (Für Aufgaben nach der Installation) So nun klicken wir auf den Xampp-Installer. Es empfiehlt sich in ein Laufwerk zu installieren ohne zusätzliches Unterverzeichniss, also so c:\xampp oder auch f:\xampp aber bitte nicht "f:\home\veyton\apache\test\veyton\xampp". Bei der Abfrage wo steht DIENSTE! klicken wir die "nicht" an! Desktop und Startmenü ist wiederum OK! Danach wird gefragt ob das Control Panel gestartet werden soll, das macht Sinn, also ja machen wir. Nun sehen wir das ControlPanel: Apache MySQL Filezilla Mercury ist ein Mailserver, den brauch wir nicht, sollte auch ausgegraut sein. Also los Apache "Start", dann MySQL "Start" und Filezilla "Start" HA! Filezilla must run as Service Wir machen einen Haken bei SVC links von Filezilla, ich würde bei der Frage Autostart "no" nehmen, man braucht Ihn ja nicht immer. Dann können wir diesen Service starten. Jetzt sollte bei allen 3 Modulen "running" stehen. Das ist die Chance zu gucken ob es funktionert, man öffne seinen Browser und gibt in die Browseradresszeile: localhost ein. Wenn ein XAMPP Bildschirm mit Länderauswahl kommt hat alles geklappt! Wenn nicht, alles nochmal löschen und von vorne beginnen. Ok alles scheint zu funktionieren, jetzt müssen wir ein wenig arbeiten um die xampp installation für Veyton fit zu machen. Als erstes gehen wir wieder in das xampp control panel. Rechts von MySQL ist der Button "Admin" da klicken wir einfach mal drauf. Es öffnet sich im Browser phpMyAdmin, genau hier erstellen wir die Datenbank für Veyton. Erstmal klicken wir in der oberen Leiste auf "Rechte" dann auf "Neuen Benutzer hinzufügen" Bei Benutzername tragen wir ein "Veyton" <<.. ohne die " Bei der Hostauswahl wählen wir lokal, das Feld daneben wird automatisch mit localhost gefüllt. bei Passwort nehmen wir mal "123LALA123" Ihr könnt/solltet ein eigenes Passwort verwenden. Bei Datenbank für Benutzer klicken wir auf "Erstelle eine Datenbank mit gleichem Namen und gewähre alle Rechte" Alles nochmal angucken und dann unten Rechts auf OK. Dort sollte dann ein grüner Haken sein und es sollte dort stehen: "Der Benutzer wurde hinzugefügt." Ok das wars da erstmal, also raus da, oder einfach Fenster schliessen. Jetzt gehen wir wieder zu unserem Control Panel und klicken bei Filezilla auf "Admin" Wir wollen dort das Verzeichnis /htdocs für den FTP fit machen, damit wir später Rechte ändern können. Es kommt eine Abfrage.... einfach auf OK drücken. Im FTP server Fenster klicken wir auf "edit"-->"users" dann auf "sharedFolders" da sieht man ein großes H mit einem Pfad dahinter. Dann sind wir da richtig Wirklicken darunter auf "Add" und wählen unser Installationsverzeichniss von xampp/htdocs aus sollte dann so aussehen f:\xampp\htdocs <<-- genau das markieren wir einmal wenn es das nicht schon ist und klicken auf "Set as home dir" zusätzlich klicken wir alle Buttons an: Write delete read da drunter create delete List +subdirs. Alles nochmal angucken und OK drücken. Jetzt können wir das Fenster von Filezilla schliessen. Wir gehen einmal in das Verzeichnis xampp/htdocs/ Einfach über den Arbeitsplatz wo wir das xampp installiert haben. Dort finden wir eine index.php und eine index.html? Gut dann sind wir da richtig. Dort erstellen wir einen Ordner "Backup" nun verschieben wir alles aus dem Ordner xampp/htdocs/ in den Ordner Backup. Jetzt holen wir und das Veytonfile und entpacken alles in den xampp/htdocs/ Ordner. Jetzt muss wieder eine index.php vorhanden sein! OK jetzt probieren wir es mal. Wir starten den Browser in geben wieder localhost ein. Jetzt solltet Ihr eine Fehlermeldung bekommen und zwar: Site error: the file F:\xampp\htdocs\index.php requires the ionCube PHP Loader ioncube_loader_win_5.2.dll to be installed by the site administrator. AHA! Veyton braucht eine ioncube_loader_win_5.2.dll, soll es haben. Wir machen im Ordner XAMPP einen Ordner Ioncube und kopieren die ioncube_loader_win_5.2.dll in diese Verzeichniss. Nun müssen wir dem Server noch sagen wo er diese DLL finden kann und das er sie laden soll. Dafür gehen wir in den Ordner xampp/php/ und machen mit notepad die Date PHP.INI auf. Dort suchen wir nach diesem Eintrag: [Zend] genau da drunter schreiben wir unsern Pfad rein: zend_extension_ts = "f:\xampp\ioncube\ioncube_loader_win_5.2.dll" ;Pfad ggfs. anpassen Dann die Datei speichern! Nun im Control Panel den Apache einmal stoppen bis 3 zählen und wieder starten. So wieder in den Browser und wieder localhost eingeben. AHA AHA! wieder ein "Fehler": The encoded file F:\xampp\htdocs\index.php requires a license file lic/license.txt. Den license file habt Ihr normalwerweise per Mail bekommen. Wir gehen in den Ordner htdocs/lic/ und genau hier kommt die license.txt rein also rein damit! wie im Browser localhost oder einfach mal F5 drücken wenn da noch der Fehler steht mit der license. TADA! Jetzt solltet ihr diese Fenster sehen: "Willkommen bei xt:Commerce VEYTON 4.0" Unten gucken wir mal ob alles "grün" ist und weiter gehts! dafür klicken wir auf "weiter" Einmal die Bedingungen akzeptieren. Nun kommt ein Fenster wo man für die Datenbank Angaben machen muss, die wir ja schon erstellt haben. Datenbankserver: localhost Benutzername: Veyton Passwort: 123LALA123 // oder euer gewähltes Passwort Datenbank:Veyton Prefix:xt <<--- so lassen Demodaten: mal mitnehmen ist ja nie wech Mail auch was rein ist aber nicht so wichtig, evtl. lala@lala.de Alles nochmal angucken und auf weiter, jetzt dauert es ein wenig.... dann kommt xt:Commerce VEYTON 4.0 Enterprise wurde erfolgreich installiert! hoffentlich... Da wird auch angezeigt Benutzername und Passwort für den Adminbereich, sollte man sich mal eben aufschreiben. Erstmal gucken wir nun ob das Backend geht: Also "zum Backend"... Wir loggen uns ein mit admin und dem passenden Passwort, was wir ja vorher aufgeschrieben haben. Wenn alles geklappt hat sieht man nun das Adminpanel von Veyton. Wir machen einen neues Broserfenster auf und geben wieder ein localhost wird auch hier der neue Veyton Shop geladen hast du es geschafft und hast Veyton installiert. Ich hoffe ich konnte helfen. Den Rest macht das Handbuch! Viel Glück beim reich werden. Das ist für eine lokale Installation gedacht, nicht für einen Live Server! PS: Ich werde das noch hübsch mit Bilder machen, aber heute nicht mehr. Falls noch Ideen da sind immer her damit, man kann alles verbessern.
  10. Hallo, da ich gerne Tests und einige Änderungen an meinem Shop vornehmen möchte, wollte ich den Shop lokal aufsetzten. Nachdem ich die Datenbank importiert und die configure.php Dateien + index.php umgebschrieben habe kommen folgende Fehlermeldungen: Deprecated: Function ereg() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\application_top.php on line 211 Warning: session_start() [function.session-start]: open(/tmp\sess_lbpt7pcl2u6ak0bo6uo5kpu7j4, O_RDWR) failed: No such file or directory (2) in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\application_top.php on line 296 Deprecated: Function eregi() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\language.php on line 96 Deprecated: Function eregi() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\language.php on line 96 Deprecated: Function eregi() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\language.php on line 96 Deprecated: Function eregi() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\language.php on line 96 Deprecated: Function eregi() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\language.php on line 96 Deprecated: Function eregi() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\language.php on line 96 Deprecated: Function eregi() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\language.php on line 96 Deprecated: Function eregi() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\language.php on line 96 Deprecated: Function ereg() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\paypal_checkout.php on line 103 Deprecated: Function ereg() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\classes\paypal_checkout.php on line 105 Deprecated: Function session_is_registered() is deprecated in E:\XAMPP\xampp\htdocs\webseiten\shop\includes\functions\sessions.php on line 88 Warnung: XT-Commerce kann in die Konfigurationsdatei schreiben: /includes/configure.php. Das stellt ein mögliches Sicherheitsrisiko dar - bitte korrigieren Sie die Benutzerberechtigungen zu dieser Datei! Warnung: Das Verzeichnis für die Sessions existiert nicht: /tmp. Die Sessions werden nicht funktionieren bis das Verzeichnis erstellt wurde! Ich bitte um Hilfe, entweder hier oder mir einfach mailen. Vielen Dank!
  11. Hallo zusammen, mal ne kleine Frage, ich habe den Veyton 4.0.12 bereits online laufen und möchte mir nun das ganze klonen um etwas damit rum zu experimentieren. Was muss ich denn jetzt alles anpassen um das Ganze lokal zum laufen zu bringen? Reicht es wenn ich in irgendner Config die Pfade anpasse oder ist da noch mehr?
  12. Hallo, bin komplett neu hier. Wie bekomme ich die Exportdatei eines bestehenden Shops zur Datenanalyse (soll darauf basierend eine neue Importdatei erstellen) auf den lokalen Rechner? Gruß dieselross
  13. Hallo zusammen, wir haben für unseren Kunden einen Verton-Shop angelegt, der natürlich eine eigene Lizenz hat. Diese Installation befindet sich auf unserem Entwicklungsserver. Zusätzlich haben die beiden Anwendungsentwickler, die den Shop aufbauen, je eine lokale Installation mit 2 weiteren Lizenznummern. Laut unserem Admin ging das nicht anders? Wie verhält es sich nun mit den Lizenzen der PlugIns? Diese müssen ja an eine Verton-Lizenz gebunden werden. Das Problem ist aber, dass beide Entwickler lokal entwickeln müssen. Wo ist unser Fehler? Was kann man da machen? Danke und Grüße!
  14. Hallo, irgendwie steh ich gerade auf der Leitung: ich habe einen Multishop lokal unter MAMP ( Mac ) installiert. Wie kann ich die unterschiedlichen Shops vom Frontend her aufrufen - habe ja keine unterschiedlichen Domains. Grüsse
  15. Ich möchte lokal einen Shop mit 2 Mandaten ( unterschiedliche Länder) aufsetzen. Datenbank/Backend habe ich alles soweit eingerichtet, Lizenz stimmt auch. Problem: Wie spreche ich den 2.Shop an. 1.Shop: http://localhost:8888/euro/de/index.html 2. Shop ist ein Schweizer http://ch.localhost:8888/euro/de/index.html funktioniert nicht, so schlägt es aber Veyton im Backend vor.... Lösung?
  16. Hallo, ich versuche zu Testzwecken meinen Shop lokal zu installieren, um ein bisschen rumzuspielen und zu testen. macht sich am laufendem System nicht so gut. ich habe mir also via ftp meinen shop heruntergezogen. Wenn ich jetzt http://localhost/euro123/index.php eingebe erhalte ich folgende Fehlermeldung: Site error: the file C:\Websiten\euro123\index.php requires the ionCube PHP Loader ioncube_loader_win_5.2.dll to be installed by the site administrator.[/CODE] gut, ionCube heruntergeladen: PHP Encoder, protection, installer and performance tools from ionCube: Loader Download als installer, ausgeführt und irgendwo hingepackt...geht trotzdem nicht! Wo muss ich das hininstallieren? Was muss ich nich beachten?
  17. shop ist lokal installiert und geht soweit Nun möchte ich das Stylesheet anpassen. Firebug zeigt mir als Ort das hier an: http://localhost/shop1/templates/xt_default/css/stylesheet.css lokal liegt die Datei doch in \xt-commerce_4.0.14\xt-commerce_4.0.14\shop1\templates\xt_default\css richtig? Wenn ich jetzt die stylesheet.css bearbeite und abspeichere, ändert sich am Aussehen des Shops absolut nichts, was nicht verwunderlich ist, denn Firebug zeigt die stylesheet im Shop als unverändert an. Verändert ist sie laut Editor mit dem ich sie geändert habe aber. Um zu gucken, wo zum Henker er sich diese css herholt, hab ich einfach mal den Pfad von shop1 nach shop 2 umbenannt und der shop läuft trotzdem komplett weiter. Interpretiert da eine .php die Pfade um? Und was muss ich tun, damit die Änderungen der css wirksam werden? Danke schon mal für Hilfe!
  18. Hallo alle zusammen, ich habe folgendes Problem, und zwar möchte ich gerne den Shop + xt:Office lokal laufen lassen. Der Shop läuft lokal wunderbar in phpmyadmin ist alles auf localhost gestellt. Bei der Installation von xt:O gabs auch keine Probleme. Bei Angabe der Daten für den Shop stimmt was nicht so genau. Ich habe mehrere Möglichkeiten probiert. Benutzername vom Backend sowie Passwort ist kein Problem und bei SOAP-URL habe ich versucht: localhost, localhost/index.php(sowie html), localhost/, 127.0.0.1, localhost/xtadmin/. Er Synchronisiert nicht und Initial Download geht auch nicht. Denn normal müssten Kategorien / Lieferzeiten etc. ja gefüllt werden. Notwendige Einstellungen habe ich auch so übernommen wie es in der Anleitung steht. Danke schonmal
  19. Hallo, ich habe den gesamten xt:c 4 Shopinhalt via FTP vom Server runtergeladen. Wie öffne ich diesen jetzt lokal auf meinem PC? Die Shopsoftware habe ich leider nicht, da es über Strato nur online zu verwalten ist. Aber es muss doch dennoch lokal anzusehen sein .. wenn ich einzelne Datein mit Dreamweaver öffne, kommt leider nix gescheites bei raus. Danke
  20. Hallo Leute, bin sehr frisch hier angemeldet, und wurde auf XT:Commerce aufmerksam gemacht, als ich auf der suche nach einer guten shopsoftware war. Nun habe ich einen Testaccount gestarten und dass hat mein interesse sehr geweckt! Als ich verzweifelt meinen Shopbanner anlegen wollte, ist mir aufgefallen das das bei der demo version nicht funktioniert. Warum dann Testshop? Kann ich denn irgendwie XT:Commerce irgendwie auf meinem Laptop kostenlos voll ausstesten, mit meinen eigenen logos, artikel und so? Würde gerne mal schauen wie meine Idee da so funktioniert. Oder muss ich da sowas kaufen? Mit freundlichen Grüßen Efe-Abi
  21. Hi, in der index.html habe ich eine Abfrage, die je nach Ergebniss ein anderes Layout bewirken soll. Lokal funktioniert die folgende Abfrage, aber online nicht. Dann wird nur "div id: content" wirksam, egal auf welcher Seite. {if $smarty.get.page == 'index' or $smarty.server.REQUEST_URI == '/index.php' or $smarty.server.SERVER_NAME == 'meinShop.de' or $smarty.server.REQUEST_URI == '/meinShop/'} <div id="content">{elseif $smarty.get.page == 'product'}<div id="content-product"> {else}<div id="content-drin">{/if}{/if}{$content}</div></div> Weiss jemand Rat? Auf der Startseite soll "content" geladen werden, auf der Produkt-Detail-Seite soll "content-product" geladen werden und auf allen anderen Seiten "content-drin". Weiss jemand Rat? Liebe Grüße, Sandra
  22. Hallo zusammen, ich wollte lokal an Formularen und ShopDesgin entwickeln und habe dafür ein export der db erstellt und per FTP das gesamte Shop Verzeichniss vom WebServer runtergeladen. Nun habe ich Xampp installiert und die db importiert. Den Inhalt des Shopverzeichniss habe ich in htdocs unter Shop kopiert. Wenn ich nun die index.php des Shops aufrufe sehe ich nur weiß. Keine meldung, einfach nur weiß. Ich denke mal hier sind bestimmt noch ein paar Einstellungen zu machen. Aber wo? Kann mir jemand helfen? Daaaanke und LG, Dani
  23. Hallo, ich habe meine Homepage lokal gespeichert und wollte diese jetzt lokal über den Explorer öffnen. Wie geht das? In welches Verzeichnis muss ich damit ich lokal Änderungen vornehmen kann und das direkt testen? Und in welchen Verzeichnis sind die Vorlagen für die E-Mails die versendet werden? Muss dort meine AGB´s ändern. Danke für Eure Hilfe. Ciao Nico
  24. Wir haben soeben unsere lokale Installation von Veyton 4 auf unseren Server übertragen. Wir haben dafür nur eine beta-Domain eingerichtet. Jetzt bekommen wir allerdings folgende Fehlermeldungen: Fatal error: The encoded file /srv/shop/index.php requires a license file. The license file /srv/shop/lic/license.txt is not valid for this server. in Unknown on line 0 Die letzte Meldung finde ich sehr eigenartig. Es handelt sich bei der beta-Shopadresse lediglich um eine Subdomain der Hauptadresse, Was muss denn da geändert werden? Oder muss das Teil komplett neu installiert werden (ein Aufruf von /xtinstaller/ bringt die selben Meldungen)? Vielen Dank!
  25. Hallo alle zusammen, Ich muss einen Live-Shop eines Kunden lokal zum laufen bekommen. Habe mir dazu das gesamte Projekt vom Server gezogen, die Datenbank lokal installiert und in allen möglichen configurations Dateien, die ich finden konnte die Verbindungsdaten und Pfade eingerichtet. Das Frontend scheint nun vollständig zu laufen. Nur das Backend will nicht. Sobald ich in das Verzeichnis "http://localhost/projektverzeichnis/admin" springe, kommen nur noch Fehler. Derzeit kommt der Fehler: Warning: require(k:/projektverzeichnis/includes/functions/general.php) [function.require]: failed to open stream: No such file or directory in K:\projektverzeichnis\admin\includes\application_top.php on line 291 Fatal error: require() [function.require]: Failed opening required 'k:/projektverzeichnis/includes/functions/general.php' (include_path='.;\xampp\php\pear\') in K:\projektverzeichnis\admin\includes\application_top.php on line 291 Habe geschaut... die Datei ist auch nicht unter diesem Pfad zu finden. Kopiere ich sie hinein ( was ich vermutlich garnicht machen brauche ), kommt es zu einem "redeclare" Fehler: Fatal error: Cannot redeclare xtc_get_prid() (previously declared in K:\projektverzeichnis\inc\xtc_get_prid.inc.php:20) in K:\projektverzeichnis\includes\functions\general.php on line 567 ... habe die kopierte Datei gleich wieder entfernt, da ich denke, dass sie da auch nicht hin gehört und der Fehler durch etwas ganz anderes erfolgt. Ich hoffe Ihr könnt mir ein paar Tipps geben, wo ich hier was Konfigurieren muss, damit auch das Backend lokal funktioniert. Gruß Mario
×
×
  • Create New...