Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'method'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 10 results

  1. Hallo!!! Brauche dringen Hilfe. Wenn ein Kunde was kauft und den Bestellvorgang abschlie?en will, dann kommt: Error! Unable to determine connection method on a link! Known methods: NONSSL SSL Bitte bitte, was kann das denn sein? Habe ich irgendwo irgendwas verstellt? Am Anfang ging es ja...
  2. Hallo Community, nach der erfolgreichen Installation des Veyton Shop CE (4.0.14) kann ich war noch ins Backend einloggen und der Shop läuft im Frontend ohne Probleme, aber es wird kein Modul im Backend geladen. Das Backend sieht aus wie immer, aber die Ajax-Anfrage wird nie beantwortet, oder kommt leer wieder zurück. ( Einige wenige Seiten / Module laufen: System->Datenbankmonitor->Query Alle Seiten unter "Partner" ) Unter Chrome bekomme ich folgende Fehlermeldungen wenn ich die Module aufrufe (und diese per Ajax geladen werden sollten): Uncaught TypeError: Cannot call method 'getForm' of undefined adminHandler.phpPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=configuration&edit_id=1&store_id=1 200 (OK) adminHandler.php?load_section=product&pg=overviewPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=product&pg=overview undefined (undefined) adminHandler.php?load_section=manufacturer&pg=overviewPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=manufacturer&pg=overview undefined (undefined) adminHandler.phpPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=xt_reviews&plugin=xt_reviews 500 (Internal Server Error) adminHandler.php?load_section=xt_master_slave&plugin=xt_master_slavePOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=xt_master_slave&plugin=xt_master_slave undefined (undefined) adminHandler.php?load_section=order&pg=overviewPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=order&pg=overview undefined (undefined) adminHandler.php?load_section=customer&pg=overviewPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=customer&pg=overview undefined (undefined) adminHandler.php?load_section=customers_status&pg=overviewPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=customers_status&pg=overview undefined (undefined) adminHandler.php?load_section=exportPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=export undefined (undefined) adminHandler.php?load_section=xt_im_export&plugin=xt_im_exportPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=xt_im_export&plugin=xt_im_export undefined (undefined) adminHandler.php?load_section=email_manager&pg=overviewPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=email_manager&pg=overview undefined (undefined) adminHandler.php?load_section=plugin_installed&pg=overviewPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=plugin_installed&pg=overview undefined (undefined) adminHandler.php?load_section=plugin_uninstalled&pg=overviewPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=plugin_uninstalled&pg=overview undefined (undefined) adminHandler.php?load_section=stock_rulePOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=stock_rule undefined (undefined) adminHandler.php?load_section=shipping_statusPOST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=shipping_status undefined (undefined) Unter Firefox-Firebug bekomme ich (andere) Ausgaben: Bekannte Probleme mit der aktuellen Firefox Version: http://getfirebug.com/knownissues GET http://shop.myurl.de/xtAdmin/DropdownData.php?get=ext_languages&skip_empty=true&_dc=1305891710407 200 OK 1.35s firebu...rver.js (Zeile 169) <System> POST http://shop.myurl.de/xtAdmin/get-nodes.php 200 OK 629ms firebu...rver.js (Zeile 169) <System> POST http://shop.myurl.de/xtAdmin/get-nodes.php 200 OK 711ms firebu...rver.js (Zeile 169) <System> POST http://shop.myurl.de/xtAdmin/get-nodes.php 200 OK 726ms firebu...rver.js (Zeile 169) <System> POST http://shop.myurl.de/xtAdmin/get-nodes.php 200 OK 698ms firebu...rver.js (Zeile 169) <System> POST http://shop.myurl.de/xtAdmin/get-nodes.php 200 OK 656ms firebu...rver.js (Zeile 169) <System> POST http://shop.myurl.de/xtAdmin/get-nodes.php 200 OK 749ms firebu...rver.js (Zeile 169) <System> POST http://shop.myurl.de/xtAdmin/get-nodes.php 200 OK 855ms firebu...rver.js (Zeile 169) <System> GET http://shop.myurl.de/xtAdmin/adminHandler.php?_dc=1305891710896&keepalive=true 200 OK 1.22s firebu...rver.js (Zeile 169) <System> ParameterHeaderAntwortJSONCookies {"error":"ERROR404"} POST http://shop.myurl.de/xtAdmin/dashboard.php 200 OK 1.38s firebu...rver.js (Zeile 169) <System> Ext.getCmp("total-form") is undefined [Bei diesem Fehler anhalten] Ext.util.JSON=new (function(){var useH...code;Ext.decode=Ext.util.JSON.decode; ext-all.js (Zeile 23) POST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=customer&pg=overview 200 OK 279ms firebu...rver.js (Zeile 169) <System> ParameterHeaderPostAntwortXMLCookies POST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=xt_im_export&plugin=xt_im_export 200 OK 418ms firebu...rver.js (Zeile 169) <System> ParameterHeaderPostAntwortXMLCookies POST http://shop.myurl.de/xtAdmin/adminHandler.php?load_section=payment&pg=overview 200 OK 537ms firebu...rver.js (Zeile 169) <System> ParameterHeaderPostAntwortXMLCookies XML-Verarbeitungsfehler: Kein Element gefunden Adresse: moz-nullprincipal:{9a7a7e9f-c98a-4f02-96be-7ff0ed40c345} Zeile Nr. 1, Spalte 1: ^ GET http://shop.myurl.de/xtAdmin/adminHandler.php?_dc=1305891770897&keepalive=true 200 OK 281ms firebu...rver.js (Zeile 169) <System> ParameterHeaderAntwortJSONCookies {"error":"ERROR404"} Grade den 404 Error beim "keep alive" finde ich komsich. Ich habe die Vermutung, dass es irgendwie am Server liegen könnte, da die selbe Filebase und die selbe Datenbank auf einem anderen Server funktioniert. (exportiert->imortiert->xt_stores-Tabelle geändert) Ich habe bereits das memory limit erhöht und ein paar andere php_flags probiert: php_value max_execution_time 120 php_value max_input_time 120 php_value memory_limit 512M php_value register_long_arrays On php_flag register_globals off Ebenso habe ich normale Ajax-Requests mit einer Testseite auf dem Server probiert, auch diese laufen ohne Probleme. Leider bekomme ich bei dem Server kein php-error.log um zu sehen was da schief läuft. ( Auch nicht mit folgendem in der .htaccess: php_flag display_startup_errors on php_flag display_errors on php_flag html_errors on php_flag log_errors on php_flag ignore_repeated_errors off php_flag ignore_repeated_source off php_flag report_memleaks on php_flag track_errors on php_value docref_root 0 php_value docref_ext 0 php_value error_log /var/www/vhosts/myurl.de/subdomains/shop/httpdocs/PHP_errors.log und mit der Datei PHP_errors.log angelegt und beschreibbar. ) Könnte das Problem irgendwie beim ioncube_loader liegen? Vielen Dank für Eure Hilfe! Robert EDIT: Wenn man alle Fehlermeldungen einstellt, dann erscheint im BE folgender Fehler: Warning: session_start() [0function.session-start0]: Cannot send session cache limiter - headers already sent (output started at /var/www/vhosts/meineSeite/subdomains/shop/httpdocs/xtFramework/admin/main.php:40) in /var/www/vhosts/meineSeite/subdomains/shop/httpdocs/xtFramework/admin/database_handler.php on line 60 Wieso dieser Fehler auftritt, und warum schon etwas vorher gesendet wird, ist mir unklar und aufgrund der Verschlüsselung auch nicht nachvollziehbar. Es sollte allerdings nicht am Shop liegen, da dieser ja auf zwei anderen Servern tadellos funktioniert.
  3. Hallo, ich hatte mich einem anderen Thread angeschlossen dort bisher aber keine Antwort erhalten. Seit irgendwann (Zeitpunkt nicht bekannt!) kann man, wenn englisch als Sprache ausgewählt ist, nicht mehr bezahlen => nach Abschluss der Bestellung erhält man auf der Seite checkout_process.php die Fehlermeldung: Error! Unable to determine connection method on a link! Known methods: NONSSL SSL Nur Saferpay geht => wechsele ich zurück auf Deutsch geht wieder Alles ... Ich hab schon Alles versucht und komme nicht weiter - Zu Testen ist dies hier: www.bikersdiscount.de => Englisch als Sprache auswählen => ein Produkt nehmen => bezahlen wollen ... außer saferpay (??!!) geht nix ... Danke für jeden Tipp! Klausi
  4. Hi Leute! Ich hab ein riesen Problem - Ich ändere gerade für jemanden einen XT COMMERCE Web Shop mit XTC4 Template und Smarty Tags... Aus irgendeinem Grund bekommen ich auf einmal folgende Fehlermeldung: Fatal error: Call to undefined method stdClass::_get_plugin_filepath() in /var/www/web4/html/shop/includes/classes/Smarty_2.6.10/internals/core.load_plugins.php on line 57 An den Smarty Tags habe ich nichts gemacht, ich habe lediglich die Firmenanschrift in den verschiedenen Datein geändert... Hab leider kein vernünftiges Backup gemacht und muss das irgendwie wieder hinbiegen - Brauche dringend Hilfe...
  5. Hallo Leute, ich betreibe meinen XT Shop schon einige Jahre ohne größere Probleme. Nun bekomme ich Kundenanrufe daß der Bestellvorgang nicht möglich ist! Beim checkout kommt plötzlich folfgende Fehlermeldung: Unable to determine connection method on a link Ich habe mir den xt booster installieren lassen, könnte es daran liegen? Im Forum war nichts brauchbares zu finden..... http://www.sterlingserver.com/shop/ Bin völlig ratlos, über etwas Hilfe würde ich mich sehr freuen.... Viele Grüße Ritchi
  6. Hallo zusammen, Mein Shop ist kurz davor online zu gehen nur folgendes Problem habe ich noch, es taucht auf wenn man in englischer Sprache die Bestellung abschicken möchte (bestellt man "auf Deutsch" klappt alles!!): Error! Unable to determine connection method on a link! Known methods: NONSSL SSL Kann mir jemand zeitnah weiterhelfen damit ich heute nacht relaunchen kann, wäre super!
  7. Hallo Zusammen, ich habe schon überall gesucht aber nichts gefunden und hoffe nun Ihr könnt mir weiterhelfen. Wenn ich einen Artikel in eine Kategorie einfüge und dann die Seite aufrufe bekomme ich folgenden Fehler: Fatal error: Call to undefined method product::buildDataArray() in C:\Programme\xampp\htdocs\xtcommerce\templates\default\source\boxes\whats_new.php on line 64 Ich setze xampp ein und habe schon auf PHP4 und 5 geschaltet und zurück. Der Fehler ist der gleiche. Heisst das jetzt er kennst diese Methode nicht oder wie soll ich das verstehen? Hat jemand von euch einen Lösungsvorschlag.
  8. Hallo .. ... wenn ich einen artikel in den warenkorb hinzufügen will, dann bekomme ich folgenden fehler: Fatal error: Unknown(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition shoppingcart of the object you are trying to operate on was loaded _before_ the session was started in /is/htdocs/67897/www.intermezzo-werbung.de/multishop/includes/cart_actions.php on line 157 hier ist der code ... case 'add_product_creator' : if (isset ($_POST['pID']) && is_numeric($_POST['pID'])) { if((SHOP_USE == 'mall')&&(USE_SHOP_MALL=='true')){ $owner_check_query = xtc_db_query("SELECT products_owner from ".TABLE_PRODUCTS." where products_id='".(int)$_POST['pID']."'"); $owner_check = xtc_db_fetch_array($owner_check_query); $shop_query = xtc_db_query("SELECT shop_url, shop_subdomain from ".TABLE_SHOP_TO_URL." where shop_id='".$owner_check['products_owner']."'"); $shop = xtc_db_fetch_array($shop_query); if($shop['subdomain']!='true'){ $shop_link = 'http://www.'.$shop_url.''; }else{ $shop_link = 'http://'.$shop_url.''; } if((!$_SESSION['cart_owner'])||($_SESSION['cart_owner']=='')){ $_SESSION['cart_owner'] = $owner_check['products_owner']; }else{ if($_SESSION['cart_owner']!=$owner_check['products_owner']){ xtc_redirect(xtc_href_link(FILENAME_SHOPPING_CART, xtc_get_all_get_params($parameters).'&error_message=true')); } } } if ($_POST['products_qty'] > MAX_PRODUCTS_QTY) $_POST['products_qty'] = MAX_PRODUCTS_QTY; $_SESSION['cart']->add_cart((int) $_POST['pID'], $_SESSION['cart']->get_quantity(xtc_get_uprid($_POST['pID'], $_POST['id'])) + xtc_remove_non_numeric($_POST['products_qty']), $_POST['id']); } xtc_redirect(xtc_href_link($goto, xtc_get_all_get_params($parameters))); break; ich weiß es leider nich!
  9. Habe den Shop V3.0.3. auf den Server geladen, installiert (keine Probleme) und bekomme - ohne dass der Shop ?ffnet - folgende Fehlermeldung: "Fatal error: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition shoppingcart of the object you are trying to operate on was loaded _before_ the session was started in /home/xx/xx/xx/xx_shop/inc/xtc_count_cart.inc.php on line 18" Lokal lief alles einwandfrei. Hat jemand eine Idee, woran es liegen kann?
  10. hi, im forum habe ich leider nix gefunden zu dem fehler. mein problem. local alles ok. nur online geht es nicht. import l?uft ohne probleme nur der export nicht. habe ich schreibrechte falsch gesetzt? denn local gibt es ja nun keine, glaube ich zumindest *g* online ja....was meint ihr...kennt jemand den fehler? gru? arne :stupid:
×
×
  • Create New...