Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'proxy'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 17 results

  1. Hallo, was muss ich tun das die Bilder auch unter einem ssl Proxy angezeigt werden. Es ist die Version 4.1 Es läuft alles gut nur so wie im Bestellprozess der shop unter https://ssl.webpack.de/mein-shop.de läuft werden keine Bilder angezeigt. Die Links funktionieren seltsamer weise. In der datei box_payment_logo.html konnte ich das Problem mit einer festen Eingabe des Pfads ändern. Wie mach ich das aber das mir auch das PayPal Logo und das Produktbild im Bestellprozess angezeigt werden? Oder funktioniert das mit der 4.1er gar nicht? Wäre schade um die viele Zeit die wir in den shop investiert haben.
  2. Hallo hab XTC 4.0.14 und irgendwie steh ich gerade aufm schlauch habe von meinem Anbieter nun ein Proxy SSL zugang bekommen (aufch freund google usw schon belästigt) bekomm den shop aber nicht zum laufen .. sobald er auf SSL umspringt klappt gar nichts mehr könnt mal jemand schaun wo der fehler ist ? Shop Domain: FliechZeuch.com SSL Domain: ssl.ssl1.de/www.fliechzeuch.com/ Url http: FliechZeuch.com Url https: https://ssl.ssl1.de/www.fliechzeuch.com/ das ssl zeugs sollen die Proxy SSL daten sein von meinem Provider Hacken bei SSL iss drinnen probieren könnt ihr das gerne mal auf FliechZeuch.com sobald ich auf Warenkorb und/oder Kasse klick geht nichts mehr. oder hab ich irgendwo was vergessen ? XTC 4.0.14
  3. Ich bekomme kein connect von der WaWi zum Shop. Ich nehme an das dies am Proxy liegt hinter den ich sitze. Wo kann ich den Proxy konfigurieren. Aus den Systemeinstellungen wir der offenbar nicht übernommen? Desweiteren habe ich nach der Installation beim ersten Start von xt:Commerce Office folgende Fehlermeldung erhalten: Run-time error '339' Component 'RICHTX32.OCX' or one of its dependencies not correctly registered: a file is missing or invalid. Wer kann helfen?
  4. Hallo Leute, ich hoffe ihr könnt mir helfen. Ich habe nun wirklich alle Lösungsansätze versucht, die ich hier im Forum, oder in den Weiten des Webs gefunden habe. Aber ich konnte mein Problem nicht lösen, es geht um folgendes: Ich habe nachträglich in einen XTC Shop ein SSL Proxy eingefügt. Webhoster ist übrigens 1&1 (1und1). Auf der Seite klappt alles eigentlich soweit, sobald ich zur Kasse gehe erscheint die URL als https://ssl.kundenserver.de/meineDomain Wenn ich mich jedoch als Admin einlogge passierts: Jeder Link im Adminbereich, sei es zur Artikelübersicht, Bestellungen, Einstellungen - einfach jeder Link führt dazu, dass ich aus dem Adminbereich rausgeschmissen werde. Woran könnte das denn liegen? Ich hab wirklich keine Ahnung mehr wo ich ansetzen soll. LG und Danke!
  5. Hallo, ich habe nun bestimmt 30 Einträge in diesem Forum gelesen in denen Anleitungen zur Einrichtung von SSL genannt werden. Bei Einrichtung von SSL über einen eigenen Server mit eigenem Zertifikat beschränkt sich die Änderung ja auf die beiden config-Dateien im includes und admin/includes Verzeichnis. Problem ist das SSL zwar funktioniert aber bei den entsprechenden Seiten immer die Warnmeldung kommt einige Objekte seien unsicher. Es handelt sich um das Standardlayout nach einer Neuinstallation. Ich habe keine externen Links hinzugefügt. Nun läuft SSL wie gesagt mit der Warnmeldung auf den Seiten z.B Kundendaten oder Kasse. Diese lästige Warnmeldung muss nun irgendwie auch noch weg: 1. Möglichkeit Ich lasse den ganzen Shop via SSL laufen, dies habe ich bisher nur erreichen können wenn ich in den config-Dateien bei http-Server ebenfalls https://www.meindedomain.de eingebe. Dann läuft alles via SSL, das Schloss ist da und die lästige Warnmeldung weg. 2. Möglichkeit Ich suche die Seite ab und korrigiere alle Links die per http:// aufgerufen werden. Eigentlich sollte doch das mitgelieferte Template diese Fehler nicht aufweisen oder muss doch noch eine weitere Datei angepasst werden ? Die Änderungen in der Datei XTC_redirect_inc.php habe ich auch schon probiert aber bringt keine Änderung. Wie macht ihr das mit dem SSL ? Viele Grüße Basti
  6. Hallo Zusammen, ich wollte mich jetzt gerade in meinen Adminbereich einloggen und nun kommt folgende Fehlermeldung: Proxy Error The proxy server received an invalid response from an upstream server. The proxy server could not handle the request GET /pfotenliebeshop.de/admin/start.php. Reason: Error reading from remote server Habe keinerlei Änderungen vorgenommen. kurz vorher kam ich noch rein! Was ist da denn schon wieder los? Bitte, wer weiß Rat? Liebe Grüße Silke
  7. Hallo wenn ich meine seite aufrufe erscheint manchmal folgendes. Proxy Error The proxy server received an invalid response from an upstream server. The proxy server could not handle the request GET /index.php. Reason: Document contains no data wenn ich dann auf aktualisieren klicken geht es dann meistens woran kan das liegen?
  8. Hallo, ich habe erfolgreich den SSL Proxy konfiguriert. Nun habe ich folgendes Problem. Logge ich mich als Admin ein komme ich zwar auf die SSL Admin Seite, w?hle ich aber einen beliebigen Men?punkt aus gelange ich auf die Login Seite auf der http:// Seite. Das gleiche wenn sich ein Kunde anmeldet. Er kommt auf die SSL Seite, wird umgeleitet auf die http Seite und hat keine Artikel im Warenkorb mehr und mu? sich erneut anmelden (das gleiche Spiel von vorne) Wer kann mir Helfen. Dringend !!!!!!!
  9. Hallo folgende Frage wirft sich mir auf. Kann man den Shop auch ?ber ein SSL Proxy sch?tzen oder braucht man dazu unbedingt ein Zerifikat. Ich habe meines erachtens ein SSL Proxy, da mein Provider folgendes schreibt Bitte w?hlen Sie Ihre Domain(s) aus, die Sie ?ber den SSL - Proxy sch?tzen m?chten. Ihre Daten sind dann ?ber https://ssl-account.com/domain-name.de zus?tzlich SSL gesch?tzt erreichbar. Wenn man den Shop auch ?ber ein SSL Proxy sch?tzen kann, dann w?rde ich noch gerne wissen ob man da dann anders vorgehen muss als bei einem SSl Zertifikat gru? sallust
  10. Mahlzeit! Ich habe nun auch mal n Problem mitm SSL-Proxy von Hosteurope. Habe mich hier im Forum durchgew?hlt und alles M?gliche ge?ndert. Soweit scheint es auch zu laufen, nur - der IE6.0 zeigt gar kein Schloss und der Firefox ein durchgestrichenes Schloss an. Hat jemand eine Idee? Mit application_top sieht so aus: // verify the ssl_session_id if the feature is enabled $request_type = (substr($_SERVER['SCRIPT_URI'],0,5) == 'https') ? 'SSL' : 'NONSSL'; { $ssl_session_id = getenv('SSL_SESSION_ID'); if (!session_is_registered('SSL_SESSION_ID')) { $_SESSION['SESSION_SSL_ID'] = $ssl_session_id; } und wenn ich anstelle dessen diesen Eintrag nehme $request_type = ($_SERVER['HTTP_X_FORWARDED_HOST'] == 'ssl-account.com') ? 'SSL' : 'NONSSL'; bekomme ich n Parse-Error genau in der Zeile. :cry: Und ?h, welche application_top muss ich nehmen? Ich hoffe doch die in /includes und nicht die in /admin/includes. Oder? :pst: Gruss Der Frank :rock:
  11. Hallo, ich habe bei mir Proxy eingeschaltet und wenn ich mich im Admin anmelde sehe ich auch das Schloss in der Browserzeile. Wenn ich aber auf der Seite ?ber die einzelnen Kategorien gehe, sind das ganz normale HTTP Verbindungen. M?ssten das nicht auch HTTPS Verbindungen sein ? Wo kann denn der Fehler liegen ? Gru? Thomas
  12. Hallo, vor l?ngerer Zeit war hier im Forum ein Posting ?ber SSL Proxy. Dort war eine Anleitung, wie man einen XTC Shop mit einem SSL Proxy ans laufen bekommt, ohne das man eine Fehlermeldung erh?lt. Mein Provider hat so eine Anleitung auch aber nur f?r die OSC Shops. Ich wollte nun wissen ob jemand so eine Anleitung auch f?r XTC hat. Seit dem Plattencrash von XTC ist diese Anleitung leider nicht mehr vorhanden. Kann mir jemand helfen? Greetz Viper
  13. Hi, wenn der Provider und der Shopbesucher jeweils einen Proxy verwenden, dann kommt es zu eigenartigen Effekten beim Navigieren durch den Shop. Man gelangt dann manchmal pl?tzlich auf die Login-Seite, wenn man eine Kategorie ausw?hlt - auch wenn man schon eingeloggt ist. Zum Problem: In der Datei "includes/application_top.php" wird gepr?ft, ob "meinsslserver.de" in der Variable $_SERVER['HTTP_X_FORWARDED_HOST'] steht und dann das SSL bzw. NONSSL Flag gesetzt. Greift nun der Proxy des Kunden ?ber den Proxy des Provider auf den Shop zu, steht in der Variable $_SERVER['HTTP_X_FORWARDED_HOST'] nicht mehr nur "meinsslserver.de" sondern "proxydeskunden.com,meinsslserver.de". Damit schl?gt das setzen der Variable auf SSL fehl und es kommt zum komischen Verhalten des Shops. Man k?nnte nun $request_type = ($_SERVER['HTTP_X_FORWARDED_HOST'] == 'meinsslserver.de') ? 'SSL' : 'NONSSL'; durch if (preg_match("/sslsites\.de$/",$_SERVER['HTTP_X_FORWARDED_HOST'])) { $request_type = "SSL"; } else { $request_type = "NONSSL"; } ersetzen. Damit ?berpr?ft PHP ob "meinsslserver.de" als letztes in der genannten Variable vorkommt und setzt die Variable dann immer korrekt. Nun meine Frage: Ist das eine gute L?sung, oder kann ich mir damit Sicherheitsprobleme einhandeln?
  14. Hallo zusammen Nach stundemlangen Lesen von Threads und Versuchen gebe ich auf. Ich w?rde gern gegen Endgeld jemanden bitten mir ein SSL Proxy einzurichten. Ich habe z.Zt. den Shop in einem https Ordner installiert. Nur sind die Verbindungszeiten sehr lang. Zumindest kommt es mir so vor das die Ladezeiten l?nger sind wie bei einner normalen Installation. Interessant w?re nat?rlich zu wissen, ob sich das ganze ?berhaupt lohnt mit einem Proxy. Wenn jemand Lust hat m?ge er mir ein Angebot per PM machen zur Einrichtung des Proxys. Mein Hoster ist server4you. Das System ist noch jungf?ulich, abgesehen von der Shop-Installation. Gruss Ralf
  15. Hallo XTCler, mein Webspace hat kein eigenes Zertifikat sondern einen SSL-Proxy. Nun w?sste ich gern: Recht es wenn ich als ssl bei der Installation statt https://domainname.de --> https://ssl-account.com/domainname.de eingebe? Oder muss ich weitere Modifikationen vornehmen dass die SSL-Verschl?sselung l?uft?! Eine Anleitung meines Webhosters f?r osCommerce ist vorhanden: http://script-test.de/anleitungen/Shop/osc...2/sslschutz.htm Ist diese auch 1:1 auf xtCommerce ?bertargbar? Wahrscheinlich nicht oder? :grml:
  16. Gibt es eine Beschreibung oder paar Tipps. Wie richte ich nun SSL im Shop und Adminbereich ein ?ber diesen SSL-Proxy? :grml: Danke.
  17. Ich bin gerade dabei ein VB6 bzw. VF6 Programm zu schreiben mit dem ich extern die Shop -Daten pflegen kann. Nun wollte ich mal den Zugriff ?ber ODBC ausprobieren und zwar mit MyCDBC Nur schaffe ich es leider nicht den Server also den Standort des Shops einzugeben. Auch scheint der Zugriff ?ber einen Proxyserver nicht unterst?tzt zu werden. Kann mir da jemand helfen - evtl. stelle ich mich auch nur sehr doof an - lool Falls nicht werde ich ?ber OCX den Einstieg versuchen. Mit nen netten gru? aus Franken
×
×
  • Create New...