Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'urls'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 99 results

  1. Hallo, in XT-Commerce 4.2.00 gibt es im Adminbereich ja den Menüpunkt "SEO & Shop Optimierung" und dabei den Unterpunkt "SEO Urls neu generieren". Dort habe ich versucht für sämtliche Kategorien URLs zu generieren, wobei mir auch angezeigt wurde, dass alle Kategorien verarbeitet wurden. Wenn ich jedoch in xt_seo_url oder direkt in den Kategorien schaue haben diese nach wie vor keine SUMA URL. Weiss jemand woran das liegen könnte? Meine Kategorien kommen per SQL-Import in den Shop und die SUMA-URL ist das einzige was die Kategorien daran hindert im Shop angezeigt zu werden. Vielen Dank im voraus.
  2. XT-Commerce 4.2.00 Ich habe bisher meinen Shop von einer Firma bearbeiten lassen, also Update und Erweiterungen, allerdings ist das mit der Zeit sehr teuer und ab und zu würde ich auch gern selber mal etwas wissen. Ist es möglich unter SEO Optimierung die Anzeigen 404 URLs löschen / gelöschte URLs löschen komplett gesammelt zu löschen? Wenn ja wie und ist das auch sinnvoll. Es sind mittlerweile so viele. Vielleicht ist das für die Optimierung besser oder spart Speicherplatz?! Oder muss das so bleiben?
  3. Moin, wir haben das Problem, das bei den Mandanten die URL für die Produkte nicht korrekt generiert wird. Im Hauptshop funktioniert es: www.meinshophauptshop.de/Kategoriename/Produktname Bei Mandanten sieht es wie folgt aus: www.meinshopmandant/Produktname Die Kategorie wird in der URL nicht eingetragen. Kennt wer ne Lösung? Mfg
  4. How are URLs generated in xt:c? And where are they maintained, in order to guarantee consistence in search-engines (Google etc)? Where is the mapping of URL to product stored in xt:c? Can anyone help me by answering these? Thanks in advance.
  5. Hallo Leute, im Handbuch und im Forum habe ich nichts dazu gefunden, vielleicht weiß jemand von Euch weiter? Bei den Suma URLs werden bei mir die Umlaute (im Link) nicht dargestellt - ist das nur eine Einstellungssache oder so beabsichtigt? Also kein "ae" für "ä" usw., fehlt einfach im Link. Herzliche Grüße Nils
  6. Wer kann mir helfen, ween ich die Suma Url Option einschalte, funktionier alles was ich bis jetzt überprüft habe, nur nicht die Warenkorbfunktion. Wenn ich in den Warenkorb drücke wird der Artikel wohl in den Warenkorb gelegt, jedoch eine URL dann aufgerufen, die nicht gefunden wird z.B. Url Syntax: de/product&info=193.htm Die Zahl ist die Artikel ID aus dem system. Hat jemand ne Idee wo da der Fehler steckt? Achso Shopversion xt Commerce Veyton 4.1.00:confused:
  7. Kurze Frage zu XTC-3: möchte einige Kategorien umbenennen bzw. rumschieben. Meine Frage: solange die Kategorie ID gleich bleibt, ist es doch egal, was hinter dem ....c200.... steht oder? Also, wenn die Kategorie vorher gelautet hat: Reifen und dann Reifen 4x4, führen lt. Selbsttest beide URLs, die alte und die neue, in die richtige Kategorie- Bitte um kurze Rückbestätigung, da dies ja ansonsten heißen würde, wenn ich falsch läge, dass auch alle URLS zb. bei Adwords Anzeigen geändert werden müssten und dass dann natürlich keine Sinn macht.
  8. Hi, der Exportmanager erstellt mir nach langem Testen eine wirklich supertolle sitemap (XML; für Google), die Google sogar akzeptiert; leider werden aber immer nur die URLs der Produktseiten mit in die Datei geschrieben, aber zB. nicht die von Kategorien und Unterkategorien (also von div. Übersichtsseiten, auf denen wir halt auch einen gewissen Text stehen haben). Wie bekomme ich hin, dass die URLs dieser Seiten mit in die sitemap geschrieben werden? Danke, durchblick (4.0.14 CE)
  9. Hallo, Ich versuche xt:commerce auf meien webspace bei 1&1 zu installieren. Der Systemtest meldet alles ok außer "Apache - mod_rewrite (SEO Urls!)" In diversen Foren findet man muss RewriteEngine On RewriteBase / in die .htaccess einfügen. Dies hab ich in verschiedenen Varianten (neue .htaccess oder bereits vorhandene im xtcommerce hauptverzeichnis. Funktioniert beides nicht. Rotes Ausrufungszeichen bleibt bei Systemtest bestehen. Was kann ich tun? So sieht meine .htaccess aus: Sie befindet sich im hauptverzeichnis welches mit der URL verbunden ist und in der die xtcommers dateien und ordner liegen. AddType x-mapp-php6 .php AddHandler x-mapp-php6 .php # RewriteEngine on # RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php DirectoryIndex index.php <IfModule mod_rewrite.c> SetEnv HTTP_MOD_REWRITE On RewriteEngine on RewriteBase / RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php </IfModule> <IfModule mod_expires.c> ExpiresActive On ExpiresDefault "access plus 1 seconds" ExpiresByType image/x-icon "access plus 2692000 seconds" ExpiresByType image/jpeg "access plus 2692000 seconds" ExpiresByType image/png "access plus 2692000 seconds" ExpiresByType image/gif "access plus 2692000 seconds" ExpiresByType application/x-shockwave-flash "access plus 2692000 seconds" ExpiresByType text/css "access plus 2692000 seconds" ExpiresByType text/javascript "access plus 2692000 seconds" ExpiresByType application/x-javascript "access plus 2692000 seconds" </IfModule> <IfModule mod_headers.c> <FilesMatch "\\.(ico|jpe?g|png|gif|swf|css|js)$"> Header set Cache-Control "max-age=2692000, public" </FilesMatch> Header unset ETag Header unset Last-Modified </IfModule> Danke für Hilfe!!! josepe45
  10. Hi, nach der Aktivierung von SEO-URLs hängt die Software an die Links in der Navigation teilweise irgendwelche (ich denke mal ziemlich sinnfreie) Query-Strings an, also z.B.: www.domain.tld/schoener/seo/url/pfad.html?x7659f=eptjsq3177gc4jv0ctirbctac710d3 Wie bekommt man das denn weg? Ist ja eigentlich nicht im Sinne der SEO-URLs. Gruß, Uwe
  11. Hallo, ich habe einige Datensätze in die Datenbank eingefügt (via PHP) und die Produkte werden auch im Shop angezeigt. Was allerdings nicht zu funktionieren scheint, ist die automatische Generierung von Suma URLs. Wenn ich über die Kategorieansicht versuche neue zu generieren, bekomme ich zwar eine Erfolgsmeldung, aber die Datensätze bleiben unverändert. Gibt es hier eine automatische Lösung oder muss ich diese selbst programmieren? Update: Es funktioniert nur, wenn ich entsprechende Artikel anhake. Jetzt weiß ich bescheid Allerdings tut sich nun die Frage auf, ob in der seitenweise Produktauflistung eine mehrfach Auswahl möglich ist. Ich bin daran gestern schon verzweifelt, als ich Testprodukte manuell löschen musste.
  12. Hallo, mein Problem: Wenn ich im Backend "Mod Rewrite URL" auf "true" stelle passiert folgendes: Das Frontend startet beim Aufruf noch ganz normal, wenn ich über die Links mit der Maus fahre, sind die auch tatsächlich verändert worden (aus .../index.php?page=categorie&cat=3 wird .../kategorie3/...). Sobald ich aber auf einen Link klicke, kommt eine Fehlermeldung (a 500 Internal Server Error error). Stelle ich den rewrite-modus wieder auf "false" funktioniert wieder alles. Was könnte der Grund dafür sein? Was muss ich hier für eine Einstellung ändern? Ich würde mich sehr über eine Antwort freuen.
  13. Guten Tag, ich möchte bei einem Online Shop von Smartstore auf xtc umsteigen und die Urls so beibehalten. Problem ist wenn ich vorher eine Kategorie mit dem Verzeichnisnamen /kategorie/ hatte und eine Kategorie im xtc anlege wird die Url automatisch so generiert /kategorie So ist aber die alte Seite ohne / nicht erreichbar. Füge ich aber dann in der Kategorie das / ein dann passt es erst mal. Lege ich aber ein Produkt in der Kategorie an dann sieht die url komischerweise so aus /kategorie//produkt Also 2x // Wie kann ich das Problem lösen? Gruß Vital
  14. Tag zusammen, habe die Startversion vom 4.1-shop installiert und erste Kategorien und ein Produkt angelegt. Leider werden keine sprechende Urls angezeigt. Kann mir jemand sagen, wo ich sprechende Urls aktivieren kann. Die Url sehen so aus: http://test.meine-domain.de/index.php?page=product&info=3 http://test.meine-domain.de/index.php?page=categorie&cat=12 gruss hansibaer
  15. Moin verehrte Gemeinde, ein gutes neues Jahr rundrum! Auf der Jagd nach Vermeidungsmöglichhkeiten für duplicate content bin auch ich bei den Session-IDs angekommen, die mit schöner Regelmässigkeit bei Google, Yahoo etc. im Index auftauchen und so jede Seite in x-facher Ausführung in den Index bringen. Das xt_canonical-Plugin (vielen Dank dafür!!) habe ich entdeckt und installiert, die Produkteseiten sind seitdem "clean". Allerdings habe ich das Problem noch für die Startseite meines Shops und die Content- und Kategorieseiten. Kann man die Funktion des Plugins auf diese Seiten ausdehnen? Oder die gleiche Funktion durch einen anderen Trick erreichen? Müsste ja keine grosse Logik dazu, einfach nur ein Verweis auf die Stamm-URL der Seite. Die Suche hat mir zwar ein paar Treffer geliefert und auch einen Post mit "Oldbear hat's gelöst", nur leider steht die Lösung nicht dabei... würde mich über einen kleinen Tipp sehr freuen.
  16. Hallo Community, ich habe folgendes Problem mit einer frischen Installation von VEYTON 4.0.15: Ich habe die suchmaschinenfreundlichen URLs eingeschaltet, was bei Kategorien und Artikeln bisher auch wunderbar funktioniert. ABER: Im Contentbereich "Inhalte" möchte ich das auch erreichen, was aber überhaupt nicht klappt. - Im Backend werden Änderungen an den SEO URLs überhaupt nicht übernommen. Im Browser erscheinen die URLs wie folgt: Liefer- und Versandkosten: http://meine_domain.de/de/.html Datenschutz: http://meine_domain.de/de/1.html ... usw. Hat da jemand einen Rat (und vielleicht eine Lösung) für mich? Ich bin am verzweifeln!!! Achso: Meine SEO-Einstellungen habe ich mal als Bild angehängt. Vielen Dank im Voraus.... Martin
  17. Hi Leute, ich schreibe gerade ein Template für XT-Commerce Veyton 4.014 fertig, das von jmd. anders angefangen wurde. Ich würde gerne im Content - Manager SEO URLs verwenden. Ich habe da keine Möglichkeit gefunden. Ich habe mir jetzt quick & dirty beholfen, indem ich eine kleine parser funktion in content.html geschrieben habe, der es erlaubt einen Funktionsaufruf im Content Manager zu schreiben, die SEF-URls nach Id aus der DB holt und wiedergibt. Das ist aber nicht allzu sauber: Also, wie handelt Ihr das? Vielen Dank im Voraus. Ciao, Mojo
  18. Wenn ich im ACP die Option "Suchmaschinenfreundliche URLs benutzen?" auf "true" stelle funktioniert der Shop nicht mehr. Totaler Darstellungsfehler und die Meldung: Bei Bedarf kann ich ein Screen machen. Aber vieleicht ist das schon bekannt und in der Beta2 behoben. Bin neu hier und habe noch nicht alle Threads gelesen... Wollte es nur mal melden. mfg nanto
  19. Also ich bin auch ein Glücklicher. Mein Chef hat von einer Agentur sich Veyton aufschwatschen lassen, die noch nie einen SHOP aufgezogen hat. Jetzt geht natürlich nur die hälfte von dem was die wollen machen mit dem SHOP. Ich bin also der Glückliche der die Arbeit vollenden darf. Die Online Doku finde ich auch sehr mager, eine Liste der classen funktionen währe schon was. Nun ja Meine Chefin hat ohne zu zögern ja gesagt als ich fragte ob wir das Buch kaufen können. Ist also Unterwegs, ich habe also zu warten. Meine dringlichte Frage ist mir ist aufgefallen das immer absolute URL's für z.B. Bilder http://www.domain.tld/folder/picture.png Warum ist das so? Als ich vor 15 Jahren mich das erste mal mit html auseinnandergesetzt habe ich gelernt immer relative urls zu benutzen also /folder/picture.png Wie kann ich das ändern? Das Hauptproblem ist, wenn ich die 302 Umleitung am Apache auf https an mache habe ich eingebettete Bilder mit http Eleganter währe beim Absenden des Formulares. <form name="example" method="https://..."> Danach header('HTTP/1.1 302 Found'); header('Location: http://...'); Moneybroker: Der Kunde muss sich da Anmelden: schöner währe es wenn der Kunde nicht davon mitbekommen würde über wen wir Abrechnen. Was mich noch wundert es gibt doch viele, die hier selber Anpassungen vornehmen ich habe aber hier wenig Posts gesehen mit Sources. Ist doch üblich wenn man was Entwickelt es zu Posten dann können auch andere davon Profitieren wenn man sich schon die Arbeit macht. LG LEO
  20. Hi, ich hatte gestern mal einen 'Veyton-Patch-Day' der 4.0.13-Updates aus dem XTC-RSS-Feed und festgestellt, dass die Links zu den Content-Pages in der Box jetzt aus den SEO URLs + den Content-IDs bestehen, also z.B.: http://www.mein-shop.de/de/Unsere-AGB.html?coID=3 Dabei gilt folgende Einstellung im Shop: SEO-URLs für Seiten (pages): false Ist das so beabsichtigt? Gruß, Uwe
  21. Hallo liebe Community, Wir haben extreme Probleme mit Paypal und dem One Step Checkout von BUI Hinsche. Wenn die SEO URLs angeschaltet sind, leitet das Checkout in der Process page_action nicht weiter an Paypal. Sind die SEO URLs ausgeschaltet, funktioniert es. Hat einer eine Ahnung woran das liegt? Hatte jemand schonmal die selben Probleme? Leider ist der Quelltext an entsprechender Stelle verschlüsselt, weswegen es nahezu unmöglich ist, das vernünftig zu analysieren. Vielleicht ist es noch von Belangen, dass keine Übergabe von Get-Parametern bei aktiver SEO URL möglich ist, weil das System dann auf 404 weiterleitet. Wäre super, wenn das jemandem schon mal passiert ist und dafür eine Lösung parat hat. Danke, Chris
  22. Sich hat sich jemand dabei etwas gedacht oder es gut gemeint. Wie der Gedankengang aussah oder welches damit verfolgt werden sollte, würde mich jedoch sehr interessieren. Ich spreche von den Großbuchstaben, die in den Url Slugs vorkommen. Wenn es für den ein oder anderen auch schön anzusehen ist, wirkt es absolut gegen eine usability die auch bishin zu den URL´s gegeben sein sollte. Einfaches Beispiel ist: Ich aktiviere mod_rewrite, das man sich am Telefon oder bei einfachen konversationen mitteilen kann;"Such das Produkt mal bei: Jetzt ist das oben rot markierte slash de ja schon suboptimal, aber nun noch dazu sagen zu müssen: ;"Such das Produkt mal bei:" Ist nicht nur viel schwerer zu merken und vermitteln, sondern es bringt noch andere Nachteile mit sich. Ist man beim verlinken von anderen Seiten und nutzt nicht copy&paste, muss man nachsehen, wie das Produkt geschrieben wurde. Anstatt wie fast im gesamten restlichen Internet üblich alles klein zu schreiben. Sicher weiß der ein oder andere nun doch, Vorteile des bisherigen Systems zu nennen, die Nachteile glaube ich aber überwiegen irgendwie.
  23. Hi! Habe schon gegoogelt und Forum durchsucht, aber für veyton noch keine passende Lösung gefunden. Da ich gar nicht weiß, wie ich vorgehen muss, stell ich mal blöd die Frage: "Wie kann man bei veyton suchmaschinenfreundliche URLs generieren?" Bei v3.04 konnta man das doch einfach aktivieren, sofern ich mich richtig erinnere! Danke im Voraus!
  24. ..hmm ich arbeite mich ja gerade in die Materie ein, vielleicht war mein Beitrag zu überhastet eingestellt. Ich habe nochmal überlegt.. also in der jetzigen Einstellung ohne / am Ende funktioniert alles wunderbar. Gebe ich in die Adresszeile am Ende den / ein, so werde ich auf die Index Seite umgeleitet. Auch das Canonical Tag Plugin funktioniert und sagt: geh zur http://shop.de/de/index Seite. Soweit ich es verstanden habe dadurch Doublecontent vermieden, obwohl kein / am Ende ist. Es ist ja die hauptsache das der Inhalt nur einmal gewertet wird mit oder ohne / spielt keine Rolle! Oder? Hallo, ich möchte gerne erreichen das meine Urls der Kategorien und Artikel mit einem / enden. Beispiel: http://shop.de/artikel/ http://shop.de/artikel/produkt1/ Prinzipiell funktionieren die Suma-Urls bei meinem Shop. Der Eintrag der auch tatsächlich eingestellt ist lässt sich auch aufrufen. Ergänze ich meine .htaccess um: RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_URI} !(.*)/$ RewriteRule ^(.*)$ http://shop.de/$1/ [R=301,L] wird automatisch der / am Ende angehängt. Ändere ich nun über den xtAdmin den Eintrag manuell , bzw. ergänze ich den / , so lässt sich auch die Kategorie oder der Artikel aufrufen. ohne / werde ich auf die Index Seite weitergeleitet. Wenn ich nun allerdings die Suma-Urls automatisch generieren lasse so wird der / wieder entfernt. Wie ist es möglich das der / automatisch mit generiert wird? Über die Suche konnte ich keine Lösung finden. hier der Rest meiner .htaccess : DirectoryIndex index.php AddDefaultCharset utf-8 RewriteEngine on RewriteBase / RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php Gibt es dafür eine Lösung?
  25. Hallo, ich habe alle Kategorien in einem Shop mit suma-freundlichen URLs ausgestattet. Nur bei den Contents will das einfach nicht klappen. Dort bekomme ich immer so einen Link angezeigt: xxxx.de Gibt es einen bestimmten Punkt, wo das geändert werden kann? Kann man das überhaupt ändern?? Ich würde mich freuen, wenn ihr weiterhelfen könntet. Gruss und Danke Kiki
×
×
  • Create New...