Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'windows'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 30 results

  1. Hi zusammen, ich habe hier ein Problem das mich wirklich in den Wahnsinn treibt. Artikelbilder die unter Windows im Explorer und jedem Grafikprogramm richtig erscheinen (Hochkant) werden im Shop gedreht, also quer angezeigt. Ich habe die Bilder bereits x-mal gedreht in allen Methoden, Kopien angelegt usw. Der Shop zeigt die Teile immer gleich an. Habe ich eine Chance dem Shop beizubringen die Position korrekt zu erkennen oder kann ich die Bilder im Shop irgendwie bearbeiten und um 90° drehen? (4.1.10). Besten Dank, Manuel
  2. Hallo Zusammen, ich habe seit gestern ein massives Problem mich im Admin-Bereich anzumelden, nachdem unsere PCs ein Windows Update bekommen haben. Selbst die Deinstallation der Updates hat nichts gebracht. Ältere PCs können sich jedoch im Admin-Bereich anmelden. Das ganze ist zudem Shopübergreifend. Ich habe vier separate Installationen im Einsatz. Überall das selbe Problem. Die Sessions-Tabelle habe ich schon geleert. Ebenso den Cache über den Admin-Bereich (von einem funktionierenden PC). Bis Freitag lief alles problemlos. Hoffe mir kann jemand helfen Browser: FireFox 26 OS: Windows 7 - 64 - Ult. Shop: XTC Veyton 4.1.0 PHP: 5.3.27 MySQL: 5.5.34
  3. Hallo, Ich habe ein Problem mit der Installation von XTC. Wie in der Anleitung habe ich nun den kompletten XTCommerce Ordner entpackt und auf den Webserver geladen. Schreibrechte wurden auch gesetzt. Wenn ich jetzt versuche den Installer aufzurufen bekomme ich ich nur eine wei?e Seite angezeigt. Keine Fehlermeldung wie erwartet. Ich habe hier ja schon in einigen Beitr?gen gelesen das es mit einem Windows Server mit IIS und Plesk Probleme geben soll. Dort habe ich gelesen das man diverse Variablen $_Server['DOCUMENT_ROOT'] durch $_Server['VirtualDocumentRoot'] gegeneinander austauschen soll. Leider wurde nirgends beschrieben in welchen Dateien diese ?nderungen vorgenommen werden sollen und um wieviele ?nderungen es geht, damit man alle nach einander abarbeiten kann. Es w?re nett wenn sich jemand bereit erkl?ren w?rde mir dabei ein wenig zu helfen. Damit ich das Problem in den Griff bekomme. Vielen Dank schon mal daf?r im vorraus. Gru? Happy30
  4. Hallo, nachdem ich gestern ionCube erfolgreich auf Xampp installiert habe, bekomme ich nun meinen veyton-shop zwar installiert, aber nicht geöffnet. Fehlermeldungen siehe Thread von gestern ganz unten (worauf leider niemand gepostet hat, deswegen mein Versuch mit neuem Thread) http://www.xt-commerce.com/forum/fragen-zur-software/79377-installationspfad-wirft-leere-seite-aus.html#post363319 Irgendetwas stört die ganze xt Software an meinem neuen Rechner. Kann es am 64bit System liegen, oder an der PHP-Version 5.3 ? Liebe Grüße, Sandra
  5. Hallo, wir haben Veyton auf Windows Server 2003 (XAMPP-Umgebung) installiert und haben das Problem, dass freie Downloads (als Attachment zu Artikeln, z.B. Datenblätter) nicht heruntergeladen werden. Stattdessen kommt eine weiße Seite. Ich habe jetzt hier im Forum geforscht und gelesen, dass die freien Downloads auf Basis von SymLinks gemacht werden - geht das unter Windows überhaupt? Muss ich da jetzt was umprogrammieren in class.download.php oder gibt es eine schrecklich einfache Lösung für Windows Server 2003, die ich nicht bedacht habe? Grüße Thorsten
  6. Guten Abend, ich habe ein Problem XT Commerce auf einem VPS mit Windows und Plesk zum Laufen zu bringen. Habe auch schon die Suche sowie Google benutzt, nur leider keine Lösung gefunden. Die Installationsroutine von XT Commerce lief erst gar nicht, dann habe ich die application.php modifiziert und dann kam ich zur ersten Seite der Installation, aber beim Datenbankimport kam die Fehlermeldung mit dem timeout, daraufhin habe ich in der php.ini den wert "max_execution_time" auf false gesetzt, danach kam ein anderer fehler von fastcgi Dann habe ich meine Daten vom meinem lokalen Rechner mit xampp genommen, die Daten sowie die Datenbank importiert. Und die configure.php angepasst, aber es läuft nicht. Folgender Fehler erscheint: Ich habe dann nochmal ein unverändertes XTCommerce 3.04SP2.1 genommen und habe versucht nach dieser Anleitung hier im Forum vorzugehen, aber die Zeilenangaben passen irgendwie nicht: Ich habe keine Idee mehr, vielleicht könnt ihr mir helfen. Ich ahbe Danke euch schon mal. LG Basti
  7. Hallo, ich habe diese Anleitung gesehen und die Rechte auf einem Windows Dateiserver entsprechend gesetzt. Ich weiß nicht wie z. B. ein Apache Webserver das macht aber bei Windows werden Rechte i. d. R. auf die Unterordner vererbt. Die Anleitung ist also in der Richtung verwirrend da einige Ordner genannt werden die aus darüber liegenden Ordnern automatisch schon Schreibrechte bekommen haben. Was ist mit den Unterordnern die nicht genannt sind ? Soll man bei denen einzeln die Schreibrechte entfernen ? 2. Behauptet der installierte Shop nun hartnäckig die includes/configure.php wäre nicht geschützt da in die Datei schreiben kann. Das kann der XTC gerne probieren aber mein Webserver sagt mit unter Berechtigungen eindeutig das der WEB-User in Windows keine Schreibrechte hat. Sogar die Rechte explizit auf "Verweigern" zu setzen bringt XTC nicht dazu von seiner Meinung ich hätte ein mögliches Sicherheitsrisiko ab. Gibt es dazu schon eine Möglichkeit die Rote Meldung abzuschalten ? Gibt es vielleicht eine aktuellere Anleitung zu XTC Rechten vielleicht auch speziell für Windows-Server ? Viele Grüße Basti __________________________________________________________ "Folgende Rechte m?ssen Sie nun vergeben: Verzeichnis Rechte Zweck /cache 777 Cache Dateien von Smarty /templates_c 777 Smarty Verzeichnis /images 777 Bilderverzeichnis /images/content 777 Bilder aus Spaw Editor /images/product_images/info_images 777 Info-Bilder /images/product_images/original_images 777 Original-Bilder /images/product_images/popup_images 777 Popup-Bilder /images/product_images/thumbnail_images 777 Thumbnail-Bilder /media/content 777 Dateien aus Content-Manager /media/products 777 Dateien aus Produkt-Manager /admin/backups 777 Datenbank Backups /admin/images/icons 777 Kundengruppen Icons /admin/rss 777 Dateien aus Admin Info Datei Rechte Zweck /includes/configure.php 777 Konfigurationsdatei Shop /includes/configure.org.php 777 Backup der Konfiguration /admin/includes/configure.php 777 Konfigurationsdatei Admin /admin/includes/configure.org.php 777 Backup der Konfiguration Anmerkung: Rechte 777 bedeutet Lesen/Schreiben/Ausf?hren f?r Besitzer/Gruppe/Andere."
  8. Für die Installation des IonCube zur Entschlüsselung der Dateien von xt:VEYTON benötigt man: - aktuelle XAMPP- Version (http://www.apachefriends.org/de/xampp-windows.html) - den aktuellen IonCube Loader für Windows (http://www.ioncube.com/loaders.php) - Das xt:VEYTON Server-Testscript (http://www.xt-commerce.com/forum/showthread.php?t=65387) Installation: 1. APACHE server ggf. installieren 2. IonCube Loader Ordner in das XAMPP Verzeichnis kopieren (*LAUFWERK*:\*PFAD*\XAMPP\) 3. php.ini Datei editieren: (*LAUFWERK*:\*PFAD*\XAMPP\apache\bin\php.ini) 3.1. Suchhe nach: [Zend] 3.2. Danach (direkt als 1.Zeile nach [Zend]) folgende Zeile einfügen und anpassen: zend_extension_ts = "*LAUFWERK*:*PFAD*\ioncube\ioncube_loader_win_5.2.dll" 3.3. Sche nach: zend_optimizer.enable_loader = 0 Ersetzen mit: zend_optimizer.enable_loader = 1 4. Apache-Server neu Starten. 5. xt:VEYTON Server Test Script in das Document Root (htdocs) entpacken und im Browser ausführen.
  9. Hallo zusammen, ich entwickle für einen Kunden ein Webportal indem unter anderem xtc als Shopsoftware eingesetzt wird. Die Architektur Windows 2003 Server R2, Apache2.2.x, php5.2.x als mod_php Innerhalb dieser Konfiguration ist allerdings die Datumsanzeige die über function xtc_date_long( ) erzeugt wird nicht nutzbar. Da die Direktive setlocale,die in den lang.php Dateien gesetzt wird, nicht für den Thread in dem das Skript läuft sondern für den gesamten Prozess (indem mehrere Threads laufen)wirkt, kann und kommt es vor, dass das Datumsformat einer anderen Sprache (also z.B. Sprache Deutsch ausgewählt, aber Wochentag und Monatsname in Englisch) ausgegeben wird. Nach bisherigen Tests kommt das in bis zu 30% Aufrufe von xtc_date_long vor. Dieses Phänomen ist auch so in der PHP Doku beschrieben. Da eine Änderung der Systemarchitektur nicht in Frage kommt (Apache with prefork oder php als cgi) bleibt wohl (bis php6 dann soll setlocale auch in multithreaded umgebungen laufen) erst mal keine andere Lösung als Datumsanzeigen mit Wochentag und Monatsnamen per Skript abhängig von der $_SESSION['language'] zusammen zusetzen.
  10. Hallo Gemeinde, wir ziehen in betracht das wir uns einen XT commerce Shop zulegen. Aufgrund der Suchmaschinen Taktik sind natürlich "reale URLS" anzustreben. Aufgrund der Tatsache das wir einen wechsel auf ein Linux System oder Apache nicht in erwägung ziehen beschäftige ich mich gerade damit mittel "ISAPIREWRITE" dies vom Apache zu emulieren. Für Typo3 funktioniert das auch tadellos. Wie sieht es hier mit XTC aus? Gibt es hierfür auch Rules für ISAPIREWRITE? Gruß Christian
  11. Moin, Warning: main(/shop/Index.phpincludes/classes/boxes.php): failed to open stream: No such file or directory in C:\Inetpub\vhosts\xxxxxxxxx.de\httpdocs\shop\xtc_installer\includes\application.php on line 36 Fatal error: main(): Failed opening required '/shop/Index.phpincludes/classes/boxes.php' (include_path='.;./includes;./pear') in C:\Inetpub\vhosts\xxxxxxxxxxx.de\httpdocs\shop\xtc_installer\includes\application.php on line 36 folgende Fehlermeldungen bekomme ich wenn ich den xtc_installer aufrufe, bin auch schon so weit das Index.phpincludes natürlich Blödsinn ist, habe dann in der configure einiges ausprobiert ( siehe folgendes Zeilen ) und bekomme dann aber andere Fehlermeldungen... define('HTTP_SERVER', 'http://xxxxxxxxxxx.de'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', 'https://xxxxxxxxxxx.de'); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? define('DIR_WS_CATALOG', 'C:\Inetpub\vhosts\xxxxxxxxxxx.de\httpdocs\shop\'); define('DIR_FS_DOCUMENT_ROOT', 'C:\Inetpub\vhosts\xxxxxxxxxxx.de\httpdocs\shop\'); define('DIR_FS_CATALOG', 'C:\Inetpub\vhosts\xxxxxxxxxxx.de\httpdocs\shop\'); Da das ganze nachher auf einem windows server laufen soll, bin ich mir bei den Pfadanangaben in der configure auch nicht ganz sicher ob sich / und \ da so einfach vertragen... ist version 304sp2.1 Bin für jede Hilfe dankbar
  12. Hallo, ich kriege die Fehlermeldung auf einem Windows 2003 (Apach 2.2 / PHP5) System: Warnung: XT-Commerce kann in die Konfigurationsdatei schreiben: /includes/configure.php. Das stellt ein mögliches Sicherheitsrisiko dar - bitte korrigieren Sie die Benutzerberechtigungen zu dieser Datei! Die Warnung ist schlicht weg falsch, die Berechtigung ist nur auf lesen gesetzt. Ich nehme an, dass das Skript nur unfähig ist, die Berechtigung unter NTFS richtig zu lesen. Was kann ich tun? Der Versuch security_check.php zu editieren schlug leider fehl. Mit freundlichen Grüßen Tarsinion
  13. Hallo! Ich habe eine algemeine Frage: Gibt es überhaupt eine Windows-Server-Konfiguration, wo XTC produktionsmessig vernüftig läuft? Warum findet man (ich mindestens) keine Info dazu? Basis: Windows2003 - IIS oder apache(2) für Win? - PHP: CGI oder ISAPI? Oder sind die Fagen sinnlos und XTC funzt nur unter Linux? Danke!
  14. Habe ein Problem dies Betrifft die Shop Installation unter Windows: Der aktuelle Shop läuft auf einem Linux Server, da wir aber ein Redesign machen und die ganze Site neu aufbauen läuft nun alles unter Windows. Shop konnte ich installieren, auch wenn er bei Schritt 7 nicht mehr weiter ging (?). Shop läuft nun auch soweit, nur kann ich auf keinen Produktlink klicken und anmelden kann ich mich auch nicht. Kann mir jemand helfen?? Danke. Shop: http://new.xundheit.ch/shop
  15. hallo. hat jemand lust und zeit, uns den xtcommerce auf einem windows rechner mit IIS 6.0 zu installieren. die install läuft bei uns durch, ohne fehler, aber nach der install ist weder ein shop sichtbar noch ein login möglich. bitte pauschalpreis offerieren oder stundenansatz < 50 euro. meldet euch bei mir unter ctek (at) ctek.ch. danke
  16. Hallo, ich habe da mal ein Problem. Ich habe jetzt einen Root Server bei Server4You und zwar ein Windows Server. Nun soweit so gut ich habe auch soweit alles eingestellt und und eine Domain angelegt wo ich per FTP auch meine XTC Shop Daten raufgeschoben habe und zum Problem bei der Installation von XTC kommt folgende meldung. Warning: main(/includes/classes/boxes.php): failed to open stream: No such file or directory in C:\Inetpub\vhosts\lillesam.de\httpdocs\xtc_installer\includes\application.php on line 36 Fatal error: main(): Failed opening required '/includes/classes/boxes.php' (include_path='.;./includes;./pear') in C:\Inetpub\vhosts\lillesam.de\httpdocs\xtc_installer\includes\application.php on line 36 if (!defined('DIR_FS_DOCUMENT_ROOT')) { define('DIR_FS_DOCUMENT_ROOT', $_SERVER['DOCUMENT_ROOT']); $local_install_path=str_replace('/xtc_installer','',$_SERVER['PHP_SELF']); $local_install_path=str_replace('index.php','',$local_install_path); $local_install_path=str_replace('install_step1.php','',$local_install_path); $local_install_path=str_replace('install_step2.php','',$local_install_path); $local_install_path=str_replace('install_step3.php','',$local_install_path); $local_install_path=str_replace('install_step4.php','',$local_install_path); $local_install_path=str_replace('install_step5.php','',$local_install_path); $local_install_path=str_replace('install_step6.php','',$local_install_path); $local_install_path=str_replace('install_step7.php','',$local_install_path); $local_install_path=str_replace('install_finished.php','',$local_install_path); define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . $local_install_path); } if (!defined('DIR_FS_INC')) define('DIR_FS_INC', DIR_FS_CATALOG.'inc/') [/HTML] was ist da bloß falsch ich tippe mal ganz stark das es was mit dem Windows Server zu tun hat. Danke für eure Tipps MFG Gunnar
  17. Hallo Freunde, habe ein Problem und "fast" keine Ahnung. Habe mittels FTP die Shop Daten auf den Server ?bertragen. Kriege aber eine Fehlermeldung bei der Installation: Fatal error: main(): Failed opening required '/shop/includes/classes/boxes.php' (include_path='.;c:\php4\pear') in D:\Inetpub\xxxxxx-xxxxxx.de\web\shop\xtc_installer\includes\application.php on line 36 Kann mir jemand vieleicht helfen? Den ISS kann und will ich nicht deaktivieren. (Ist halt in Gebrauch.) Muss es mit "Eurer" Hilfe auch so hinkriegen. W?rde mich ?ber Hilfe riesig freuen. Gr?sse Easy
  18. Hallo an alle, heute habe ich xt:Commerce unter Windows 2003 Server installiert, hat soweit gut geklappt, Installation lief ohne Fehler durch. Beim Aufruf des Frontends und des Backend erhalte ich nun folgende Fehler, bei dem ich nicht weiss, was ich da tun soll: Warning: Smarty::fetch(templates_c\%%C8^C87^C87668D7%%index.html.php) [function.fetch]: failed to open stream: No such file or directory in ...\xtcommerce\includes\classes\Smarty_2.6.10\Smarty.class.php on line 1258 Ist das ein Fehler aufgrund eines falschen Eintrages in der configure.ini? Wenn ja, welchen Eintrag muss ich ?ndern/anpassen? Ich bin f?r jeden Tipp dankbar. Ich verwende PHP 5.03, MySQL 4.13, Windows 2003 Server
  19. Fehlermeldung: Warning: main(/php/xtcommerce/includes/classes/boxes.php): failed to open stream: No such file or directory in c:\inetpub\wwwroot\php\xtcommerce\xtc_installer\includes\application.php on line 36 Fatal error: main(): Failed opening required '/php/xtcommerce/includes/classes/boxes.php' (include_path='.;c:\php4\pear') in c:\inetpub\wwwroot\php\xtcommerce\xtc_installer\includes\application.php on line 36 Ansonsten l?uft PHP perfekt auf meiner Maschine. L?sung: Der Fehler kommt daher, dass die Variable $_SERVER['DOCUMENT_ROOT'] nicht exisitert, was man einfach ?berpr?fen kann, indem man sich das ganze Array mit "print_r ($_Server)" auf dem Bildschirm ausgeben l?sst. Daher einfach vor der Zeile (in applikation.php im admin/include- Verzeichnis) define('DIR_FS_DOCUMENT_ROOT', $_SERVER['DOCUMENT_ROOT']); die folgende Zeile einf?gen $_SERVER['DOCUMENT_ROOT']='serverroot'; wobei f?r 'serverroot' das Root-Verzeichnis des Webservers, also beispielsweise 'c:/inetpub/' einzuf?gen w?re. So funktioniert es einwandfrei - und anders nie und nimmer... !!! Wichtig: bei der Installation darauf achten, dass auch die Gro?/Kleinschreibung bei den Pfad- und Laufwerksangaben stimmen 'D:/web-data/xtshop/' oder 'd:/web-data/xtshop/' Verzeichnisse "include" in der root und im Verzeichnis "admin" den Schreibschutz rausnehmen und vollzugriff f?r "jeder" gestatten (!!! Achtung, ich min mir nicht sicher). im rootverzeichnis ein Unterverzeichnis "tmp" anlegen. in der Datenbank in der Tabelle "configuration" den Eintrag "\tmp" finden und ersetzen gene "tmp"
  20. Hallo, ich hab ein D900 und versuche Windows XP 64bit zu installieren. Aber irgendwie klappt das nicht. Ich bekomme immer die Meldung das ich ACPI im Bios aktivieren soll... Wo steht das denn? Find nix Hat jemand ne Idee wie ich das Teil zum laufen bekomme :sad: ??
  21. Hallo! Zu Testzwecken wollte ich die Version 2 mal unter Windows XP (mit installiertem PHP) installieren. Funktioniert das ?berhaupt? Ich bekommen n?mlich Fehlermeldungen beim Aufruf von xt_installer... Danke f?r Eure Hilfe!
  22. Hallo zusammen, Ich bin ganz neu hier. Ich habe mir die Version 2 heruntergeladen,und habe folgendes Problem: Ich habe die Zip-Datei entpackt und auf meinen Server hochgeladen. wenn ich jetzt die Installation starten m?chte kommt folgende Fehlermeldung: IISPassword The page cannot be displayed There is a problem with the page youare trying to reach and it cannot be displayed. It is most likely that configuration files for this url are corrupted. -------------------------------------------------------------------------------- Please try the following: Click the Refresh button, or try again later. Open the home page, and then look for links to the information you want. If you believe you should be able to view this directory or page, please contact the Web site administrator by using the e-mail address or phone number listed on the home page. HTTP Error 500 IISPassword for Internet Information Services -------------------------------------------------------------------------------- ? IISPassword Info kann mir da irgendjemand weiterhelfen??? Ich habe ?brigens einen Windows-Server falls dass was ausmacht. Viele Gr??e Michael
  23. Hi Leute, bisher hatte ich immer mit OS-Commerce meinen Shop verwaltet, aber da waren nun einige Bugs drin und von der Funktionalit?t sagt es mir auch nicht wirklich zu. Nun wollte ich fragen, ob es f?r dieses erweiterte System eine Windows Oberfl?che gibt, wo man die Produkte erstellen und hochlanden kann?? Nat?rlich in xt-commerce rein Gruss Bj?rn
  24. Habe ein Windows Server und m?chte gerne ein instal von Shop machen bekomme keine Seite zusehen. Was mache falsch muss ich noch was machen .Es ist ein neuer Root Server. Habe alles per Ftp rauf geschoben. PHP mysql l?uft
  25. Hallo Leute, isses nur bei mir so oder ist das generell ?? Ich habe den Shop auf Grund der Gr??e nicht erst runtergeladen und dann per FTP wieder hochgeladen (dabei wird normalerweise jede ASCII Datei automatisch Unix encoded, daher d?rfte es den meisen auch nicht auffallen), sondern direkt per wget auf den Server kopiert und entpackt. Dabei ist mir aufgefallen, da? alle Dateien Windows encoded sind (erkennbar an den "^M" an jedem Zeilenende. Egal ob ich per TAR oder per MC (Midnight Commander) entpacke, die Windows Steuerzeichen sind drin. Es sieht so aus, als wenn das TAR Archiv einfach aus dem ZIP Archiv erstellt wurde. (Das ist insofern doof, da dies beim Download einzelner Dateien zwecks Anpassung die Struktur diese zerst?rt und nach dem Wiederhochladen teilweise nix mehr funktioniert.) Wie kann ich am besten alles auf Unix umcodieren, ohne das Ganze nochmal per FTP hochladen zu m?ssen ?? Da? es nicht an meinem Server oder dessen Einstellungen liegt, sehe ich daran, da? andere Pakete (u.A. auch oscommerce) richtig codiert vorliegen (ZIP als Win und TAR als Unix Code). Gru? Outi
×
×
  • Create New...