Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'wysiwyg'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 4 results

  1. Hallo zusammen. Ich setze meinen ersten xtc v3.0.4 SP2.1 Shop auf. Wo kann ich den WYSIWYG Editor für die Artikelbeschreibung einschalten? Danke im voraus.
  2. Es ist zwar eine Notlösung den ganz zu deaktivieren, aber eine Lösung des Problems ist das auf Dauer wohl nicht. Weiss denn irgendwer ob da was in Aussicht ist? Oder muss ich mir deshalb nen PC kaufen?
  3. Hallo miteinander! Irgendwie habe ich beim letzen Male den Editor zerschossen...., ich möchte im Bereich " Kategorien" was ändern, es zeigt sich allerdings nur der HTML-Editor. Habe von HTML keine Ahnung, ich möchte bequem Text schreiben, ohne HTML Gedöns. Ich finde auch keinen "Knopf" um das Teil umzustellen. Frage: Wie bekomme ich meinen WYSIWYG Editor wieder???? Bin für jede Idee dankbar!
  4. Hallo, ich versuche gerade einen neuen WYSIWYG Editor im Admin Interface einzubauen, da der alte Fehlerhaft ist und nicht alles korrekt ausführt. Ich möchte den InnovaEditor nutzen. Leider komme ich einfach nicht weiter. Hier mein Versuch(xtc_wysiwyg.inc.php): $js_src = "http://www.xtadmin.de/xtc/editor/script/innovaeditor.js"; switch($type) { // WYSIWYG editor content manager textarea named cont case 'content_manager': $val ='<script type="text/javascript" src="'.$js_src.'"></script>'; break; case 'content_manager1': $val ='<script type="text/javascript"> window.onload = function() { var oEdit = new InnovaEditor("oEdit"); oEdit.width="100%"; oEdit.height=550; oEdit.features=["FullScreen","Preview","Print", "Search","SpellCheck","|", "Superscript","Subscript","|","LTR","RTL","|", "Table","Guidelines","Absolute","|", "Flash","Media","|", //"InternalLink","CustomObject","|", "Form","Characters","ClearAll", //"XHTMLFullSource", "XHTMLSource","BRK", "Cut","Copy","Paste","PasteWord","PasteText","|", "Undo","Redo","|","Hyperlink","Bookmark","Image","|", "JustifyLeft","JustifyCenter","JustifyRight","JustifyFull","|", "Numbering","Bullets","|","Indent","Outdent","|", "Line","RemoveFormat","BRK", "StyleAndFormatting","TextFormatting","ListFormatting", "BoxFormatting","ParagraphFormatting","CssText","Styles","|", //"CustomTag", "Paragraph","FontName","FontSize","|", "Bold","Italic","Underline","Strikethrough","|", "ForeColor","BackColor"]; oEdit.css="'.$css_src.'"; oEdit.cmdAssetManager = "modalDialogShow(\''.$manager.'\',640,465)"; //Command to open the Asset Manager add-on. oEdit.cmdInternalLink = "modelessDialogShow(\'links.htm\',365,270)"; //Command to open your custom link lookup page. oEdit.cmdCustomObject = "modelessDialogShow(\'objects.htm\',365,270)"; //Command to open your custom content lookup page. oEdit.arrCustomTag=[["First Name","{%first_name%}"], ["Last Name","{%last_name%}"], ["Email","{%email%}"]];//Define custom tag selection oEdit.customColors=["#ff4500","#ffa500","#808000","#4682b4","#1e90ff","#9400d3","#ff1493","#a9a9a9"];//predefined custom colors oEdit.mode="XHTMLBody"; //Editing mode. oEdit.REPLACE("cont"); } </script>'; break; }[/PHP] Ich habe hier 2 case machen müssen, der eine wird im HEAD geladen und der zweite muß nach der TEXTAREA geladen werden. Leider wird er nicht angezeigt! Wenn ich die Zeile window.onload = function() { aus kommentiere dann ist er endlich da, aber das ist ja nicht der Sinn! Bei den Alten FCKEditor ist die window.onload = function() { auch vorhanden. Meine Speicherung nimmt er auch nicht an. Hier mein Versuch(html_output.php): [PHP]function xtc_draw_textarea_field($name, $wrap, $width, $height, $text = '', $params = '', $reinsert_value = true) { $field = '<textarea id="'.$name.'" name="' . $name . '" wrap="' . $wrap . '" cols="' . $width . '" rows="' . $height . '"'; if ($params) $field .= ' ' . $params; $field .= '>'; /* function encodeHTML($sHTML) { $sHTML=ereg_replace("&","&",$sHTML); $sHTML=ereg_replace("<","<",$sHTML); $sHTML=ereg_replace(">",">",$sHTML); return $sHTML; } if(isset($text)) { $sContent=stripslashes($text); $text .= encodeHTML($sContent); } */ if ( ($GLOBALS[$name]) && ($reinsert_value) ) { $field .= $GLOBALS[$name]; } elseif ($text != '') { $field .= $text; } $field .= '</textarea>'; return $field; }[/PHP] Habe beide Varianten probiert, aber nichts... Kann mir vielleicht jemand weiterhelfen, damit ich es endlich zum laufen bekomme! Vielen Dank
×
  • Create New...